Statistics.Statistics

An NDoc Documented Class Library

Statistics.Statistics Namespace

Namespace hierarchy

Classes

Class | Description
Statistics | Class: Statistics Class is a univariate statistics and probability class for one dimensional arrays

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Statistics Class

Class: Statistics Class is a univariate statistics and probability class for one dimensional arrays

For a list of all members of this type, see Statistics Members.

System.Object
Statistics.Statistics.Statistics

public class Statistics

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

License: Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems and Economic Analytics, Limited 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 Financial.Seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is free software; you can redistribute it and/or modify it under the terms of the GNU Lesser General Public License as published by the Free Software Foundation; either version 2.1 of the License, or (at your option) any later version. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU Lesser General Public License for more details. You should have received a copy of the GNU Lesser General Public License along with this library; if not, write to the Free Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA Please email changes and enhancements to Financial.Seal@cox.net include name and email for developer recognition.

Example

public statistics as new statistics.statistics

Requirements

Namespace: Statistics.Statistics

Assembly: Statistics (in Statistics.dll)

See Also

Statistics Members | Statistics.Statistics Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Statistics Members

Statistics overview

Public Instance Constructors

Statistics Constructor Initializes a new instance of the Statistics class.

Public Instance Methods

average | Method: Average - Finds the average or mean value of a one dimensional array
CND | Method: CND - Better Normal distribuion CDF
CumNorm | Method: CumNorm - Normal distribuion CDF
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
inverseNormal | Method: InverseNormal - Inverse of a standard normal variate
max | Method: Max - Finds the maximum value in a one dimensional array
min | Method: Min - Finds the minimum value in a one dimensional array
Normal_Prob | Method: Normal_prob - Normal distribuion PDF
STDDEVP | Method: STDDEVPp - Finds the population standard deviation of a one dimensional array
STDDEVS | Method: STDDEVSp - Finds the sample standard deviation of a one dimensional array
Tau3 | Method: Tau3 - L-moment rank order statistics
ToString (inherited from Object) | Returns a String that represents the current Object.
variancep | Method: Variancep - Finds the population variance of a one dimensional array
variances | Method: Variancep - Finds the sample variance of a one dimensional array

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Statistics Class | Statistics.Statistics Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Statistics Constructor

Initializes a new instance of the Statistics class.

public Statistics();

See Also

Statistics Class | Statistics.Statistics Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Statistics Methods

The methods of the Statistics class are listed below. For a complete list of Statistics class members, see the Statistics Members topic.

Public Instance Methods

average | Method: Average - Finds the average or mean value of a one dimensional array
CND | Method: CND - Better Normal distribuion CDF
CumNorm | Method: CumNorm - Normal distribuion CDF
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
inverseNormal | Method: InverseNormal - Inverse of a standard normal variate
max | Method: Max - Finds the maximum value in a one dimensional array
min | Method: Min - Finds the minimum value in a one dimensional array
Normal_Prob | Method: Normal_prob - Normal distribuion PDF
STDDEVP | Method: STDDEVPp - Finds the population standard deviation of a one dimensional array
STDDEVS | Method: STDDEVSp - Finds the sample standard deviation of a one dimensional array
Tau3 | Method: Tau3 - L-moment rank order statistics
ToString (inherited from Object) | Returns a String that represents the current Object.
variancep | Method: Variancep - Finds the population variance of a one dimensional array
variances | Method: Variancep - Finds the sample variance of a one dimensional array

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Statistics Class | Statistics.Statistics Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Statistics.average Method

Method: Average - Finds the average or mean value of a one dimensional array

public double average(
ref double[] x
);

Parameters

x
Passed one dimensional array

Return Value

value as Double

Example

y=statistics.average(x)

See Also

Statistics Class | Statistics.Statistics Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Statistics.CND Method

Method: CND - Better Normal distribuion CDF

public double CND(
double z
);

Parameters

z
normal CDF value

Return Value

value as Double

Remarks

Cumulative normal probability. More accurate cumulative normal to 10 decimal places, provide by my friend Matt Suhr.

Example

d=statistics.cnd(z)

See Also

Statistics Class | Statistics.Statistics Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Statistics.CumNorm Method

Method: CumNorm - Normal distribuion CDF

public double CumNorm(
double z
);

Parameters

z
normal CDF value

Return Value

value as Double

Remarks

Cumulative normal probability. Basic algorithm from all derivative finance textbooks.

Example

d=statistics.cumnorm(z)

See Also

Statistics Class | Statistics.Statistics Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Statistics.inverseNormal Method

Method: InverseNormal - Inverse of a standard normal variate

public double inverseNormal(
double uniformRandVar
);

Parameters

uniformRandVar
standard normal random variate

Return Value

value as Double

Example

d=statistics.inversenormal(uniformrandvar)

See Also

Statistics Class | Statistics.Statistics Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Statistics.max Method

Method: Max - Finds the maximum value in a one dimensional array

public double max(
ref double[] x
);

Parameters

x
Passed one dimensional array

Return Value

value as Double

Example

y=statistics.max(x)

See Also

Statistics Class | Statistics.Statistics Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Statistics.min Method

Method: Min - Finds the minimum value in a one dimensional array

public double min(
ref double[] x
);

Parameters

x
Passed one dimensional array

Return Value

value as Double

Example

y=statistics.min(x)

See Also

Statistics Class | Statistics.Statistics Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Statistics.Normal_Prob Method

Method: Normal_prob - Normal distribuion PDF

public double Normal_Prob(
double z
);

Parameters

z
z value

Return Value

value as Double

Example

d=statistics.normal_prob(z)

See Also

Statistics Class | Statistics.Statistics Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Statistics.STDDEVP Method

Method: STDDEVPp - Finds the population standard deviation of a one dimensional array

public double STDDEVP(
ref double[] x,
ref double avg
);

Parameters

x
Passed one dimensional array
avg
passed average value of one dimensional array

Return Value

value as Double

Example

avgx=statistics.average(x) y=statistics.stddevp(x,avgx)

See Also

Statistics Class | Statistics.Statistics Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Statistics.STDDEVS Method

Method: STDDEVSp - Finds the sample standard deviation of a one dimensional array

public double STDDEVS(
ref double[] x,
ref double avg
);

Parameters

x
Passed one dimensional array
avg
passed average value of one dimensional array

Return Value

value as Double

Example

avgx=statistics.average(x) y=statistics.stddevs(x,avgx)

See Also

Statistics Class | Statistics.Statistics Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Statistics.Tau3 Method

Method: Tau3 - L-moment rank order statistics

public double Tau3(
double[] Y,
ref object Risk
);

Parameters

Y
array for calculation L-moment rank order statistics
Risk
risk structure for returning rank order statistics

Return Value

value as Double

Remarks

Hoskins L-Moment Tau Statistics Must define the structure in the example before using

Example

Public Structure RiskAdjStruct Dim M, L As Array 'B(2),L(2 To 3) as Array 'As Double Dim Sigma, Tau3, Value As Double End Structure Public risk as riskadjstruct tau3stat=statistics.tau3(Y,risk)

See Also

Statistics Class | Statistics.Statistics Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Statistics.variancep Method

Method: Variancep - Finds the population variance of a one dimensional array

public double variancep(
ref double[] x,
ref double avg
);

Parameters

x
Passed one dimensional array
avg
passed average value of one dimensional array

Return Value

value as Double

Example

avgx=statistics.average(x) y=statistics.variancep(x,avgx)

See Also

Statistics Class | Statistics.Statistics Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Statistics.variances Method

Method: Variancep - Finds the sample variance of a one dimensional array

public double variances(
ref double[] x,
ref double avg
);

Parameters

x
Passed one dimensional array
avg
passed average value of one dimensional array

Return Value

value as Double

Example

avgx=statistics.average(x) y=statistics.variances(x,avgx)

See Also

Statistics Class | Statistics.Statistics Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Statistics.StatisticsHierarchy

An NDoc Documented Class Library

Statistics.Statistics Hierarchy

System.Object
Statistics.Statistics.Statistics

See Also

Statistics.Statistics Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net