SimCalendar

An NDoc Documented Class Library

SimCalendar Namespace

Namespace hierarchy

Classes

Class | Description
simcalendar | Class: Simcalendar class is a class to created simulation data structure for a valuing derivatives.

Structures

Structure | Description
simcalendar.holidays | Structure: Holidays /Expiration calendar structure for forward curves
simcalendar.simcalendar | Structure: simcalendar - calendar structure for simcalendar class

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


simcalendar Class

Class: Simcalendar class is a class to created simulation data structure for a valuing derivatives.

For a list of all members of this type, see simcalendar Members.

System.Object
SimCalendar.simcalendar

public class simcalendar

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

License: Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems and Economic Analytics, Limited 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 Financial.Seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is free software; you can redistribute it and/or modify it under the terms of the GNU Lesser General Public License as published by the Free Software Foundation; either version 2.1 of the License, or (at your option) any later version. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU Lesser General Public License for more details. You should have received a copy of the GNU Lesser General Public License along with this library; if not, write to the Free Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA Please email changes and enhancements to Financial.Seal@cox.net include name and email for developer recognition. Notes: only daily works, need to build monthly hourly yearly qtrly

Example

            create a simulation calendar
        Public simcal As New SimCalendar.simcalendar

            must set dates before assigning type so the calendar struct can be redimensioned
         simcal.firstdate = storage_dynamic.dates.transactiondate
         simcal.lastdate = storage_static.enddate
         simcal.caltype = "Daily"
         simcal.holiday = curve.holiday 'must be set before or the holidays are left as nothing
         simcal.commodityType = "NG"
         simcal.setLastTradeDate()
         simcal.setSeasons()

Requirements

Namespace: SimCalendar

Assembly: SimCalendar (in SimCalendar.dll)

See Also

simcalendar Members | SimCalendar Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


simcalendar Members

simcalendar overview

Public Instance Constructors

simcalendar Constructor Initializes a new instance of the simcalendar class.

Public Instance Fields

m_simcal Property: m_simcal - module level variable of simacalendar structure

Public Instance Properties

caltype | Property: caltype module level variable of calendar type Options are: Daily, Hourly, Weekly, Monthly, Quarterly, Yearly ONLY DAILY WORKS AT THIS TIME
commodityType | Property: m_commodityType - specifies commodity for calendar and seasons Commodity Type based on Nymex Futures Commodity Codes see href="www.nymex.com"
firstdate | Property: firstdate module level variable of start date for calendar
holiday | Property: holiday - structure holding holiday dates
lastdate | Property: lastdate module level variable of last date for calendar

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
setLastTradeDate | Method (public) setLastTradeDate determines the last trading day in a month based on Holidays and weekends from the calendar object. The last day of the month is set to lasttradedate if not called
setSeasons | Method (public) setSeasons sets the season of the simcalendar object uses lasttradeday of a month for end of season roll.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

simcalendar Class | SimCalendar Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


simcalendar Constructor

Initializes a new instance of the simcalendar class.

public simcalendar();

See Also

simcalendar Class | SimCalendar Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


simcalendar Fields

The fields of the simcalendar class are listed below. For a complete list of simcalendar class members, see the simcalendar Members topic.

Public Instance Fields

m_simcal Property: m_simcal - module level variable of simacalendar structure

See Also

simcalendar Class | SimCalendar Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


simcalendar.m_simcal Field

Property: m_simcal - module level variable of simacalendar structure

public simcalendar[] m_simcal;

See Also

simcalendar Class | SimCalendar Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


simcalendar Properties

The properties of the simcalendar class are listed below. For a complete list of simcalendar class members, see the simcalendar Members topic.

Public Instance Properties

caltype | Property: caltype module level variable of calendar type Options are: Daily, Hourly, Weekly, Monthly, Quarterly, Yearly ONLY DAILY WORKS AT THIS TIME
commodityType | Property: m_commodityType - specifies commodity for calendar and seasons Commodity Type based on Nymex Futures Commodity Codes see href="www.nymex.com"
firstdate | Property: firstdate module level variable of start date for calendar
holiday | Property: holiday - structure holding holiday dates
lastdate | Property: lastdate module level variable of last date for calendar

See Also

simcalendar Class | SimCalendar Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


caltype Property

An NDoc Documented Class Library

simcalendar.caltype Property

Property: caltype module level variable of calendar type Options are: Daily, Hourly, Weekly, Monthly, Quarterly, Yearly ONLY DAILY WORKS AT THIS TIME

public string caltype {get; set;}

See Also

simcalendar Class | SimCalendar Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


commodityType Property

An NDoc Documented Class Library

simcalendar.commodityType Property

Property: m_commodityType - specifies commodity for calendar and seasons Commodity Type based on Nymex Futures Commodity Codes see href="www.nymex.com"

public string commodityType {get; set;}

See Also

simcalendar Class | SimCalendar Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


firstdate Property

An NDoc Documented Class Library

simcalendar.firstdate Property

Property: firstdate module level variable of start date for calendar

public System.DateTime firstdate {get; set;}

See Also

simcalendar Class | SimCalendar Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


holiday Property

An NDoc Documented Class Library

simcalendar.holiday Property

Property: holiday - structure holding holiday dates

public object holiday {get; set;}

See Also

simcalendar Class | SimCalendar Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


lastdate Property

An NDoc Documented Class Library

simcalendar.lastdate Property

Property: lastdate module level variable of last date for calendar

public System.DateTime lastdate {get; set;}

See Also

simcalendar Class | SimCalendar Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


simcalendar Methods

The methods of the simcalendar class are listed below. For a complete list of simcalendar class members, see the simcalendar Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
setLastTradeDate | Method (public) setLastTradeDate determines the last trading day in a month based on Holidays and weekends from the calendar object. The last day of the month is set to lasttradedate if not called
setSeasons | Method (public) setSeasons sets the season of the simcalendar object uses lasttradeday of a month for end of season roll.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

simcalendar Class | SimCalendar Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


simcalendar.setLastTradeDate Method

Method (public) setLastTradeDate determines the last trading day in a month based on Holidays and weekends from the calendar object. The last day of the month is set to lasttradedate if not called

public void setLastTradeDate();

Return Value

Updates Calendar Structure

See Also

simcalendar Class | SimCalendar Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


simcalendar.setSeasons Method

Method (public) setSeasons sets the season of the simcalendar object uses lasttradeday of a month for end of season roll.

public void setSeasons();

Return Value

Updates Calendar Structure

See Also

simcalendar Class | SimCalendar Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


simcalendar.holidays Structure

Structure: Holidays /Expiration calendar structure for forward curves

For a list of all members of this type, see simcalendar.holidays Members.

System.Object
System.ValueType
SimCalendar.simcalendar.holidays

public struct simcalendar.holidays

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: SimCalendar

Assembly: SimCalendar (in SimCalendar.dll)

See Also

simcalendar.holidays Members | SimCalendar Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


simcalendar.holidays Members

simcalendar.holidays overview

Public Instance Fields

contractdate | Variable name="ContractDate" Array for holding expiration dates contract period date values
holiday | Variable name="Holiday" Array for holding holiday/expiration dates

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

simcalendar.holidays Class | SimCalendar Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


simcalendar.holidays Fields

The fields of the simcalendar.holidays structure are listed below. For a complete list of simcalendar.holidays structure members, see the simcalendar.holidays Members topic.

Public Instance Fields

contractdate | Variable name="ContractDate" Array for holding expiration dates contract period date values
holiday | Variable name="Holiday" Array for holding holiday/expiration dates

See Also

simcalendar.holidays Class | SimCalendar Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


simcalendar.holidays.contractdate Field

Variable name="ContractDate" Array for holding expiration dates contract period date values

public DateTime[] contractdate;

See Also

simcalendar.holidays Class | SimCalendar Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


simcalendar.holidays.holiday Field

Variable name="Holiday" Array for holding holiday/expiration dates

public DateTime[] holiday;

See Also

simcalendar.holidays Class | SimCalendar Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


simcalendar.simcalendar Structure

Structure: simcalendar - calendar structure for simcalendar class

For a list of all members of this type, see simcalendar.simcalendar Members.

System.Object
System.ValueType
SimCalendar.simcalendar.simcalendar

public struct simcalendar.simcalendar

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: SimCalendar

Assembly: SimCalendar (in SimCalendar.dll)

See Also

simcalendar.simcalendar Members | SimCalendar Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


simcalendar.simcalendar Members

simcalendar.simcalendar overview

Public Instance Fields

day | name="Day" Day of the month for the transaction date
holiday | name="Holiday" Holiday boolean flag variable
hour | name="Hour" Hour of the day for the transaction date
lastTradeDay | name="lastTradeDay" Last trading day of month boolean flag
month | name="Month" Month of the year date occurs
quarter | name="Quarter" Quarter of the year date occurs
seasonnumber | name="Seasonnumber" Season counter variable
transactiondate | name="Transactiondate" Transaction date variable
weekday | name="Weekday" Weekday name variable
year | name="Year" Year of the transaction date

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

simcalendar.simcalendar Class | SimCalendar Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


simcalendar.simcalendar Fields

The fields of the simcalendar.simcalendar structure are listed below. For a complete list of simcalendar.simcalendar structure members, see the simcalendar.simcalendar Members topic.

Public Instance Fields

day | name="Day" Day of the month for the transaction date
holiday | name="Holiday" Holiday boolean flag variable
hour | name="Hour" Hour of the day for the transaction date
lastTradeDay | name="lastTradeDay" Last trading day of month boolean flag
month | name="Month" Month of the year date occurs
quarter | name="Quarter" Quarter of the year date occurs
seasonnumber | name="Seasonnumber" Season counter variable
transactiondate | name="Transactiondate" Transaction date variable
weekday | name="Weekday" Weekday name variable
year | name="Year" Year of the transaction date

See Also

simcalendar.simcalendar Class | SimCalendar Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


simcalendar.simcalendar.day Field

name="Day" Day of the month for the transaction date

public int day;

See Also

simcalendar.simcalendar Class | SimCalendar Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


simcalendar.simcalendar.holiday Field

name="Holiday" Holiday boolean flag variable

public bool holiday;

See Also

simcalendar.simcalendar Class | SimCalendar Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


simcalendar.simcalendar.hour Field

name="Hour" Hour of the day for the transaction date

public int hour;

See Also

simcalendar.simcalendar Class | SimCalendar Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


simcalendar.simcalendar.lastTradeDay Field

name="lastTradeDay" Last trading day of month boolean flag

public bool lastTradeDay;

See Also

simcalendar.simcalendar Class | SimCalendar Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


simcalendar.simcalendar.month Field

name="Month" Month of the year date occurs

public int month;

See Also

simcalendar.simcalendar Class | SimCalendar Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


simcalendar.simcalendar.quarter Field

name="Quarter" Quarter of the year date occurs

public int quarter;

See Also

simcalendar.simcalendar Class | SimCalendar Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


simcalendar.simcalendar.seasonnumber Field

name="Seasonnumber" Season counter variable

public long seasonnumber;

See Also

simcalendar.simcalendar Class | SimCalendar Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


simcalendar.simcalendar.transactiondate Field

name="Transactiondate" Transaction date variable

public DateTime transactiondate;

See Also

simcalendar.simcalendar Class | SimCalendar Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


simcalendar.simcalendar.weekday Field

name="Weekday" Weekday name variable

public int weekday;

See Also

simcalendar.simcalendar Class | SimCalendar Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


simcalendar.simcalendar.year Field

name="Year" Year of the transaction date

public int year;

See Also

simcalendar.simcalendar Class | SimCalendar Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


SimCalendarHierarchy

An NDoc Documented Class Library

SimCalendar Hierarchy

System.Object
SimCalendar.simcalendar
System.ValueType
SimCalendar.simcalendar.holidays
SimCalendar.simcalendar.simcalendar

See Also

SimCalendar Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net