PositionClass

An NDoc Documented Class Library

PositionClass Namespace

Namespace hierarchy

Classes

Class | Description
Positionclass | Class: Positions class creates a trading book for holding valuation model results and current positions.

Structures

Structure | Description
Positionclass.BookIDStruct | Structure: BookIDStruct structure of curve ids
Positionclass.BookStruct | name="Intrinsic" Array containing simulated positions
Positionclass.PosHeaderStruct | Structure: PosHeaderStruct structure of trading positions attributes
Positionclass.PositionStruct | Structure: PositionStruct structure of trading positions

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Positionclass Class

Class: Positions class creates a trading book for holding valuation model results and current positions.

For a list of all members of this type, see Positionclass Members.

System.Object
CurveClass.CurveClass
PositionClass.Positionclass

public class Positionclass : CurveClass

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

License: Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems and Economic Analytics, Limited 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 Financial.Seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is free software; you can redistribute it and/or modify it under the terms of the GNU Lesser General Public License as published by the Free Software Foundation; either version 2.1 of the License, or (at your option) any later version. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU Lesser General Public License for more details. You should have received a copy of the GNU Lesser General Public License along with this library; if not, write to the Free Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA Please email changes and enhancements to Financial.Seal@cox.net include name and email for developer recognition.

Requirements

Namespace: PositionClass

Assembly: PositionClass (in PositionClass.dll)

See Also

Positionclass Members | PositionClass Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Positionclass Members

Positionclass overview

Public Instance Constructors

Positionclass Constructor Constructor for ExtendedDates Class

Public Instance Fields

book | Property: Book property for positions class
marketcurve (inherited from CurveClass.CurveClass) |

Public Instance Properties

commodityType (inherited from CurveClass.CurveClass)
holiday (inherited from CurveClass.CurveClass)

Public Instance Methods

BookBuild |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
marketbuild (inherited from CurveClass.CurveClass) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Private Instance Methods

readXcelBook

See Also

Positionclass Class | PositionClass Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Positionclass Constructor

Constructor for ExtendedDates Class

public Positionclass();

See Also

Positionclass Class | PositionClass Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Positionclass Fields

The fields of the Positionclass class are listed below. For a complete list of Positionclass class members, see the Positionclass Members topic.

Public Instance Fields

book | Property: Book property for positions class
marketcurve (inherited from CurveClass.CurveClass) |

See Also

Positionclass Class | PositionClass Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Positionclass.book Field

Property: Book property for positions class

public BookStruct book;

See Also

Positionclass Class | PositionClass Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Positionclass Methods

The methods of the Positionclass class are listed below. For a complete list of Positionclass class members, see the Positionclass Members topic.

Public Instance Methods

BookBuild |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
marketbuild (inherited from CurveClass.CurveClass) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Private Instance Methods

readXcelBook

See Also

Positionclass Class | PositionClass Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Positionclass.BookBuild Method

public void BookBuild(
ref object model,
object tdate,
string commoditytype,
long size
);

See Also

Positionclass Class | PositionClass Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Positionclass.readXcelBook Method

private void readXcelBook(
ref object model,
long size
);

See Also

Positionclass Class | PositionClass Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Positionclass.BookIDStruct Structure

Structure: BookIDStruct structure of curve ids

For a list of all members of this type, see Positionclass.BookIDStruct Members.

System.Object
System.ValueType
PositionClass.Positionclass.BookIDStruct

public struct Positionclass.BookIDStruct

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Used when downloading from a database

Requirements

Namespace: PositionClass

Assembly: PositionClass (in PositionClass.dll)

See Also

Positionclass.BookIDStruct Members | PositionClass Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Positionclass.BookIDStruct Members

Positionclass.BookIDStruct overview

Public Instance Fields

Spot name="Spot" Spot price curve id

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

Positionclass.BookIDStruct Class | PositionClass Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Positionclass.BookIDStruct Fields

The fields of the Positionclass.BookIDStruct structure are listed below. For a complete list of Positionclass.BookIDStruct structure members, see the Positionclass.BookIDStruct Members topic.

Public Instance Fields

Spot name="Spot" Spot price curve id

See Also

Positionclass.BookIDStruct Class | PositionClass Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Positionclass.BookIDStruct.Spot Field

name="Spot" Spot price curve id

public string Spot;

See Also

Positionclass.BookIDStruct Class | PositionClass Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Positionclass.BookStruct Structure

name="Intrinsic" Array containing simulated positions

For a list of all members of this type, see Positionclass.BookStruct Members.

System.Object
System.ValueType
PositionClass.Positionclass.BookStruct

public struct Positionclass.BookStruct

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: PositionClass

Assembly: PositionClass (in PositionClass.dll)

See Also

Positionclass.BookStruct Members | PositionClass Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Positionclass.BookStruct Members

Positionclass.BookStruct overview

Public Instance Fields

positions | name="Positions" Structure of PositionStruct
PositionsHeader | name="Positionsheader" Structure of Positions attributes Struct
season | name="Season" Season variable
seasonnumber | name="Seasonnumber" Season counter variable
transactiondate | name="TransactionDate" Transaction Date of the Book

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

Positionclass.BookStruct Class | PositionClass Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Positionclass.BookStruct Fields

The fields of the Positionclass.BookStruct structure are listed below. For a complete list of Positionclass.BookStruct structure members, see the Positionclass.BookStruct Members topic.

Public Instance Fields

positions | name="Positions" Structure of PositionStruct
PositionsHeader | name="Positionsheader" Structure of Positions attributes Struct
season | name="Season" Season variable
seasonnumber | name="Seasonnumber" Season counter variable
transactiondate | name="TransactionDate" Transaction Date of the Book

See Also

Positionclass.BookStruct Class | PositionClass Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Positionclass.BookStruct.positions Field

name="Positions" Structure of PositionStruct

public PositionStruct[] positions;

See Also

Positionclass.BookStruct Class | PositionClass Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Positionclass.BookStruct.PositionsHeader Field

name="Positionsheader" Structure of Positions attributes Struct

public PosHeaderStruct PositionsHeader;

See Also

Positionclass.BookStruct Class | PositionClass Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Positionclass.BookStruct.season Field

name="Season" Season variable

public string season;

See Also

Positionclass.BookStruct Class | PositionClass Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Positionclass.BookStruct.seasonnumber Field

name="Seasonnumber" Season counter variable

public long seasonnumber;

See Also

Positionclass.BookStruct Class | PositionClass Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Positionclass.BookStruct.transactiondate Field

name="TransactionDate" Transaction Date of the Book

public DateTime transactiondate;

See Also

Positionclass.BookStruct Class | PositionClass Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Positionclass.PosHeaderStruct Structure

Structure: PosHeaderStruct structure of trading positions attributes

For a list of all members of this type, see Positionclass.PosHeaderStruct Members.

System.Object
System.ValueType
PositionClass.Positionclass.PosHeaderStruct

public struct Positionclass.PosHeaderStruct

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Holds attributes relating hedges and simulated positions

Requirements

Namespace: PositionClass

Assembly: PositionClass (in PositionClass.dll)

See Also

Positionclass.PosHeaderStruct Members | PositionClass Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Positionclass.PosHeaderStruct Members

Positionclass.PosHeaderStruct overview

Public Instance Fields

ContractDate | name="ContractDate" Array containing Time Periods of the Instrinsic/Hedge positions
enddate | name="EndDate" Ending date of the Intrinsic/hedge positions
expirationdate | name="ExpirationDate" Array containing Expiration Dates of the Intrinsic/Hedge positions
name | name="Name" Array containing names of the Intrinsic/Hege positions

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

Positionclass.PosHeaderStruct Class | PositionClass Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Positionclass.PosHeaderStruct Fields

The fields of the Positionclass.PosHeaderStruct structure are listed below. For a complete list of Positionclass.PosHeaderStruct structure members, see the Positionclass.PosHeaderStruct Members topic.

Public Instance Fields

ContractDate | name="ContractDate" Array containing Time Periods of the Instrinsic/Hedge positions
enddate | name="EndDate" Ending date of the Intrinsic/hedge positions
expirationdate | name="ExpirationDate" Array containing Expiration Dates of the Intrinsic/Hedge positions
name | name="Name" Array containing names of the Intrinsic/Hege positions

See Also

Positionclass.PosHeaderStruct Class | PositionClass Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Positionclass.PosHeaderStruct.ContractDate Field

name="ContractDate" Array containing Time Periods of the Instrinsic/Hedge positions

public DateTime[] ContractDate;

See Also

Positionclass.PosHeaderStruct Class | PositionClass Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Positionclass.PosHeaderStruct.enddate Field

name="EndDate" Ending date of the Intrinsic/hedge positions

public DateTime[] enddate;

See Also

Positionclass.PosHeaderStruct Class | PositionClass Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Positionclass.PosHeaderStruct.expirationdate Field

name="ExpirationDate" Array containing Expiration Dates of the Intrinsic/Hedge positions

public DateTime[] expirationdate;

See Also

Positionclass.PosHeaderStruct Class | PositionClass Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Positionclass.PosHeaderStruct.name Field

name="Name" Array containing names of the Intrinsic/Hege positions

public string[] name;

See Also

Positionclass.PosHeaderStruct Class | PositionClass Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Positionclass.PositionStruct Structure

Structure: PositionStruct structure of trading positions

For a list of all members of this type, see Positionclass.PositionStruct Members.

System.Object
System.ValueType
PositionClass.Positionclass.PositionStruct

public struct Positionclass.PositionStruct

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Hedge holds the actual positions, Intrinsic hold the simulated positions

Requirements

Namespace: PositionClass

Assembly: PositionClass (in PositionClass.dll)

See Also

Positionclass.PositionStruct Members | PositionClass Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Positionclass.PositionStruct Members

Positionclass.PositionStruct overview

Public Instance Fields

Hedge | name="Hedge" Array containing hedge positions of the book
Intrinsic | name="Name" Array containing names of the Intrinsic/Hege positions

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

Positionclass.PositionStruct Class | PositionClass Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Positionclass.PositionStruct Fields

The fields of the Positionclass.PositionStruct structure are listed below. For a complete list of Positionclass.PositionStruct structure members, see the Positionclass.PositionStruct Members topic.

Public Instance Fields

Hedge | name="Hedge" Array containing hedge positions of the book
Intrinsic | name="Name" Array containing names of the Intrinsic/Hege positions

See Also

Positionclass.PositionStruct Class | PositionClass Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Positionclass.PositionStruct.Hedge Field

name="Hedge" Array containing hedge positions of the book

public double[] Hedge;

See Also

Positionclass.PositionStruct Class | PositionClass Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Positionclass.PositionStruct.Intrinsic Field

name="Name" Array containing names of the Intrinsic/Hege positions

public double[] Intrinsic;

See Also

Positionclass.PositionStruct Class | PositionClass Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


PositionClassHierarchy

An NDoc Documented Class Library

PositionClass Hierarchy

System.Object
CurveClass.CurveClass
PositionClass.Positionclass
System.ValueType
PositionClass.Positionclass.BookIDStruct
PositionClass.Positionclass.BookStruct
PositionClass.Positionclass.PosHeaderStruct
PositionClass.Positionclass.PositionStruct

See Also

PositionClass Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net