ExtendedDates

An NDoc Documented Class Library

ExtendedDates Namespace

Namespace hierarchy

Classes

Class | Description
ExtendedDates | Class: ExtendedDates adds additional date manipulation fuctionality.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


ExtendedDates Class

Class: ExtendedDates adds additional date manipulation fuctionality.

For a list of all members of this type, see ExtendedDates Members.

System.Object
ExtendedDates.ExtendedDates

public class ExtendedDates

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

License: Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems and Economic Analytics, Limited 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 Financial.Seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is free software; you can redistribute it and/or modify it under the terms of the GNU Lesser General Public License as published by the Free Software Foundation; either version 2.1 of the License, or (at your option) any later version. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU Lesser General Public License for more details. You should have received a copy of the GNU Lesser General Public License along with this library; if not, write to the Free Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA Please email changes and enhancements to Financial.Seal@cox.net include name and email for developer recognition.

Requirements

Namespace: ExtendedDates

Assembly: ExtendedDates (in ExtendedDates.dll)

See Also

ExtendedDates Members | ExtendedDates Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


ExtendedDates Members

ExtendedDates overview

Public Instance Constructors

ExtendedDates Constructor Constructor for ExtendedDates Class

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
intnx | Method: intnx is a method to increment a date variable with alignment
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExtendedDates Class | ExtendedDates Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


ExtendedDates Constructor

Constructor for ExtendedDates Class

public ExtendedDates();

See Also

ExtendedDates Class | ExtendedDates Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


ExtendedDates Methods

The methods of the ExtendedDates class are listed below. For a complete list of ExtendedDates class members, see the ExtendedDates Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
intnx | Method: intnx is a method to increment a date variable with alignment
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExtendedDates Class | ExtendedDates Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


ExtendedDates.intnx Method

Method: intnx is a method to increment a date variable with alignment

public DateTime intnx(
DateInterval interval,
DateTime d,
long increment,
string align
);

Parameters

interval
Microsoft.VisualBasic.DateInterval
d
date parameter
increment
value to increment date parameter
align
alignment parameter

Return Value

date value

Example

intnx(DateInterval.Day,#12/15/2004#,1,"end") returns 12/16/2004 note the alignment has no bearing with day interval intnx(DateInterval.Month,#12/15/2004#,1,"beginning") returns 1/1/2005

See Also

ExtendedDates Class | ExtendedDates Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


ExtendedDatesHierarchy

An NDoc Documented Class Library

ExtendedDates Hierarchy

System.Object
ExtendedDates.ExtendedDates

See Also

ExtendedDates Namespace

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net