CurveClass

An NDoc Documented Class Library

CurveClass Namespace

Namespace hierarchy

Classes

Class | Description
CurveClass | Class: Curve class creates a market price structure to hold pricing and contract information.

Structures

Structure | Description
CurveClass.CurveIDStruct | Structure: CurveIDStruc structure for holding database price reference id
CurveClass.CurveStruct | Structure: CurveStruct structure for holding Market prices and interest rates
CurveClass.ForwardStruct | Structure: ForwardStruct structure for holding Market prices and interest rates for a single day
CurveClass.holidays | Structure: Holidays /Expiration calendar structure for forward curves

Send comments on this topic.


CurveClass Class

Class: Curve class creates a market price structure to hold pricing and contract information.

For a list of all members of this type, see CurveClass Members.

System.Object
CurveClass.CurveClass

public class CurveClass

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

License: Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems and Economic Analytics, Limited 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 Financial.Seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is free software; you can redistribute it and/or modify it under the terms of the GNU Lesser General Public License as published by the Free Software Foundation; either version 2.1 of the License, or (at your option) any later version. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU Lesser General Public License for more details. You should have received a copy of the GNU Lesser General Public License along with this library; if not, write to the Free Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA Please email changes and enhancements to Financial.Seal@cox.net include name and email for developer recognition.

Requirements

Namespace: CurveClass

Assembly: CurveClass (in CurveClass.dll)

See Also

CurveClass Members | CurveClass Namespace


CurveClass Members

CurveClass overview

Public Static Fields

NUMOFDAYSYEAR |
o_stochastix | Property: module level object for Stochastic.Net Daycounters

Public Static Methods

season | Method: (shared) season for setting natural gas injection/withdrawal season variable
seasonset | Method: (hared) seasonset: returns the first or last month of the commodity season

Public Instance Constructors

CurveClass Constructor Constructor for Curve Class

Public Instance Fields

marketcurve Property: module level market curve of curvestruct

Public Instance Properties

commodityType | Property: m_commodityType - specifies commodity for calendar and seasons Commodity Type based on Nymex Futures Commodity Codes see href="www.nymex.com"
holiday | Property: Holidays property

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
marketbuild | Method: (public) Marketbuild for initializing market structures
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CurveClass Class | CurveClass Namespace


CurveClass Constructor

Constructor for Curve Class

public CurveClass();

See Also

CurveClass Class | CurveClass Namespace


CurveClass Fields

The fields of the CurveClass class are listed below. For a complete list of CurveClass class members, see the CurveClass Members topic.

Public Static Fields

NUMOFDAYSYEAR |
o_stochastix | Property: module level object for Stochastic.Net Daycounters

Public Instance Fields

marketcurve Property: module level market curve of curvestruct

See Also

CurveClass Class | CurveClass Namespace


CurveClass.marketcurve Field

Property: module level market curve of curvestruct

public CurveStruct marketcurve;

See Also

CurveClass Class | CurveClass Namespace


CurveClass.NUMOFDAYSYEAR Field

public const double NUMOFDAYSYEAR = 365.25;

See Also

CurveClass Class | CurveClass Namespace


CurveClass.o_stochastix Field

Property: module level object for Stochastic.Net Daycounters

public static readonly Actual365 o_stochastix;

See Also

CurveClass Class | CurveClass Namespace


CurveClass Properties

The properties of the CurveClass class are listed below. For a complete list of CurveClass class members, see the CurveClass Members topic.

Public Instance Properties

commodityType | Property: m_commodityType - specifies commodity for calendar and seasons Commodity Type based on Nymex Futures Commodity Codes see href="www.nymex.com"
holiday | Property: Holidays property

See Also

CurveClass Class | CurveClass Namespace


commodityType Property

An NDoc Documented Class Library

CurveClass.commodityType Property

Property: m_commodityType - specifies commodity for calendar and seasons Commodity Type based on Nymex Futures Commodity Codes see href="www.nymex.com"

public string commodityType {get; set;}

See Also

CurveClass Class | CurveClass Namespace


holiday Property

An NDoc Documented Class Library

CurveClass.holiday Property

Property: Holidays property

public object holiday {get; set;}

See Also

CurveClass Class | CurveClass Namespace


CurveClass Methods

The methods of the CurveClass class are listed below. For a complete list of CurveClass class members, see the CurveClass Members topic.

Public Static Methods

season | Method: (shared) season for setting natural gas injection/withdrawal season variable
seasonset | Method: (hared) seasonset: returns the first or last month of the commodity season

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
marketbuild | Method: (public) Marketbuild for initializing market structures
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CurveClass Class | CurveClass Namespace


CurveClass.marketbuild Method

Method: (public) Marketbuild for initializing market structures

public void marketbuild(
ref object model,
object refObj,
string type
);

Parameters

model
object that contains calling object
refObj
type

Remarks

Creates a structure that contains all the commodity market information downloads the commodites and calcs maturities, discount rates and other required variables.

See Also

CurveClass Class | CurveClass Namespace


CurveClass.season Method

Method: (shared) season for setting natural gas injection/withdrawal season variable

public static string season(
int mv,
string commoditytype
);

Parameters

mv
Month index for determining season
commoditytype
Commodity Type based on NYMEX designations

Remarks

Need to add other commodities

See Also

CurveClass Class | CurveClass Namespace


CurveClass.seasonset Method

Method: (hared) seasonset: returns the first or last month of the commodity season

public static long seasonset(
string type,
bool retvalue
);

Parameters

type
Commodity type designation
retvalue
return flag for first month (true) or last month (false) of season cycle

Remarks

See Also

CurveClass Class | CurveClass Namespace


CurveClass.CurveIDStruct Structure

Structure: CurveIDStruc structure for holding database price reference id

For a list of all members of this type, see CurveClass.CurveIDStruct Members.

System.Object
System.ValueType
CurveClass.CurveClass.CurveIDStruct

public struct CurveClass.CurveIDStruct

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

BidAsk and implied volatilities should be tied to forward id values otherwise additional variables need to be declared for these.

Requirements

Namespace: CurveClass

Assembly: CurveClass (in CurveClass.dll)

See Also

CurveClass.CurveIDStruct Members | CurveClass Namespace


CurveClass.CurveIDStruct Members

CurveClass.CurveIDStruct overview

Public Instance Fields

Balmon | Variable name="BalMon" Balance of the Month Price ID
ExchangeRate | Variable name="ExchangeRate" Exchange Rate curve ID
Forward | Variable name="Forward" Forward Curve ID
ForwardBasis | Variable name="ForwardBasis" Forward Basis curve ID
Interest | Variable name="Interest" Interest Rate/YTM Curve ID
Spot | Variable name="Spot" Spot Price ID
SpotBasis | Variable name="SpotBasis" Spot Basis Price ID
Vol | Variable name="VOL" Implied Volatility curve ID

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

CurveClass.CurveIDStruct Class | CurveClass Namespace


CurveClass.CurveIDStruct Fields

The fields of the CurveClass.CurveIDStruct structure are listed below. For a complete list of CurveClass.CurveIDStruct structure members, see the CurveClass.CurveIDStruct Members topic.

Public Instance Fields

Balmon | Variable name="BalMon" Balance of the Month Price ID
ExchangeRate | Variable name="ExchangeRate" Exchange Rate curve ID
Forward | Variable name="Forward" Forward Curve ID
ForwardBasis | Variable name="ForwardBasis" Forward Basis curve ID
Interest | Variable name="Interest" Interest Rate/YTM Curve ID
Spot | Variable name="Spot" Spot Price ID
SpotBasis | Variable name="SpotBasis" Spot Basis Price ID
Vol | Variable name="VOL" Implied Volatility curve ID

See Also

CurveClass.CurveIDStruct Class | CurveClass Namespace


CurveClass.CurveIDStruct.Balmon Field

Variable name="BalMon" Balance of the Month Price ID

public string Balmon;

See Also

CurveClass.CurveIDStruct Class | CurveClass Namespace


CurveClass.CurveIDStruct.ExchangeRate Field

Variable name="ExchangeRate" Exchange Rate curve ID

public string ExchangeRate;

See Also

CurveClass.CurveIDStruct Class | CurveClass Namespace


CurveClass.CurveIDStruct.Forward Field

Variable name="Forward" Forward Curve ID

public string Forward;

See Also

CurveClass.CurveIDStruct Class | CurveClass Namespace


CurveClass.CurveIDStruct.ForwardBasis Field

Variable name="ForwardBasis" Forward Basis curve ID

public string ForwardBasis;

See Also

CurveClass.CurveIDStruct Class | CurveClass Namespace


CurveClass.CurveIDStruct.Interest Field

Variable name="Interest" Interest Rate/YTM Curve ID

public string Interest;

See Also

CurveClass.CurveIDStruct Class | CurveClass Namespace


CurveClass.CurveIDStruct.Spot Field

Variable name="Spot" Spot Price ID

public string Spot;

See Also

CurveClass.CurveIDStruct Class | CurveClass Namespace


CurveClass.CurveIDStruct.SpotBasis Field

Variable name="SpotBasis" Spot Basis Price ID

public string SpotBasis;

See Also

CurveClass.CurveIDStruct Class | CurveClass Namespace


CurveClass.CurveIDStruct.Vol Field

Variable name="VOL" Implied Volatility curve ID

public string Vol;

See Also

CurveClass.CurveIDStruct Class | CurveClass Namespace


CurveClass.CurveStruct Structure

Structure: CurveStruct structure for holding Market prices and interest rates

For a list of all members of this type, see CurveClass.CurveStruct Members.

System.Object
System.ValueType
CurveClass.CurveClass.CurveStruct

public struct CurveClass.CurveStruct

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: CurveClass

Assembly: CurveClass (in CurveClass.dll)

See Also

CurveClass.CurveStruct Members | CurveClass Namespace


CurveClass.CurveStruct Members

CurveClass.CurveStruct overview

Public Instance Fields

curves | Variable name="Curves" Defines a Forward struture
season | Variable name="Season" seaon of curve
seasonnumber | Variable name="Seasonnumber" season number for curves
transactiondate | Variable name="TransactionDate" Transaction date of curves

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

CurveClass.CurveStruct Class | CurveClass Namespace


CurveClass.CurveStruct Fields

The fields of the CurveClass.CurveStruct structure are listed below. For a complete list of CurveClass.CurveStruct structure members, see the CurveClass.CurveStruct Members topic.

Public Instance Fields

curves | Variable name="Curves" Defines a Forward struture
season | Variable name="Season" seaon of curve
seasonnumber | Variable name="Seasonnumber" season number for curves
transactiondate | Variable name="TransactionDate" Transaction date of curves

See Also

CurveClass.CurveStruct Class | CurveClass Namespace


CurveClass.CurveStruct.curves Field

Variable name="Curves" Defines a Forward struture

public ForwardStruct curves;

See Also

CurveClass.CurveStruct Class | CurveClass Namespace


CurveClass.CurveStruct.season Field

Variable name="Season" seaon of curve

public string season;

See Also

CurveClass.CurveStruct Class | CurveClass Namespace


CurveClass.CurveStruct.seasonnumber Field

Variable name="Seasonnumber" season number for curves

public long seasonnumber;

See Also

CurveClass.CurveStruct Class | CurveClass Namespace


CurveClass.CurveStruct.transactiondate Field

Variable name="TransactionDate" Transaction date of curves

public DateTime transactiondate;

See Also

CurveClass.CurveStruct Class | CurveClass Namespace


CurveClass.ForwardStruct Structure

Structure: ForwardStruct structure for holding Market prices and interest rates for a single day

For a list of all members of this type, see CurveClass.ForwardStruct Members.

System.Object
System.ValueType
CurveClass.CurveClass.ForwardStruct

public struct CurveClass.ForwardStruct

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Normal market is price,basis, interest rate, forward=price+basis. season>> are specific to storage onlymaturity and discountfactor are for interest rate only

Requirements

Namespace: CurveClass

Assembly: CurveClass (in CurveClass.dll)

See Also

CurveClass.ForwardStruct Members | CurveClass Namespace


CurveClass.ForwardStruct Members

CurveClass.ForwardStruct overview

Public Instance Fields

Basis | Variable name="Basis" Array (curve) of basis prices
bidask | Variable name="BIDASK" Array (curve) of forward bid/ask spreads
ContractDate | Variable name="Contractdate" Array (curve) of contract or reference dates for forwards
dealperiod | Variable name="DealPeriod" Array (curve) deal periods counters for each element of the curve
discountfactor | Variable name="Discount factor" Array (curve) discount factors measured using maturity discounted to transactdate of structure
enddate | Variable name="Enddate" Array (curve) of enddate of physical flows associated with contract period
exchangerate | Variable name="ExchangeRate" Array (curve) of forward exchange rates
expirationdate | Variable name="ExpirationDate" Array (curve) of expiration dates associated with contract period
Forward | Variable name="Forward" Array (curve) of forward prices that are = price + basis
ImpliedVol | Variable name="ImpliedVol" Array (curve) of Implied Volatilities
Interest | Variable name="Interest" Array (curve) of interest rates (YTM)
maturity | Variable name="Maturity" Array (curve) maturity times measured as percentage of year based on transactiondate and contractdate
name | Variable name="Name" Array (curve) of name associated with forwards
period | Variable name="Period" Array (curve) counters for curve
Price | Variable name="Price" Array (curve) of forward prices
season | Variable name="Season" Array (curve) of season indicators associatee with each contract period
seasoncounter | Variable name="Seasoncounter" Array (curve) of season indicators associatee with each contract period
seasonnumber | Variable name="Seasonnumber" Array (curve) of season indicators associatee with each contract period
VolShape | Variable name="VolShape" Array (curve) of volatility shape factors, Not used at this time

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

CurveClass.ForwardStruct Class | CurveClass Namespace


CurveClass.ForwardStruct Fields

The fields of the CurveClass.ForwardStruct structure are listed below. For a complete list of CurveClass.ForwardStruct structure members, see the CurveClass.ForwardStruct Members topic.

Public Instance Fields

Basis | Variable name="Basis" Array (curve) of basis prices
bidask | Variable name="BIDASK" Array (curve) of forward bid/ask spreads
ContractDate | Variable name="Contractdate" Array (curve) of contract or reference dates for forwards
dealperiod | Variable name="DealPeriod" Array (curve) deal periods counters for each element of the curve
discountfactor | Variable name="Discount factor" Array (curve) discount factors measured using maturity discounted to transactdate of structure
enddate | Variable name="Enddate" Array (curve) of enddate of physical flows associated with contract period
exchangerate | Variable name="ExchangeRate" Array (curve) of forward exchange rates
expirationdate | Variable name="ExpirationDate" Array (curve) of expiration dates associated with contract period
Forward | Variable name="Forward" Array (curve) of forward prices that are = price + basis
ImpliedVol | Variable name="ImpliedVol" Array (curve) of Implied Volatilities
Interest | Variable name="Interest" Array (curve) of interest rates (YTM)
maturity | Variable name="Maturity" Array (curve) maturity times measured as percentage of year based on transactiondate and contractdate
name | Variable name="Name" Array (curve) of name associated with forwards
period | Variable name="Period" Array (curve) counters for curve
Price | Variable name="Price" Array (curve) of forward prices
season | Variable name="Season" Array (curve) of season indicators associatee with each contract period
seasoncounter | Variable name="Seasoncounter" Array (curve) of season indicators associatee with each contract period
seasonnumber | Variable name="Seasonnumber" Array (curve) of season indicators associatee with each contract period
VolShape | Variable name="VolShape" Array (curve) of volatility shape factors, Not used at this time

See Also

CurveClass.ForwardStruct Class | CurveClass Namespace


CurveClass.ForwardStruct.Basis Field

Variable name="Basis" Array (curve) of basis prices

public double[] Basis;

See Also

CurveClass.ForwardStruct Class | CurveClass Namespace


CurveClass.ForwardStruct.bidask Field

Variable name="BIDASK" Array (curve) of forward bid/ask spreads

public double[] bidask;

See Also

CurveClass.ForwardStruct Class | CurveClass Namespace


CurveClass.ForwardStruct.ContractDate Field

Variable name="Contractdate" Array (curve) of contract or reference dates for forwards

public DateTime[] ContractDate;

See Also

CurveClass.ForwardStruct Class | CurveClass Namespace


CurveClass.ForwardStruct.dealperiod Field

Variable name="DealPeriod" Array (curve) deal periods counters for each element of the curve

public long[] dealperiod;

See Also

CurveClass.ForwardStruct Class | CurveClass Namespace


CurveClass.ForwardStruct.discountfactor Field

Variable name="Discount factor" Array (curve) discount factors measured using maturity discounted to transactdate of structure

public double[] discountfactor;

See Also

CurveClass.ForwardStruct Class | CurveClass Namespace


CurveClass.ForwardStruct.enddate Field

Variable name="Enddate" Array (curve) of enddate of physical flows associated with contract period

public DateTime[] enddate;

See Also

CurveClass.ForwardStruct Class | CurveClass Namespace


CurveClass.ForwardStruct.exchangerate Field

Variable name="ExchangeRate" Array (curve) of forward exchange rates

public double[] exchangerate;

See Also

CurveClass.ForwardStruct Class | CurveClass Namespace


CurveClass.ForwardStruct.expirationdate Field

Variable name="ExpirationDate" Array (curve) of expiration dates associated with contract period

public DateTime[] expirationdate;

See Also

CurveClass.ForwardStruct Class | CurveClass Namespace


CurveClass.ForwardStruct.Forward Field

Variable name="Forward" Array (curve) of forward prices that are = price + basis

public double[] Forward;

See Also

CurveClass.ForwardStruct Class | CurveClass Namespace


CurveClass.ForwardStruct.ImpliedVol Field

Variable name="ImpliedVol" Array (curve) of Implied Volatilities

public double[] ImpliedVol;

See Also

CurveClass.ForwardStruct Class | CurveClass Namespace


CurveClass.ForwardStruct.Interest Field

Variable name="Interest" Array (curve) of interest rates (YTM)

public double[] Interest;

See Also

CurveClass.ForwardStruct Class | CurveClass Namespace


CurveClass.ForwardStruct.maturity Field

Variable name="Maturity" Array (curve) maturity times measured as percentage of year based on transactiondate and contractdate

public double[] maturity;

See Also

CurveClass.ForwardStruct Class | CurveClass Namespace


CurveClass.ForwardStruct.name Field

Variable name="Name" Array (curve) of name associated with forwards

public string[] name;

See Also

CurveClass.ForwardStruct Class | CurveClass Namespace


CurveClass.ForwardStruct.period Field

Variable name="Period" Array (curve) counters for curve

public double[] period;

See Also

CurveClass.ForwardStruct Class | CurveClass Namespace


CurveClass.ForwardStruct.Price Field

Variable name="Price" Array (curve) of forward prices

public double[] Price;

See Also

CurveClass.ForwardStruct Class | CurveClass Namespace


CurveClass.ForwardStruct.season Field

Variable name="Season" Array (curve) of season indicators associatee with each contract period

public string[] season;

See Also

CurveClass.ForwardStruct Class | CurveClass Namespace


CurveClass.ForwardStruct.seasoncounter Field

Variable name="Seasoncounter" Array (curve) of season indicators associatee with each contract period

public long[] seasoncounter;

See Also

CurveClass.ForwardStruct Class | CurveClass Namespace


CurveClass.ForwardStruct.seasonnumber Field

Variable name="Seasonnumber" Array (curve) of season indicators associatee with each contract period

public long[] seasonnumber;

See Also

CurveClass.ForwardStruct Class | CurveClass Namespace


CurveClass.ForwardStruct.VolShape Field

Variable name="VolShape" Array (curve) of volatility shape factors, Not used at this time

public double[] VolShape;

See Also

CurveClass.ForwardStruct Class | CurveClass Namespace


CurveClass.holidays Structure

Structure: Holidays /Expiration calendar structure for forward curves

For a list of all members of this type, see CurveClass.holidays Members.

System.Object
System.ValueType
CurveClass.CurveClass.holidays

public struct CurveClass.holidays

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: CurveClass

Assembly: CurveClass (in CurveClass.dll)

See Also

CurveClass.holidays Members | CurveClass Namespace


CurveClass.holidays Members

CurveClass.holidays overview

Public Instance Fields

contractdate | Variable name="ContractDate" Array for holding expiration dates contract period date values
holiday | Variable name="Holiday" Array for holding holiday/expiration dates

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

CurveClass.holidays Class | CurveClass Namespace


CurveClass.holidays Fields

The fields of the CurveClass.holidays structure are listed below. For a complete list of CurveClass.holidays structure members, see the CurveClass.holidays Members topic.

Public Instance Fields

contractdate | Variable name="ContractDate" Array for holding expiration dates contract period date values
holiday | Variable name="Holiday" Array for holding holiday/expiration dates

See Also

CurveClass.holidays Class | CurveClass Namespace


CurveClass.holidays.contractdate Field

Variable name="ContractDate" Array for holding expiration dates contract period date values

public DateTime[] contractdate;

See Also

CurveClass.holidays Class | CurveClass Namespace


CurveClass.holidays.holiday Field

Variable name="Holiday" Array for holding holiday/expiration dates

public DateTime[] holiday;

See Also

CurveClass.holidays Class | CurveClass Namespace


Stochastix.Business

An NDoc Documented Class Library

Stochastix.Business Namespace

Namespace hierarchy

Interfaces

Interface | Description
IBusinessCalendar |
IDayCounter |

Structures

Structure | Description
Period |

Enumerations

Enumeration | Description
Currency |
RollingConvention |
TimeUnit |


Currency Enumeration

public enum Currency

Members

Member Name | Description
ARS |
ATS |
AUD |
BDT |
BEF |
BGL |
BRL |
BYB |
CAD |
CHF |
CLP |
CNY |
COP |
CYP |
CZK |
DEM |
DKK |
EEK |
EUR |
GBP |
GRD |
HKD |
HUF |
ILS |
INR |
IQD |
IRR |
ISK |
ITL |
JPY |
KRW |
KWD |
LTL |
LVL |
MTL |
MXP |
NOK |
NPR |
NZD |
PKR |
PLN |
ROL |
SAR |
SEK |
SGD |
SIT |
SKK |
THB |
TRL |
TTD |
TWD |
USD |
VEB |
ZAR |

Requirements

Namespace: Stochastix.Business

Assembly: Stochastix.Business (in Stochastix.Business.dll)

See Also

Stochastix.Business Namespace


IBusinessCalendar Interface

For a list of all members of this type, see IBusinessCalendar Members.

public interface IBusinessCalendar

Types that implement IBusinessCalendar

Type | Description
Budapest |
CalendarBase |
Frankfurt |
Helsinki |
Johannesburg |
JointCalendar |
London |
Milan |
NewYork |
Oslo |
Stockholm |
Sydney |
TARGET |
Tokyo |
Toronto |
Warsaw |
Wellington |
WesternCalendarBase |
Zurich |

Requirements

Namespace: Stochastix.Business

Assembly: Stochastix.Business (in Stochastix.Business.dll)

See Also

IBusinessCalendar Members | Stochastix.Business Namespace


IBusinessCalendar Members

IBusinessCalendar overview

Public Instance Properties

Calendar
Culture
Region

Public Instance Methods

Advance | Overloaded.
IsBusinessDay |
IsHoliday |
Roll | Overloaded.
ToString |

See Also

IBusinessCalendar Interface | Stochastix.Business Namespace


IBusinessCalendar Properties

The properties of the IBusinessCalendar interface are listed below. For a complete list of IBusinessCalendar interface members, see the IBusinessCalendar Members topic.

Public Instance Properties

Calendar
Culture
Region

See Also

IBusinessCalendar Interface | Stochastix.Business Namespace


Calendar Property

An NDoc Documented Class Library

IBusinessCalendar.Calendar Property

System.Globalization.Calendar Calendar {get;}

See Also

IBusinessCalendar Interface | Stochastix.Business Namespace


Culture Property

An NDoc Documented Class Library

IBusinessCalendar.Culture Property

System.Globalization.CultureInfo Culture {get;}

See Also

IBusinessCalendar Interface | Stochastix.Business Namespace


Region Property

An NDoc Documented Class Library

IBusinessCalendar.Region Property

System.Globalization.RegionInfo Region {get;}

See Also

IBusinessCalendar Interface | Stochastix.Business Namespace


IBusinessCalendar Methods

The methods of the IBusinessCalendar interface are listed below. For a complete list of IBusinessCalendar interface members, see the IBusinessCalendar Members topic.

Public Instance Methods

Advance | Overloaded.
IsBusinessDay |
IsHoliday |
Roll | Overloaded.
ToString |

See Also

IBusinessCalendar Interface | Stochastix.Business Namespace


Advance Method

An NDoc Documented Class Library

IBusinessCalendar.Advance Method

Overload List

DateTime Advance(DateTime,Period);

DateTime Advance(DateTime,Period,RollingConvention);

DateTime Advance(DateTime,int,TimeUnit);

DateTime Advance(DateTime,int,TimeUnit,RollingConvention);

DateTime Advance(DateTime,TimeSpan);

DateTime Advance(DateTime,TimeSpan,RollingConvention);

See Also

IBusinessCalendar Interface | Stochastix.Business Namespace


IBusinessCalendar.Advance Method (DateTime, Period)

DateTime Advance(
DateTime date,
Period period
);

See Also

IBusinessCalendar Interface | Stochastix.Business Namespace | IBusinessCalendar.Advance Overload List


IBusinessCalendar.Advance Method (DateTime, Period, RollingConvention)

DateTime Advance(
DateTime date,
Period period,
RollingConvention convention
);

See Also

IBusinessCalendar Interface | Stochastix.Business Namespace | IBusinessCalendar.Advance Overload List


IBusinessCalendar.Advance Method (DateTime, Int32, TimeUnit)

DateTime Advance(
DateTime date,
int length,
TimeUnit units
);

See Also

IBusinessCalendar Interface | Stochastix.Business Namespace | IBusinessCalendar.Advance Overload List


IBusinessCalendar.Advance Method (DateTime, Int32, TimeUnit, RollingConvention)

DateTime Advance(
DateTime date,
int length,
TimeUnit units,
RollingConvention convention
);

See Also

IBusinessCalendar Interface | Stochastix.Business Namespace | IBusinessCalendar.Advance Overload List


IBusinessCalendar.Advance Method (DateTime, TimeSpan)

DateTime Advance(
DateTime date,
TimeSpan interval
);

See Also

IBusinessCalendar Interface | Stochastix.Business Namespace | IBusinessCalendar.Advance Overload List


IBusinessCalendar.Advance Method (DateTime, TimeSpan, RollingConvention)

DateTime Advance(
DateTime date,
TimeSpan interval,
RollingConvention convention
);

See Also

IBusinessCalendar Interface | Stochastix.Business Namespace | IBusinessCalendar.Advance Overload List


IBusinessCalendar.IsBusinessDay Method

bool IsBusinessDay(
DateTime date
);

See Also

IBusinessCalendar Interface | Stochastix.Business Namespace


IBusinessCalendar.IsHoliday Method

bool IsHoliday(
DateTime date
);

See Also

IBusinessCalendar Interface | Stochastix.Business Namespace


Roll Method

An NDoc Documented Class Library

IBusinessCalendar.Roll Method

Overload List

DateTime Roll(DateTime);

DateTime Roll(DateTime,RollingConvention);

See Also

IBusinessCalendar Interface | Stochastix.Business Namespace


IBusinessCalendar.Roll Method (DateTime)

DateTime Roll(
DateTime date
);

See Also

IBusinessCalendar Interface | Stochastix.Business Namespace | IBusinessCalendar.Roll Overload List


IBusinessCalendar.Roll Method (DateTime, RollingConvention)

DateTime Roll(
DateTime date,
RollingConvention convention
);

See Also

IBusinessCalendar Interface | Stochastix.Business Namespace | IBusinessCalendar.Roll Overload List


IBusinessCalendar.ToString Method

string ToString();

See Also

IBusinessCalendar Interface | Stochastix.Business Namespace


IDayCounter Interface

For a list of all members of this type, see IDayCounter Members.

public interface IDayCounter

Types that implement IDayCounter

Type | Description
Actual360 |
Actual365 |
ActualActualAFB |
ActualActualISDA |
ActualActualISMA |
DayCounterBase |
Thirty360EU |
Thirty360Italian |
Thirty360US |

Requirements

Namespace: Stochastix.Business

Assembly: Stochastix.Business (in Stochastix.Business.dll)

See Also

IDayCounter Members | Stochastix.Business Namespace


IDayCounter Members

IDayCounter overview

Public Instance Methods

DayCount |
ToString |
YearFraction | Overloaded.

See Also

IDayCounter Interface | Stochastix.Business Namespace


IDayCounter Methods

The methods of the IDayCounter interface are listed below. For a complete list of IDayCounter interface members, see the IDayCounter Members topic.

Public Instance Methods

DayCount |
ToString |
YearFraction | Overloaded.

See Also

IDayCounter Interface | Stochastix.Business Namespace


IDayCounter.DayCount Method

int DayCount(
DateTime startDate,
DateTime endDate
);

See Also

IDayCounter Interface | Stochastix.Business Namespace


IDayCounter.ToString Method

string ToString();

See Also

IDayCounter Interface | Stochastix.Business Namespace


YearFraction Method

An NDoc Documented Class Library

IDayCounter.YearFraction Method

Overload List

double YearFraction(DateTime,DateTime);

double YearFraction(DateTime,DateTime,DateTime,DateTime);

See Also

IDayCounter Interface | Stochastix.Business Namespace


IDayCounter.YearFraction Method (DateTime, DateTime)

double YearFraction(
DateTime startDate,
DateTime endDate
);

See Also

IDayCounter Interface | Stochastix.Business Namespace | IDayCounter.YearFraction Overload List


IDayCounter.YearFraction Method (DateTime, DateTime, DateTime, DateTime)

double YearFraction(
DateTime startDate,
DateTime endDate,
DateTime refPeriodStart,
DateTime refPeriodEnd
);

See Also

IDayCounter Interface | Stochastix.Business Namespace | IDayCounter.YearFraction Overload List


Period Structure

For a list of all members of this type, see Period Members.

System.Object
System.ValueType
Stochastix.Business.Period

public struct Period

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Stochastix.Business

Assembly: Stochastix.Business (in Stochastix.Business.dll)

See Also

Period Members | Stochastix.Business Namespace


Period Members

Period overview

Public Static Methods

Parse

Public Static Operators

Addition Operator
Subtraction Operator

Public Instance Constructors

Period Constructor

Public Instance Fields

Length
Units

Public Instance Properties

Frequency

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

Period Class | Stochastix.Business Namespace


Period Constructor

public Period(
int length,
TimeUnit units
);

See Also

Period Class | Stochastix.Business Namespace


Period Fields

The fields of the Period structure are listed below. For a complete list of Period structure members, see the Period Members topic.

Public Instance Fields

Length
Units

See Also

Period Class | Stochastix.Business Namespace


Period.Length Field

public int Length;

See Also

Period Class | Stochastix.Business Namespace


Period.Units Field

public TimeUnit Units;

See Also

Period Class | Stochastix.Business Namespace


Period Properties

The properties of the Period structure are listed below. For a complete list of Period structure members, see the Period Members topic.

Public Instance Properties

Frequency

See Also

Period Class | Stochastix.Business Namespace


Frequency Property

An NDoc Documented Class Library

Period.Frequency Property

public int Frequency {get;}

See Also

Period Class | Stochastix.Business Namespace


Period Methods

The methods of the Period structure are listed below. For a complete list of Period structure members, see the Period Members topic.

Public Static Methods

Parse

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

Period Class | Stochastix.Business Namespace


Period.Parse Method

public static Period Parse(
string periodString
);

See Also

Period Class | Stochastix.Business Namespace


Period.ToString Method

public override string ToString();

See Also

Period Class | Stochastix.Business Namespace


Period Operators

The operators of the Period structure are listed below. For a complete list of Period structure members, see the Period Members topic.

Public Static Operators

Addition Operator
Subtraction Operator

See Also

Period Class | Period Members | Stochastix.Business Namespace


Period Addition Operator

public static DateTime operator +(
DateTime date,
Period p
);

See Also

Period Class | Stochastix.Business Namespace


Period Subtraction Operator

public static DateTime operator -(
DateTime date,
Period p
);

See Also

Period Class | Stochastix.Business Namespace


RollingConvention Enumeration

public enum RollingConvention

Members

Member Name | Description
Preceding |
ModifiedPreceding |
Following |
ModifiedFollowing |
Actual |

Requirements

Namespace: Stochastix.Business

Assembly: Stochastix.Business (in Stochastix.Business.dll)

See Also

Stochastix.Business Namespace


TimeUnit Enumeration

public enum TimeUnit

Members

Member Name | Description
Days |
Weeks |
Months |
Years |

Requirements

Namespace: Stochastix.Business

Assembly: Stochastix.Business (in Stochastix.Business.dll)

See Also

Stochastix.Business Namespace


Stochastix.Business.Calendars

An NDoc Documented Class Library

Stochastix.Business.Calendars Namespace

Namespace hierarchy

Classes

Class | Description
Budapest |
CalendarBase |
Frankfurt |
Helsinki |
Johannesburg |
JointCalendar |
London |
Milan |
NewYork |
Oslo |
Stockholm |
Sydney |
TARGET |
Tokyo |
Toronto |
Warsaw |
Wellington |
WesternCalendarBase |
Zurich |

Enumerations

Enumeration | Description
JointCalendar.Rule |
Month |


Budapest Class

For a list of all members of this type, see Budapest Members.

System.Object
Stochastix.Business.Calendars.CalendarBase
Stochastix.Business.Calendars.WesternCalendarBase
Stochastix.Business.Calendars.Budapest

public sealed class Budapest : WesternCalendarBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Stochastix.Business.Calendars

Assembly: Stochastix.Business (in Stochastix.Business.dll)

See Also

Budapest Members | Stochastix.Business.Calendars Namespace


Budapest Members

Budapest overview

Public Static Fields

Instance

Public Instance Constructors

Budapest Constructor Initializes a new instance of the Budapest class.

Public Instance Properties

Calendar (inherited from CalendarBase)
Culture (inherited from CalendarBase)
Region (inherited from CalendarBase)

Public Instance Methods

Advance (inherited from CalendarBase) | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsBusinessDay (inherited from WesternCalendarBase) |
IsHoliday (inherited from CalendarBase) |
Roll (inherited from CalendarBase) | Overloaded.
ToString (inherited from CalendarBase) |

See Also

Budapest Class | Stochastix.Business.Calendars Namespace


Budapest Constructor

NOTE: This constructor is now obsolete.

Use Budapest.Instance in .NET applications.

Initializes a new instance of the Budapest class.

public Budapest();

See Also

Budapest Class | Stochastix.Business.Calendars Namespace


Budapest Fields

The fields of the Budapest class are listed below. For a complete list of Budapest class members, see the Budapest Members topic.

Public Static Fields

Instance

See Also

Budapest Class | Stochastix.Business.Calendars Namespace


Budapest.Instance Field

public static readonly IBusinessCalendar Instance;

See Also

Budapest Class | Stochastix.Business.Calendars Namespace


CalendarBase Class

For a list of all members of this type, see CalendarBase Members.

System.Object
Stochastix.Business.Calendars.CalendarBase
Stochastix.Business.Calendars.JointCalendar
Stochastix.Business.Calendars.Tokyo
Stochastix.Business.Calendars.WesternCalendarBase

public abstract class CalendarBase : IBusinessCalendar

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Stochastix.Business.Calendars

Assembly: Stochastix.Business (in Stochastix.Business.dll)

See Also

CalendarBase Members | Stochastix.Business.Calendars Namespace


CalendarBase Members

CalendarBase overview

Public Static Fields

NullDate

Public Instance Properties

Calendar
Culture
Region

Public Instance Methods

Advance | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsBusinessDay |
IsHoliday |
Roll | Overloaded.
ToString |

Protected Instance Constructors

CalendarBase Overloaded. Initializes a new instance of the CalendarBase class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CalendarBase Class | Stochastix.Business.Calendars Namespace


CalendarBase Constructor

Overload List

protected CalendarBase(string,CultureInfo);

protected CalendarBase(string,CultureInfo,Calendar);

See Also

CalendarBase Class | Stochastix.Business.Calendars Namespace


CalendarBase Constructor (String, CultureInfo)

protected CalendarBase(
string name,
CultureInfo culture
);

See Also

CalendarBase Class | Stochastix.Business.Calendars Namespace | CalendarBase Constructor Overload List


CalendarBase Constructor (String, CultureInfo, Calendar)

protected CalendarBase(
string name,
CultureInfo culture,
Calendar calendar
);

See Also

CalendarBase Class | Stochastix.Business.Calendars Namespace | CalendarBase Constructor Overload List


CalendarBase Fields

The fields of the CalendarBase class are listed below. For a complete list of CalendarBase class members, see the CalendarBase Members topic.

Public Static Fields

NullDate

See Also

CalendarBase Class | Stochastix.Business.Calendars Namespace


CalendarBase.NullDate Field

public static DateTime NullDate;

See Also

CalendarBase Class | Stochastix.Business.Calendars Namespace


CalendarBase Properties

The properties of the CalendarBase class are listed below. For a complete list of CalendarBase class members, see the CalendarBase Members topic.

Public Instance Properties

Calendar
Culture
Region

See Also

CalendarBase Class | Stochastix.Business.Calendars Namespace


Calendar Property

An NDoc Documented Class Library

CalendarBase.Calendar Property

public System.Globalization.Calendar Calendar {get;}

Implements

IBusinessCalendar.Calendar

See Also

CalendarBase Class | Stochastix.Business.Calendars Namespace


Culture Property

An NDoc Documented Class Library

CalendarBase.Culture Property

public System.Globalization.CultureInfo Culture {get;}

Implements

IBusinessCalendar.Culture

See Also

CalendarBase Class | Stochastix.Business.Calendars Namespace


Region Property

An NDoc Documented Class Library

CalendarBase.Region Property

public System.Globalization.RegionInfo Region {get;}

Implements

IBusinessCalendar.Region

See Also

CalendarBase Class | Stochastix.Business.Calendars Namespace


CalendarBase Methods

The methods of the CalendarBase class are listed below. For a complete list of CalendarBase class members, see the CalendarBase Members topic.

Public Instance Methods

Advance | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsBusinessDay |
IsHoliday |
Roll | Overloaded.
ToString |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CalendarBase Class | Stochastix.Business.Calendars Namespace


Advance Method

An NDoc Documented Class Library

CalendarBase.Advance Method

Overload List

public DateTime Advance(DateTime,Period);

public DateTime Advance(DateTime,Period,RollingConvention);

public DateTime Advance(DateTime,int,TimeUnit);

public DateTime Advance(DateTime,int,TimeUnit,RollingConvention);

public DateTime Advance(DateTime,TimeSpan);

public DateTime Advance(DateTime,TimeSpan,RollingConvention);

See Also

CalendarBase Class | Stochastix.Business.Calendars Namespace


CalendarBase.Advance Method (DateTime, Period)

public DateTime Advance(
DateTime date,
Period period
);

Implements

IBusinessCalendar.Advance

See Also

CalendarBase Class | Stochastix.Business.Calendars Namespace | CalendarBase.Advance Overload List


CalendarBase.Advance Method (DateTime, Period, RollingConvention)

public DateTime Advance(
DateTime date,
Period period,
RollingConvention convention
);

Implements

IBusinessCalendar.Advance

See Also

CalendarBase Class | Stochastix.Business.Calendars Namespace | CalendarBase.Advance Overload List


CalendarBase.Advance Method (DateTime, Int32, TimeUnit)

public DateTime Advance(
DateTime date,
int length,
TimeUnit units
);

Implements

IBusinessCalendar.Advance

See Also

CalendarBase Class | Stochastix.Business.Calendars Namespace | CalendarBase.Advance Overload List


CalendarBase.Advance Method (DateTime, Int32, TimeUnit, RollingConvention)

public DateTime Advance(
DateTime date,
int length,
TimeUnit units,
RollingConvention convention
);

Implements

IBusinessCalendar.Advance

See Also

CalendarBase Class | Stochastix.Business.Calendars Namespace | CalendarBase.Advance Overload List


CalendarBase.Advance Method (DateTime, TimeSpan)

public DateTime Advance(
DateTime date,
TimeSpan interval
);

Implements

IBusinessCalendar.Advance

See Also

CalendarBase Class | Stochastix.Business.Calendars Namespace | CalendarBase.Advance Overload List


CalendarBase.Advance Method (DateTime, TimeSpan, RollingConvention)

public DateTime Advance(
DateTime date,
TimeSpan interval,
RollingConvention convention
);

Implements

IBusinessCalendar.Advance

See Also

CalendarBase Class | Stochastix.Business.Calendars Namespace | CalendarBase.Advance Overload List


CalendarBase.IsBusinessDay Method

public abstract bool IsBusinessDay(
DateTime date
);

Implements

IBusinessCalendar.IsBusinessDay

See Also

CalendarBase Class | Stochastix.Business.Calendars Namespace


CalendarBase.IsHoliday Method

public bool IsHoliday(
DateTime date
);

Implements

IBusinessCalendar.IsHoliday

See Also

CalendarBase Class | Stochastix.Business.Calendars Namespace


Roll Method

An NDoc Documented Class Library

CalendarBase.Roll Method

Overload List

public DateTime Roll(DateTime);

public DateTime Roll(DateTime,RollingConvention);

See Also

CalendarBase Class | Stochastix.Business.Calendars Namespace


CalendarBase.Roll Method (DateTime)

public DateTime Roll(
DateTime date
);

Implements

IBusinessCalendar.Roll

See Also

CalendarBase Class | Stochastix.Business.Calendars Namespace | CalendarBase.Roll Overload List


CalendarBase.Roll Method (DateTime, RollingConvention)

public DateTime Roll(
DateTime date,
RollingConvention convention
);

Implements

IBusinessCalendar.Roll

See Also

CalendarBase Class | Stochastix.Business.Calendars Namespace | CalendarBase.Roll Overload List


CalendarBase.ToString Method

public override string ToString();

Implements

IBusinessCalendar.ToString

See Also

CalendarBase Class | Stochastix.Business.Calendars Namespace


Frankfurt Class

For a list of all members of this type, see Frankfurt Members.

System.Object
Stochastix.Business.Calendars.CalendarBase
Stochastix.Business.Calendars.WesternCalendarBase
Stochastix.Business.Calendars.Frankfurt

public sealed class Frankfurt : WesternCalendarBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Stochastix.Business.Calendars

Assembly: Stochastix.Business (in Stochastix.Business.dll)

See Also

Frankfurt Members | Stochastix.Business.Calendars Namespace


Frankfurt Members

Frankfurt overview

Public Static Fields

Instance

Public Instance Constructors

Frankfurt Constructor Initializes a new instance of the Frankfurt class.

Public Instance Properties

Calendar (inherited from CalendarBase)
Culture (inherited from CalendarBase)
Region (inherited from CalendarBase)

Public Instance Methods

Advance (inherited from CalendarBase) | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsBusinessDay (inherited from WesternCalendarBase) |
IsHoliday (inherited from CalendarBase) |
Roll (inherited from CalendarBase) | Overloaded.
ToString (inherited from CalendarBase) |

See Also

Frankfurt Class | Stochastix.Business.Calendars Namespace


Frankfurt Constructor

NOTE: This constructor is now obsolete.

Use Frankfurt.Instance in .NET applications.

Initializes a new instance of the Frankfurt class.

public Frankfurt();

See Also

Frankfurt Class | Stochastix.Business.Calendars Namespace


Frankfurt Fields

The fields of the Frankfurt class are listed below. For a complete list of Frankfurt class members, see the Frankfurt Members topic.

Public Static Fields

Instance

See Also

Frankfurt Class | Stochastix.Business.Calendars Namespace


Frankfurt.Instance Field

public static readonly IBusinessCalendar Instance;

See Also

Frankfurt Class | Stochastix.Business.Calendars Namespace


Helsinki Class

For a list of all members of this type, see Helsinki Members.

System.Object
Stochastix.Business.Calendars.CalendarBase
Stochastix.Business.Calendars.WesternCalendarBase
Stochastix.Business.Calendars.Helsinki

public sealed class Helsinki : WesternCalendarBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Stochastix.Business.Calendars

Assembly: Stochastix.Business (in Stochastix.Business.dll)

See Also

Helsinki Members | Stochastix.Business.Calendars Namespace


Helsinki Members

Helsinki overview

Public Static Fields

Instance

Public Instance Constructors

Helsinki Constructor Initializes a new instance of the Helsinki class.

Public Instance Properties

Calendar (inherited from CalendarBase)
Culture (inherited from CalendarBase)
Region (inherited from CalendarBase)

Public Instance Methods

Advance (inherited from CalendarBase) | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsBusinessDay (inherited from WesternCalendarBase) |
IsHoliday (inherited from CalendarBase) |
Roll (inherited from CalendarBase) | Overloaded.
ToString (inherited from CalendarBase) |

See Also

Helsinki Class | Stochastix.Business.Calendars Namespace


Helsinki Constructor

NOTE: This constructor is now obsolete.

Use Helsinki.Instance in .NET applications.

Initializes a new instance of the Helsinki class.

public Helsinki();

See Also

Helsinki Class | Stochastix.Business.Calendars Namespace


Helsinki Fields

The fields of the Helsinki class are listed below. For a complete list of Helsinki class members, see the Helsinki Members topic.

Public Static Fields

Instance

See Also

Helsinki Class | Stochastix.Business.Calendars Namespace


Helsinki.Instance Field

public static readonly IBusinessCalendar Instance;

See Also

Helsinki Class | Stochastix.Business.Calendars Namespace


Johannesburg Class

For a list of all members of this type, see Johannesburg Members.

System.Object
Stochastix.Business.Calendars.CalendarBase
Stochastix.Business.Calendars.WesternCalendarBase
Stochastix.Business.Calendars.Johannesburg

public sealed class Johannesburg : WesternCalendarBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Stochastix.Business.Calendars

Assembly: Stochastix.Business (in Stochastix.Business.dll)

See Also

Johannesburg Members | Stochastix.Business.Calendars Namespace


Johannesburg Members

Johannesburg overview

Public Static Fields

Instance

Public Instance Constructors

Johannesburg Constructor Initializes a new instance of the Johannesburg class.

Public Instance Properties

Calendar (inherited from CalendarBase)
Culture (inherited from CalendarBase)
Region (inherited from CalendarBase)

Public Instance Methods

Advance (inherited from CalendarBase) | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsBusinessDay (inherited from WesternCalendarBase) |
IsHoliday (inherited from CalendarBase) |
Roll (inherited from CalendarBase) | Overloaded.
ToString (inherited from CalendarBase) |

See Also

Johannesburg Class | Stochastix.Business.Calendars Namespace


Johannesburg Constructor

NOTE: This constructor is now obsolete.

Use Johannesburg.Instance in .NET applications.

Initializes a new instance of the Johannesburg class.

public Johannesburg();

See Also

Johannesburg Class | Stochastix.Business.Calendars Namespace


Johannesburg Fields

The fields of the Johannesburg class are listed below. For a complete list of Johannesburg class members, see the Johannesburg Members topic.

Public Static Fields

Instance

See Also

Johannesburg Class | Stochastix.Business.Calendars Namespace


Johannesburg.Instance Field

public static readonly IBusinessCalendar Instance;

See Also

Johannesburg Class | Stochastix.Business.Calendars Namespace


JointCalendar Class

For a list of all members of this type, see JointCalendar Members.

System.Object
Stochastix.Business.Calendars.CalendarBase
Stochastix.Business.Calendars.JointCalendar

public sealed class JointCalendar : CalendarBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Stochastix.Business.Calendars

Assembly: Stochastix.Business (in Stochastix.Business.dll)

See Also

JointCalendar Members | Stochastix.Business.Calendars Namespace


JointCalendar Members

JointCalendar overview

Public Static Methods

Create Overloaded.

Public Instance Constructors

JointCalendar Overloaded. Initializes a new instance of the JointCalendar class.

Public Instance Properties

Calendar (inherited from CalendarBase)
Culture (inherited from CalendarBase)
Region (inherited from CalendarBase)

Public Instance Methods

Advance (inherited from CalendarBase) | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsBusinessDay |
IsHoliday (inherited from CalendarBase) |
Roll (inherited from CalendarBase) | Overloaded.
ToString (inherited from CalendarBase) |

See Also

JointCalendar Class | Stochastix.Business.Calendars Namespace


JointCalendar Constructor

Overload List

public JointCalendar(IBusinessCalendar,IBusinessCalendar);

public JointCalendar(IBusinessCalendar,IBusinessCalendar,string);

public JointCalendar(IBusinessCalendar,IBusinessCalendar,string,Rule);

See Also

JointCalendar Class | Stochastix.Business.Calendars Namespace


JointCalendar Constructor (IBusinessCalendar, IBusinessCalendar)

public JointCalendar(
IBusinessCalendar mainCalendar,
IBusinessCalendar otherCalendar
);

See Also

JointCalendar Class | Stochastix.Business.Calendars Namespace | JointCalendar Constructor Overload List


JointCalendar Constructor (IBusinessCalendar, IBusinessCalendar, String)

public JointCalendar(
IBusinessCalendar mainCalendar,
IBusinessCalendar otherCalendar,
string name
);

See Also

JointCalendar Class | Stochastix.Business.Calendars Namespace | JointCalendar Constructor Overload List


JointCalendar Constructor (IBusinessCalendar, IBusinessCalendar, String, Rule)

public JointCalendar(
IBusinessCalendar mainCalendar,
IBusinessCalendar otherCalendar,
string name,
Rule rule
);

See Also

JointCalendar Class | Stochastix.Business.Calendars Namespace | JointCalendar Constructor Overload List


JointCalendar Methods

The methods of the JointCalendar class are listed below. For a complete list of JointCalendar class members, see the JointCalendar Members topic.

Public Static Methods

Create Overloaded.

Public Instance Methods

Advance (inherited from CalendarBase) | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsBusinessDay |
IsHoliday (inherited from CalendarBase) |
Roll (inherited from CalendarBase) | Overloaded.
ToString (inherited from CalendarBase) |

See Also

JointCalendar Class | Stochastix.Business.Calendars Namespace


Create Method

An NDoc Documented Class Library

JointCalendar.Create Method

Overload List

public static IBusinessCalendar Create(IBusinessCalendar[],string);

public static IBusinessCalendar Create(IBusinessCalendar[],string,Rule);

See Also

JointCalendar Class | Stochastix.Business.Calendars Namespace


JointCalendar.Create Method (IBusinessCalendar[], String)

public static IBusinessCalendar Create(
IBusinessCalendar[] calendars,
string name
);

See Also

JointCalendar Class | Stochastix.Business.Calendars Namespace | JointCalendar.Create Overload List


JointCalendar.Create Method (IBusinessCalendar[], String, Rule)

public static IBusinessCalendar Create(
IBusinessCalendar[] calendars,
string name,
Rule rule
);

See Also

JointCalendar Class | Stochastix.Business.Calendars Namespace | JointCalendar.Create Overload List


JointCalendar.IsBusinessDay Method

public override bool IsBusinessDay(
DateTime date
);

Implements

IBusinessCalendar.IsBusinessDay

See Also

JointCalendar Class | Stochastix.Business.Calendars Namespace


JointCalendar.Rule Enumeration

public enum JointCalendar.Rule

Members

Member Name | Description
Holidays |
BusinessDays |

Requirements

Namespace: Stochastix.Business.Calendars

Assembly: Stochastix.Business (in Stochastix.Business.dll)

See Also

Stochastix.Business.Calendars Namespace


London Class

For a list of all members of this type, see London Members.

System.Object
Stochastix.Business.Calendars.CalendarBase
Stochastix.Business.Calendars.WesternCalendarBase
Stochastix.Business.Calendars.London

public sealed class London : WesternCalendarBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Stochastix.Business.Calendars

Assembly: Stochastix.Business (in Stochastix.Business.dll)

See Also

London Members | Stochastix.Business.Calendars Namespace


London Members

London overview

Public Static Fields

Instance

Public Instance Constructors

London Constructor Initializes a new instance of the London class.

Public Instance Properties

Calendar (inherited from CalendarBase)
Culture (inherited from CalendarBase)
Region (inherited from CalendarBase)

Public Instance Methods

Advance (inherited from CalendarBase) | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsBusinessDay (inherited from WesternCalendarBase) |
IsHoliday (inherited from CalendarBase) |
Roll (inherited from CalendarBase) | Overloaded.
ToString (inherited from CalendarBase) |

See Also

London Class | Stochastix.Business.Calendars Namespace


London Constructor

NOTE: This constructor is now obsolete.

Use London.Instance in .NET applications.

Initializes a new instance of the London class.

public London();

See Also

London Class | Stochastix.Business.Calendars Namespace


London Fields

The fields of the London class are listed below. For a complete list of London class members, see the London Members topic.

Public Static Fields

Instance

See Also

London Class | Stochastix.Business.Calendars Namespace


London.Instance Field

public static readonly IBusinessCalendar Instance;

See Also

London Class | Stochastix.Business.Calendars Namespace


Milan Class

For a list of all members of this type, see Milan Members.

System.Object
Stochastix.Business.Calendars.CalendarBase
Stochastix.Business.Calendars.WesternCalendarBase
Stochastix.Business.Calendars.Milan

public sealed class Milan : WesternCalendarBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Stochastix.Business.Calendars

Assembly: Stochastix.Business (in Stochastix.Business.dll)

See Also

Milan Members | Stochastix.Business.Calendars Namespace


Milan Members

Milan overview

Public Static Fields

Instance

Public Instance Constructors

Milan Constructor Initializes a new instance of the Milan class.

Public Instance Properties

Calendar (inherited from CalendarBase)
Culture (inherited from CalendarBase)
Region (inherited from CalendarBase)

Public Instance Methods

Advance (inherited from CalendarBase) | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsBusinessDay (inherited from WesternCalendarBase) |
IsHoliday (inherited from CalendarBase) |
Roll (inherited from CalendarBase) | Overloaded.
ToString (inherited from CalendarBase) |

See Also

Milan Class | Stochastix.Business.Calendars Namespace


Milan Constructor

NOTE: This constructor is now obsolete.

Use Milan.Instance in .NET applications.

Initializes a new instance of the Milan class.

public Milan();

See Also

Milan Class | Stochastix.Business.Calendars Namespace


Milan Fields

The fields of the Milan class are listed below. For a complete list of Milan class members, see the Milan Members topic.

Public Static Fields

Instance

See Also

Milan Class | Stochastix.Business.Calendars Namespace


Milan.Instance Field

public static readonly IBusinessCalendar Instance;

See Also

Milan Class | Stochastix.Business.Calendars Namespace


Month Enumeration

public enum Month

Members

Member Name | Description
January |
February |
March |
April |
May |
June |
July |
August |
September |
October |
November |
December |

Requirements

Namespace: Stochastix.Business.Calendars

Assembly: Stochastix.Business (in Stochastix.Business.dll)

See Also

Stochastix.Business.Calendars Namespace


NewYork Class

For a list of all members of this type, see NewYork Members.

System.Object
Stochastix.Business.Calendars.CalendarBase
Stochastix.Business.Calendars.WesternCalendarBase
Stochastix.Business.Calendars.NewYork

public sealed class NewYork : WesternCalendarBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Stochastix.Business.Calendars

Assembly: Stochastix.Business (in Stochastix.Business.dll)

See Also

NewYork Members | Stochastix.Business.Calendars Namespace


NewYork Members

NewYork overview

Public Static Fields

Instance

Public Instance Constructors

NewYork Constructor Initializes a new instance of the NewYork class.

Public Instance Properties

Calendar (inherited from CalendarBase)
Culture (inherited from CalendarBase)
Region (inherited from CalendarBase)

Public Instance Methods

Advance (inherited from CalendarBase) | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsBusinessDay (inherited from WesternCalendarBase) |
IsHoliday (inherited from CalendarBase) |
Roll (inherited from CalendarBase) | Overloaded.
ToString (inherited from CalendarBase) |

See Also

NewYork Class | Stochastix.Business.Calendars Namespace


NewYork Constructor

NOTE: This constructor is now obsolete.

Use NewYork.Instance in .NET applications.

Initializes a new instance of the NewYork class.

public NewYork();

See Also

NewYork Class | Stochastix.Business.Calendars Namespace


NewYork Fields

The fields of the NewYork class are listed below. For a complete list of NewYork class members, see the NewYork Members topic.

Public Static Fields

Instance

See Also

NewYork Class | Stochastix.Business.Calendars Namespace


NewYork.Instance Field

public static readonly IBusinessCalendar Instance;

See Also

NewYork Class | Stochastix.Business.Calendars Namespace


Oslo Class

For a list of all members of this type, see Oslo Members.

System.Object
Stochastix.Business.Calendars.CalendarBase
Stochastix.Business.Calendars.WesternCalendarBase
Stochastix.Business.Calendars.Oslo

public sealed class Oslo : WesternCalendarBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Stochastix.Business.Calendars

Assembly: Stochastix.Business (in Stochastix.Business.dll)

See Also

Oslo Members | Stochastix.Business.Calendars Namespace


Oslo Members

Oslo overview

Public Static Fields

Instance

Public Instance Constructors

Oslo Constructor Initializes a new instance of the Oslo class.

Public Instance Properties

Calendar (inherited from CalendarBase)
Culture (inherited from CalendarBase)
Region (inherited from CalendarBase)

Public Instance Methods

Advance (inherited from CalendarBase) | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsBusinessDay (inherited from WesternCalendarBase) |
IsHoliday (inherited from CalendarBase) |
Roll (inherited from CalendarBase) | Overloaded.
ToString (inherited from CalendarBase) |

See Also

Oslo Class | Stochastix.Business.Calendars Namespace


Oslo Constructor

NOTE: This constructor is now obsolete.

Use Oslo.Instance in .NET applications.

Initializes a new instance of the Oslo class.

public Oslo();

See Also

Oslo Class | Stochastix.Business.Calendars Namespace


Oslo Fields

The fields of the Oslo class are listed below. For a complete list of Oslo class members, see the Oslo Members topic.

Public Static Fields

Instance

See Also

Oslo Class | Stochastix.Business.Calendars Namespace


Oslo.Instance Field

public static readonly IBusinessCalendar Instance;

See Also

Oslo Class | Stochastix.Business.Calendars Namespace


Stockholm Class

For a list of all members of this type, see Stockholm Members.

System.Object
Stochastix.Business.Calendars.CalendarBase
Stochastix.Business.Calendars.WesternCalendarBase
Stochastix.Business.Calendars.Stockholm

public sealed class Stockholm : WesternCalendarBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Stochastix.Business.Calendars

Assembly: Stochastix.Business (in Stochastix.Business.dll)

See Also

Stockholm Members | Stochastix.Business.Calendars Namespace


Stockholm Members

Stockholm overview

Public Static Fields

Instance

Public Instance Constructors

Stockholm Constructor Initializes a new instance of the Stockholm class.

Public Instance Properties

Calendar (inherited from CalendarBase)
Culture (inherited from CalendarBase)
Region (inherited from CalendarBase)

Public Instance Methods

Advance (inherited from CalendarBase) | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsBusinessDay (inherited from WesternCalendarBase) |
IsHoliday (inherited from CalendarBase) |
Roll (inherited from CalendarBase) | Overloaded.
ToString (inherited from CalendarBase) |

See Also

Stockholm Class | Stochastix.Business.Calendars Namespace


Stockholm Constructor

NOTE: This constructor is now obsolete.

Use Stockholm.Instance in .NET applications.

Initializes a new instance of the Stockholm class.

public Stockholm();

See Also

Stockholm Class | Stochastix.Business.Calendars Namespace


Stockholm Fields

The fields of the Stockholm class are listed below. For a complete list of Stockholm class members, see the Stockholm Members topic.

Public Static Fields

Instance

See Also

Stockholm Class | Stochastix.Business.Calendars Namespace


Stockholm.Instance Field

public static readonly IBusinessCalendar Instance;

See Also

Stockholm Class | Stochastix.Business.Calendars Namespace


Sydney Class

For a list of all members of this type, see Sydney Members.

System.Object
Stochastix.Business.Calendars.CalendarBase
Stochastix.Business.Calendars.WesternCalendarBase
Stochastix.Business.Calendars.Sydney

public sealed class Sydney : WesternCalendarBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Stochastix.Business.Calendars

Assembly: Stochastix.Business (in Stochastix.Business.dll)

See Also

Sydney Members | Stochastix.Business.Calendars Namespace


Sydney Members

Sydney overview

Public Static Fields

Instance

Public Instance Constructors

Sydney Constructor Initializes a new instance of the Sydney class.

Public Instance Properties

Calendar (inherited from CalendarBase)
Culture (inherited from CalendarBase)
Region (inherited from CalendarBase)

Public Instance Methods

Advance (inherited from CalendarBase) | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsBusinessDay (inherited from WesternCalendarBase) |
IsHoliday (inherited from CalendarBase) |
Roll (inherited from CalendarBase) | Overloaded.
ToString (inherited from CalendarBase) |

See Also

Sydney Class | Stochastix.Business.Calendars Namespace


Sydney Constructor

NOTE: This constructor is now obsolete.

Use Sydney.Instance in .NET applications.

Initializes a new instance of the Sydney class.

public Sydney();

See Also

Sydney Class | Stochastix.Business.Calendars Namespace


Sydney Fields

The fields of the Sydney class are listed below. For a complete list of Sydney class members, see the Sydney Members topic.

Public Static Fields

Instance

See Also

Sydney Class | Stochastix.Business.Calendars Namespace


Sydney.Instance Field

public static readonly IBusinessCalendar Instance;

See Also

Sydney Class | Stochastix.Business.Calendars Namespace


TARGET Class

For a list of all members of this type, see TARGET Members.

System.Object
Stochastix.Business.Calendars.CalendarBase
Stochastix.Business.Calendars.WesternCalendarBase
Stochastix.Business.Calendars.TARGET

public sealed class TARGET : WesternCalendarBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Stochastix.Business.Calendars

Assembly: Stochastix.Business (in Stochastix.Business.dll)

See Also

TARGET Members | Stochastix.Business.Calendars Namespace


TARGET Members

TARGET overview

Public Static Fields

Instance

Public Instance Constructors

TARGET Constructor Initializes a new instance of the TARGET class.

Public Instance Properties

Calendar (inherited from CalendarBase)
Culture (inherited from CalendarBase)
Region (inherited from CalendarBase)

Public Instance Methods

Advance (inherited from CalendarBase) | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsBusinessDay (inherited from WesternCalendarBase) |
IsHoliday (inherited from CalendarBase) |
Roll (inherited from CalendarBase) | Overloaded.
ToString (inherited from CalendarBase) |

See Also

TARGET Class | Stochastix.Business.Calendars Namespace


TARGET Constructor

NOTE: This constructor is now obsolete.

Use TARGET.Instance in .NET applications.

Initializes a new instance of the TARGET class.

public TARGET();

See Also

TARGET Class | Stochastix.Business.Calendars Namespace


TARGET Fields

The fields of the TARGET class are listed below. For a complete list of TARGET class members, see the TARGET Members topic.

Public Static Fields

Instance

See Also

TARGET Class | Stochastix.Business.Calendars Namespace


TARGET.Instance Field

public static readonly IBusinessCalendar Instance;

See Also

TARGET Class | Stochastix.Business.Calendars Namespace


Tokyo Class

For a list of all members of this type, see Tokyo Members.

System.Object
Stochastix.Business.Calendars.CalendarBase
Stochastix.Business.Calendars.Tokyo

public sealed class Tokyo : CalendarBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Stochastix.Business.Calendars

Assembly: Stochastix.Business (in Stochastix.Business.dll)

See Also

Tokyo Members | Stochastix.Business.Calendars Namespace


Tokyo Members

Tokyo overview

Public Static Fields

Instance

Public Static Methods

EquinoxTables

Public Instance Constructors

Tokyo Constructor Initializes a new instance of the Tokyo class.

Public Instance Properties

Calendar (inherited from CalendarBase)
Culture (inherited from CalendarBase)
Region (inherited from CalendarBase)

Public Instance Methods

Advance (inherited from CalendarBase) | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsBusinessDay |
IsHoliday (inherited from CalendarBase) |
Roll (inherited from CalendarBase) | Overloaded.
ToString (inherited from CalendarBase) |

See Also

Tokyo Class | Stochastix.Business.Calendars Namespace


Tokyo Constructor

NOTE: This constructor is now obsolete.

Use Tokyo.Instance in .NET applications.

Initializes a new instance of the Tokyo class.

public Tokyo();

See Also

Tokyo Class | Stochastix.Business.Calendars Namespace


Tokyo Fields

The fields of the Tokyo class are listed below. For a complete list of Tokyo class members, see the Tokyo Members topic.

Public Static Fields

Instance

See Also

Tokyo Class | Stochastix.Business.Calendars Namespace


Tokyo.Instance Field

public static readonly IBusinessCalendar Instance;

See Also

Tokyo Class | Stochastix.Business.Calendars Namespace


Tokyo Methods

The methods of the Tokyo class are listed below. For a complete list of Tokyo class members, see the Tokyo Members topic.

Public Static Methods

EquinoxTables

Public Instance Methods

Advance (inherited from CalendarBase) | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsBusinessDay |
IsHoliday (inherited from CalendarBase) |
Roll (inherited from CalendarBase) | Overloaded.
ToString (inherited from CalendarBase) |

See Also

Tokyo Class | Stochastix.Business.Calendars Namespace


Tokyo.EquinoxTables Method

public static string EquinoxTables(
int firstYear,
int lastYear
);

See Also

Tokyo Class | Stochastix.Business.Calendars Namespace


Tokyo.IsBusinessDay Method

public override bool IsBusinessDay(
DateTime date
);

Implements

IBusinessCalendar.IsBusinessDay

See Also

Tokyo Class | Stochastix.Business.Calendars Namespace


Toronto Class

For a list of all members of this type, see Toronto Members.

System.Object
Stochastix.Business.Calendars.CalendarBase
Stochastix.Business.Calendars.WesternCalendarBase
Stochastix.Business.Calendars.Toronto

public sealed class Toronto : WesternCalendarBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Stochastix.Business.Calendars

Assembly: Stochastix.Business (in Stochastix.Business.dll)

See Also

Toronto Members | Stochastix.Business.Calendars Namespace


Toronto Members

Toronto overview

Public Static Fields

Instance

Public Instance Constructors

Toronto Constructor Initializes a new instance of the Toronto class.

Public Instance Properties

Calendar (inherited from CalendarBase)
Culture (inherited from CalendarBase)
Region (inherited from CalendarBase)

Public Instance Methods

Advance (inherited from CalendarBase) | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsBusinessDay (inherited from WesternCalendarBase) |
IsHoliday (inherited from CalendarBase) |
Roll (inherited from CalendarBase) | Overloaded.
ToString (inherited from CalendarBase) |

See Also

Toronto Class | Stochastix.Business.Calendars Namespace


Toronto Constructor

NOTE: This constructor is now obsolete.

Use Toronto.Instance in .NET applications.

Initializes a new instance of the Toronto class.

public Toronto();

See Also

Toronto Class | Stochastix.Business.Calendars Namespace


Toronto Fields

The fields of the Toronto class are listed below. For a complete list of Toronto class members, see the Toronto Members topic.

Public Static Fields

Instance

See Also

Toronto Class | Stochastix.Business.Calendars Namespace


Toronto.Instance Field

public static readonly IBusinessCalendar Instance;

See Also

Toronto Class | Stochastix.Business.Calendars Namespace


Warsaw Class

For a list of all members of this type, see Warsaw Members.

System.Object
Stochastix.Business.Calendars.CalendarBase
Stochastix.Business.Calendars.WesternCalendarBase
Stochastix.Business.Calendars.Warsaw

public sealed class Warsaw : WesternCalendarBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Stochastix.Business.Calendars

Assembly: Stochastix.Business (in Stochastix.Business.dll)

See Also

Warsaw Members | Stochastix.Business.Calendars Namespace


Warsaw Members

Warsaw overview

Public Static Fields

Instance

Public Instance Constructors

Warsaw Constructor Initializes a new instance of the Warsaw class.

Public Instance Properties

Calendar (inherited from CalendarBase)
Culture (inherited from CalendarBase)
Region (inherited from CalendarBase)

Public Instance Methods

Advance (inherited from CalendarBase) | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsBusinessDay (inherited from WesternCalendarBase) |
IsHoliday (inherited from CalendarBase) |
Roll (inherited from CalendarBase) | Overloaded.
ToString (inherited from CalendarBase) |

See Also

Warsaw Class | Stochastix.Business.Calendars Namespace


Warsaw Constructor

NOTE: This constructor is now obsolete.

Use Warsaw.Instance in .NET applications.

Initializes a new instance of the Warsaw class.

public Warsaw();

See Also

Warsaw Class | Stochastix.Business.Calendars Namespace


Warsaw Fields

The fields of the Warsaw class are listed below. For a complete list of Warsaw class members, see the Warsaw Members topic.

Public Static Fields

Instance

See Also

Warsaw Class | Stochastix.Business.Calendars Namespace


Warsaw.Instance Field

public static readonly IBusinessCalendar Instance;

See Also

Warsaw Class | Stochastix.Business.Calendars Namespace


Wellington Class

For a list of all members of this type, see Wellington Members.

System.Object
Stochastix.Business.Calendars.CalendarBase
Stochastix.Business.Calendars.WesternCalendarBase
Stochastix.Business.Calendars.Wellington

public sealed class Wellington : WesternCalendarBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Stochastix.Business.Calendars

Assembly: Stochastix.Business (in Stochastix.Business.dll)

See Also

Wellington Members | Stochastix.Business.Calendars Namespace


Wellington Members

Wellington overview

Public Static Fields

Instance

Public Instance Constructors

Wellington Constructor Initializes a new instance of the Wellington class.

Public Instance Properties

Calendar (inherited from CalendarBase)
Culture (inherited from CalendarBase)
Region (inherited from CalendarBase)

Public Instance Methods

Advance (inherited from CalendarBase) | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsBusinessDay (inherited from WesternCalendarBase) |
IsHoliday (inherited from CalendarBase) |
Roll (inherited from CalendarBase) | Overloaded.
ToString (inherited from CalendarBase) |

See Also

Wellington Class | Stochastix.Business.Calendars Namespace


Wellington Constructor

NOTE: This constructor is now obsolete.

Use Wellington.Instance in .NET applications.

Initializes a new instance of the Wellington class.

public Wellington();

See Also

Wellington Class | Stochastix.Business.Calendars Namespace


Wellington Fields

The fields of the Wellington class are listed below. For a complete list of Wellington class members, see the Wellington Members topic.

Public Static Fields

Instance

See Also

Wellington Class | Stochastix.Business.Calendars Namespace


Wellington.Instance Field

public static readonly IBusinessCalendar Instance;

See Also

Wellington Class | Stochastix.Business.Calendars Namespace


WesternCalendarBase Class

For a list of all members of this type, see WesternCalendarBase Members.

System.Object
Stochastix.Business.Calendars.CalendarBase
Stochastix.Business.Calendars.WesternCalendarBase
Derived types

public abstract class WesternCalendarBase : CalendarBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Stochastix.Business.Calendars

Assembly: Stochastix.Business (in Stochastix.Business.dll)

See Also

WesternCalendarBase Members | Stochastix.Business.Calendars Namespace


WesternCalendarBase Members

WesternCalendarBase overview

Protected Static Methods

EasterMonday

Public Instance Properties

Calendar (inherited from CalendarBase)
Culture (inherited from CalendarBase)
Region (inherited from CalendarBase)

Public Instance Methods

Advance (inherited from CalendarBase) | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsBusinessDay | Overloaded.
IsHoliday (inherited from CalendarBase) |
Roll (inherited from CalendarBase) | Overloaded.
ToString (inherited from CalendarBase) |

Protected Instance Constructors

WesternCalendarBase Constructor

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
IsBusinessDay | Overloaded.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WesternCalendarBase Class | Stochastix.Business.Calendars Namespace


WesternCalendarBase Constructor

protected WesternCalendarBase(
string name,
CultureInfo culture
);

See Also

WesternCalendarBase Class | Stochastix.Business.Calendars Namespace


WesternCalendarBase Methods

The methods of the WesternCalendarBase class are listed below. For a complete list of WesternCalendarBase class members, see the WesternCalendarBase Members topic.

Protected Static Methods

EasterMonday

Public Instance Methods

Advance (inherited from CalendarBase) | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsBusinessDay | Overloaded.
IsHoliday (inherited from CalendarBase) |
Roll (inherited from CalendarBase) | Overloaded.
ToString (inherited from CalendarBase) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
IsBusinessDay | Overloaded.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WesternCalendarBase Class | Stochastix.Business.Calendars Namespace


WesternCalendarBase.EasterMonday Method

protected static int EasterMonday(
int year
);

See Also

WesternCalendarBase Class | Stochastix.Business.Calendars Namespace


IsBusinessDay Method

An NDoc Documented Class Library

WesternCalendarBase.IsBusinessDay Method

Overload List

public override bool IsBusinessDay(DateTime);

protected abstract bool IsBusinessDay(int,Month,int,DayOfWeek,int,int);

See Also

WesternCalendarBase Class | Stochastix.Business.Calendars Namespace


WesternCalendarBase.IsBusinessDay Method (DateTime)

public override bool IsBusinessDay(
DateTime date
);

Implements

IBusinessCalendar.IsBusinessDay

See Also

WesternCalendarBase Class | Stochastix.Business.Calendars Namespace | WesternCalendarBase.IsBusinessDay Overload List


WesternCalendarBase.IsBusinessDay Method (Int32, Month, Int32, DayOfWeek, Int32, Int32)

protected abstract bool IsBusinessDay(
int day,
Month month,
int year,
DayOfWeek w,
int dayOfYear,
int easterMonday
);

See Also

WesternCalendarBase Class | Stochastix.Business.Calendars Namespace | WesternCalendarBase.IsBusinessDay Overload List


Zurich Class

For a list of all members of this type, see Zurich Members.

System.Object
Stochastix.Business.Calendars.CalendarBase
Stochastix.Business.Calendars.WesternCalendarBase
Stochastix.Business.Calendars.Zurich

public sealed class Zurich : WesternCalendarBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Stochastix.Business.Calendars

Assembly: Stochastix.Business (in Stochastix.Business.dll)

See Also

Zurich Members | Stochastix.Business.Calendars Namespace


Zurich Members

Zurich overview

Public Static Fields

Instance

Public Instance Constructors

Zurich Constructor Initializes a new instance of the Zurich class.

Public Instance Properties

Calendar (inherited from CalendarBase)
Culture (inherited from CalendarBase)
Region (inherited from CalendarBase)

Public Instance Methods

Advance (inherited from CalendarBase) | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsBusinessDay (inherited from WesternCalendarBase) |
IsHoliday (inherited from CalendarBase) |
Roll (inherited from CalendarBase) | Overloaded.
ToString (inherited from CalendarBase) |

See Also

Zurich Class | Stochastix.Business.Calendars Namespace


Zurich Constructor

NOTE: This constructor is now obsolete.

Use Zurich.Instance in .NET applications.

Initializes a new instance of the Zurich class.

public Zurich();

See Also

Zurich Class | Stochastix.Business.Calendars Namespace


Zurich Fields

The fields of the Zurich class are listed below. For a complete list of Zurich class members, see the Zurich Members topic.

Public Static Fields

Instance

See Also

Zurich Class | Stochastix.Business.Calendars Namespace


Zurich.Instance Field

public static readonly IBusinessCalendar Instance;

See Also

Zurich Class | Stochastix.Business.Calendars Namespace


Stochastix.Business.DayCounters

An NDoc Documented Class Library

Stochastix.Business.DayCounters Namespace

Namespace hierarchy

Classes

Class | Description
Actual360 |
Actual365 |
ActualActualAFB |
ActualActualISDA |
ActualActualISMA |
DayCounterBase |
Thirty360EU |
Thirty360Italian |
Thirty360US |

Enumerations

Enumeration | Description
DayCounterBase.Convention |


Actual360 Class

For a list of all members of this type, see Actual360 Members.

System.Object
Stochastix.Business.DayCounters.DayCounterBase
Stochastix.Business.DayCounters.Actual360

public sealed class Actual360 : DayCounterBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Stochastix.Business.DayCounters

Assembly: Stochastix.Business (in Stochastix.Business.dll)

See Also

Actual360 Members | Stochastix.Business.DayCounters Namespace


Actual360 Members

Actual360 overview

Public Static Fields

Instance

Public Instance Constructors

Actual360 Constructor Initializes a new instance of the Actual360 class.

Public Instance Methods

DayCount (inherited from DayCounterBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from DayCounterBase) |
YearFraction (inherited from DayCounterBase) | Overloaded.

See Also

Actual360 Class | Stochastix.Business.DayCounters Namespace


Actual360 Constructor

NOTE: This constructor is now obsolete.

Use the static Instance member in .NET applications.

Initializes a new instance of the Actual360 class.

public Actual360();

See Also

Actual360 Class | Stochastix.Business.DayCounters Namespace


Actual360 Fields

The fields of the Actual360 class are listed below. For a complete list of Actual360 class members, see the Actual360 Members topic.

Public Static Fields

Instance

See Also

Actual360 Class | Stochastix.Business.DayCounters Namespace


Actual360.Instance Field

public static readonly Actual360 Instance;

See Also

Actual360 Class | Stochastix.Business.DayCounters Namespace


Actual365 Class

For a list of all members of this type, see Actual365 Members.

System.Object
Stochastix.Business.DayCounters.DayCounterBase
Stochastix.Business.DayCounters.Actual365

public sealed class Actual365 : DayCounterBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Stochastix.Business.DayCounters

Assembly: Stochastix.Business (in Stochastix.Business.dll)

See Also

Actual365 Members | Stochastix.Business.DayCounters Namespace


Actual365 Members

Actual365 overview

Public Static Fields

Instance

Public Instance Constructors

Actual365 Constructor Initializes a new instance of the Actual365 class.

Public Instance Methods

DayCount (inherited from DayCounterBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from DayCounterBase) |
YearFraction (inherited from DayCounterBase) | Overloaded.

See Also

Actual365 Class | Stochastix.Business.DayCounters Namespace


Actual365 Constructor

NOTE: This constructor is now obsolete.

Use the static Instance member in .NET applications.

Initializes a new instance of the Actual365 class.

public Actual365();

See Also

Actual365 Class | Stochastix.Business.DayCounters Namespace


Actual365 Fields

The fields of the Actual365 class are listed below. For a complete list of Actual365 class members, see the Actual365 Members topic.

Public Static Fields

Instance

See Also

Actual365 Class | Stochastix.Business.DayCounters Namespace


Actual365.Instance Field

public static readonly Actual365 Instance;

See Also

Actual365 Class | Stochastix.Business.DayCounters Namespace


ActualActualAFB Class

For a list of all members of this type, see ActualActualAFB Members.

System.Object
Stochastix.Business.DayCounters.DayCounterBase
Stochastix.Business.DayCounters.ActualActualAFB

public sealed class ActualActualAFB : DayCounterBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Stochastix.Business.DayCounters

Assembly: Stochastix.Business (in Stochastix.Business.dll)

See Also

ActualActualAFB Members | Stochastix.Business.DayCounters Namespace


ActualActualAFB Members

ActualActualAFB overview

Public Static Fields

Instance

Public Instance Constructors

ActualActualAFB Constructor Initializes a new instance of the ActualActualAFB class.

Public Instance Methods

DayCount (inherited from DayCounterBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from DayCounterBase) |
YearFraction (inherited from DayCounterBase) | Overloaded.

See Also

ActualActualAFB Class | Stochastix.Business.DayCounters Namespace


ActualActualAFB Constructor

NOTE: This constructor is now obsolete.

Use the static Instance member in .NET applications.

Initializes a new instance of the ActualActualAFB class.

public ActualActualAFB();

See Also

ActualActualAFB Class | Stochastix.Business.DayCounters Namespace


ActualActualAFB Fields

The fields of the ActualActualAFB class are listed below. For a complete list of ActualActualAFB class members, see the ActualActualAFB Members topic.

Public Static Fields

Instance

See Also

ActualActualAFB Class | Stochastix.Business.DayCounters Namespace


ActualActualAFB.Instance Field

public static readonly ActualActualAFB Instance;

See Also

ActualActualAFB Class | Stochastix.Business.DayCounters Namespace


ActualActualISDA Class

For a list of all members of this type, see ActualActualISDA Members.

System.Object
Stochastix.Business.DayCounters.DayCounterBase
Stochastix.Business.DayCounters.ActualActualISDA

public sealed class ActualActualISDA : DayCounterBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Stochastix.Business.DayCounters

Assembly: Stochastix.Business (in Stochastix.Business.dll)

See Also

ActualActualISDA Members | Stochastix.Business.DayCounters Namespace


ActualActualISDA Members

ActualActualISDA overview

Public Static Fields

Instance

Public Instance Constructors

ActualActualISDA Constructor Initializes a new instance of the ActualActualISDA class.

Public Instance Methods

DayCount (inherited from DayCounterBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from DayCounterBase) |
YearFraction (inherited from DayCounterBase) | Overloaded.

See Also

ActualActualISDA Class | Stochastix.Business.DayCounters Namespace


ActualActualISDA Constructor

NOTE: This constructor is now obsolete.

Use the static Instance member in .NET applications.

Initializes a new instance of the ActualActualISDA class.

public ActualActualISDA();

See Also

ActualActualISDA Class | Stochastix.Business.DayCounters Namespace


ActualActualISDA Fields

The fields of the ActualActualISDA class are listed below. For a complete list of ActualActualISDA class members, see the ActualActualISDA Members topic.

Public Static Fields

Instance

See Also

ActualActualISDA Class | Stochastix.Business.DayCounters Namespace


ActualActualISDA.Instance Field

public static readonly ActualActualISDA Instance;

See Also

ActualActualISDA Class | Stochastix.Business.DayCounters Namespace


ActualActualISMA Class

For a list of all members of this type, see ActualActualISMA Members.

System.Object
Stochastix.Business.DayCounters.DayCounterBase
Stochastix.Business.DayCounters.ActualActualISMA

public sealed class ActualActualISMA : DayCounterBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Stochastix.Business.DayCounters

Assembly: Stochastix.Business (in Stochastix.Business.dll)

See Also

ActualActualISMA Members | Stochastix.Business.DayCounters Namespace


ActualActualISMA Members

ActualActualISMA overview

Public Static Fields

Instance

Public Instance Constructors

ActualActualISMA Constructor Initializes a new instance of the ActualActualISMA class.

Public Instance Methods

DayCount (inherited from DayCounterBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from DayCounterBase) |
YearFraction (inherited from DayCounterBase) | Overloaded.

See Also

ActualActualISMA Class | Stochastix.Business.DayCounters Namespace


ActualActualISMA Constructor

NOTE: This constructor is now obsolete.

Use the static Instance member in .NET applications.

Initializes a new instance of the ActualActualISMA class.

public ActualActualISMA();

See Also

ActualActualISMA Class | Stochastix.Business.DayCounters Namespace


ActualActualISMA Fields

The fields of the ActualActualISMA class are listed below. For a complete list of ActualActualISMA class members, see the ActualActualISMA Members topic.

Public Static Fields

Instance

See Also

ActualActualISMA Class | Stochastix.Business.DayCounters Namespace


ActualActualISMA.Instance Field

public static readonly ActualActualISMA Instance;

See Also

ActualActualISMA Class | Stochastix.Business.DayCounters Namespace


DayCounterBase Class

For a list of all members of this type, see DayCounterBase Members.

System.Object
Stochastix.Business.DayCounters.DayCounterBase
Derived types

public abstract class DayCounterBase : IDayCounter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Stochastix.Business.DayCounters

Assembly: Stochastix.Business (in Stochastix.Business.dll)

See Also

DayCounterBase Members | Stochastix.Business.DayCounters Namespace


DayCounterBase Members

DayCounterBase overview

Protected Internal Static Methods

ActualDays

Public Instance Methods

DayCount |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |
YearFraction | Overloaded.

Protected Instance Constructors

DayCounterBase Overloaded. Initializes a new instance of the DayCounterBase class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
YearFractionImpl |

See Also

DayCounterBase Class | Stochastix.Business.DayCounters Namespace


DayCounterBase Constructor

Overload List

protected DayCounterBase(string);

protected DayCounterBase(string,Convention,int);

See Also

DayCounterBase Class | Stochastix.Business.DayCounters Namespace


DayCounterBase Constructor (String, Convention, Int32)

protected DayCounterBase(
string name,
Convention countConvention,
int basis
);

See Also

DayCounterBase Class | Stochastix.Business.DayCounters Namespace | DayCounterBase Constructor Overload List


DayCounterBase Constructor (String)

protected DayCounterBase(
string name
);

See Also

DayCounterBase Class | Stochastix.Business.DayCounters Namespace | DayCounterBase Constructor Overload List


DayCounterBase Methods

The methods of the DayCounterBase class are listed below. For a complete list of DayCounterBase class members, see the DayCounterBase Members topic.

Protected Internal Static Methods

ActualDays

Public Instance Methods

DayCount |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |
YearFraction | Overloaded.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
YearFractionImpl |

See Also

DayCounterBase Class | Stochastix.Business.DayCounters Namespace


DayCounterBase.ActualDays Method

protected internal static int ActualDays(
DateTime startDate,
DateTime endDate
);

See Also

DayCounterBase Class | Stochastix.Business.DayCounters Namespace


DayCounterBase.DayCount Method

public int DayCount(
DateTime startDate,
DateTime endDate
);

Implements

IDayCounter.DayCount

See Also

DayCounterBase Class | Stochastix.Business.DayCounters Namespace


DayCounterBase.ToString Method

public override string ToString();

Implements

IDayCounter.ToString

See Also

DayCounterBase Class | Stochastix.Business.DayCounters Namespace


YearFraction Method

An NDoc Documented Class Library

DayCounterBase.YearFraction Method

Overload List

public double YearFraction(DateTime,DateTime);

public double YearFraction(DateTime,DateTime,DateTime,DateTime);

See Also

DayCounterBase Class | Stochastix.Business.DayCounters Namespace


DayCounterBase.YearFraction Method (DateTime, DateTime)

public double YearFraction(
DateTime start,
DateTime end
);

Implements

IDayCounter.YearFraction

See Also

DayCounterBase Class | Stochastix.Business.DayCounters Namespace | DayCounterBase.YearFraction Overload List


DayCounterBase.YearFraction Method (DateTime, DateTime, DateTime, DateTime)

public double YearFraction(
DateTime startDate,
DateTime endDate,
DateTime refPeriodStart,
DateTime refPeriodEnd
);

Implements

IDayCounter.YearFraction

See Also

DayCounterBase Class | Stochastix.Business.DayCounters Namespace | DayCounterBase.YearFraction Overload List


DayCounterBase.YearFractionImpl Method

protected virtual double YearFractionImpl(
DateTime startDate,
DateTime endDate,
DateTime refPeriodStart,
DateTime refPeriodEnd
);

See Also

DayCounterBase Class | Stochastix.Business.DayCounters Namespace


DayCounterBase.Convention Enumeration

protected enum DayCounterBase.Convention

Members

Member Name | Description
Actual |
US |
EU |
Italian |

Requirements

Namespace: Stochastix.Business.DayCounters

Assembly: Stochastix.Business (in Stochastix.Business.dll)

See Also

Stochastix.Business.DayCounters Namespace


Thirty360EU Class

For a list of all members of this type, see Thirty360EU Members.

System.Object
Stochastix.Business.DayCounters.DayCounterBase
Stochastix.Business.DayCounters.Thirty360EU

public sealed class Thirty360EU : DayCounterBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Stochastix.Business.DayCounters

Assembly: Stochastix.Business (in Stochastix.Business.dll)

See Also

Thirty360EU Members | Stochastix.Business.DayCounters Namespace


Thirty360EU Members

Thirty360EU overview

Public Static Fields

Instance

Public Instance Constructors

Thirty360EU Constructor Initializes a new instance of the Thirty360EU class.

Public Instance Methods

DayCount (inherited from DayCounterBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from DayCounterBase) |
YearFraction (inherited from DayCounterBase) | Overloaded.

See Also

Thirty360EU Class | Stochastix.Business.DayCounters Namespace


Thirty360EU Constructor

NOTE: This constructor is now obsolete.

Use the static Instance member in .NET applications.

Initializes a new instance of the Thirty360EU class.

public Thirty360EU();

See Also

Thirty360EU Class | Stochastix.Business.DayCounters Namespace


Thirty360EU Fields

The fields of the Thirty360EU class are listed below. For a complete list of Thirty360EU class members, see the Thirty360EU Members topic.

Public Static Fields

Instance

See Also

Thirty360EU Class | Stochastix.Business.DayCounters Namespace


Thirty360EU.Instance Field

public static readonly Thirty360EU Instance;

See Also

Thirty360EU Class | Stochastix.Business.DayCounters Namespace


Thirty360Italian Class

For a list of all members of this type, see Thirty360Italian Members.

System.Object
Stochastix.Business.DayCounters.DayCounterBase
Stochastix.Business.DayCounters.Thirty360Italian

public sealed class Thirty360Italian : DayCounterBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Stochastix.Business.DayCounters

Assembly: Stochastix.Business (in Stochastix.Business.dll)

See Also

Thirty360Italian Members | Stochastix.Business.DayCounters Namespace


Thirty360Italian Members

Thirty360Italian overview

Public Static Fields

Instance

Public Instance Constructors

Thirty360Italian Constructor Initializes a new instance of the Thirty360Italian class.

Public Instance Methods

DayCount (inherited from DayCounterBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from DayCounterBase) |
YearFraction (inherited from DayCounterBase) | Overloaded.

See Also

Thirty360Italian Class | Stochastix.Business.DayCounters Namespace


Thirty360Italian Constructor

NOTE: This constructor is now obsolete.

Use the static Instance member in .NET applications.

Initializes a new instance of the Thirty360Italian class.

public Thirty360Italian();

See Also

Thirty360Italian Class | Stochastix.Business.DayCounters Namespace


Thirty360Italian Fields

The fields of the Thirty360Italian class are listed below. For a complete list of Thirty360Italian class members, see the Thirty360Italian Members topic.

Public Static Fields

Instance

See Also

Thirty360Italian Class | Stochastix.Business.DayCounters Namespace


Thirty360Italian.Instance Field

public static readonly Thirty360Italian Instance;

See Also

Thirty360Italian Class | Stochastix.Business.DayCounters Namespace


Thirty360US Class

For a list of all members of this type, see Thirty360US Members.

System.Object
Stochastix.Business.DayCounters.DayCounterBase
Stochastix.Business.DayCounters.Thirty360US

public sealed class Thirty360US : DayCounterBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Stochastix.Business.DayCounters

Assembly: Stochastix.Business (in Stochastix.Business.dll)

See Also

Thirty360US Members | Stochastix.Business.DayCounters Namespace


Thirty360US Members

Thirty360US overview

Public Static Fields

Instance

Public Instance Constructors

Thirty360US Constructor Initializes a new instance of the Thirty360US class.

Public Instance Methods

DayCount (inherited from DayCounterBase) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from DayCounterBase) |
YearFraction (inherited from DayCounterBase) | Overloaded.

See Also

Thirty360US Class | Stochastix.Business.DayCounters Namespace


Thirty360US Constructor

NOTE: This constructor is now obsolete.

Use the static Instance member in .NET applications.

Initializes a new instance of the Thirty360US class.

public Thirty360US();

See Also

Thirty360US Class | Stochastix.Business.DayCounters Namespace


Thirty360US Fields

The fields of the Thirty360US class are listed below. For a complete list of Thirty360US class members, see the Thirty360US Members topic.

Public Static Fields

Instance

See Also

Thirty360US Class | Stochastix.Business.DayCounters Namespace


Thirty360US.Instance Field

public static readonly Thirty360US Instance;

See Also

Thirty360US Class | Stochastix.Business.DayCounters Namespace


CurveClassHierarchy

An NDoc Documented Class Library

CurveClass Hierarchy

System.Object
CurveClass.CurveClass
System.ValueType
CurveClass.CurveClass.CurveIDStruct
CurveClass.CurveClass.CurveStruct
CurveClass.CurveClass.ForwardStruct
CurveClass.CurveClass.holidays

See Also

CurveClass Namespace


WesternCalendarBase Hierarchy

System.Object
CalendarBase
WesternCalendarBase
Budapest
Frankfurt
Helsinki
Johannesburg
London
Milan
NewYork
Oslo
Stockholm
Sydney
TARGET
Toronto
Warsaw
Wellington
Zurich

See Also

WesternCalendarBase Class | WesternCalendarBase Members | Stochastix.Business.Calendars Namespace


Stochastix.Business.CalendarsHierarchy

An NDoc Documented Class Library

Stochastix.Business.Calendars Hierarchy

System.Object
Stochastix.Business.Calendars.CalendarBase ---- Stochastix.Business.IBusinessCalendar
Stochastix.Business.Calendars.JointCalendar
Stochastix.Business.Calendars.Tokyo
Stochastix.Business.Calendars.WesternCalendarBase
Stochastix.Business.Calendars.Budapest
Stochastix.Business.Calendars.Frankfurt
Stochastix.Business.Calendars.Helsinki
Stochastix.Business.Calendars.Johannesburg
Stochastix.Business.Calendars.London
Stochastix.Business.Calendars.Milan
Stochastix.Business.Calendars.NewYork
Stochastix.Business.Calendars.Oslo
Stochastix.Business.Calendars.Stockholm
Stochastix.Business.Calendars.Sydney
Stochastix.Business.Calendars.TARGET
Stochastix.Business.Calendars.Toronto
Stochastix.Business.Calendars.Warsaw
Stochastix.Business.Calendars.Wellington
Stochastix.Business.Calendars.Zurich
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Stochastix.Business.Calendars.JointCalendar.Rule
Stochastix.Business.Calendars.Month

See Also

Stochastix.Business.Calendars Namespace


DayCounterBase Hierarchy

System.Object
DayCounterBase
Actual360
Actual365
ActualActualAFB
ActualActualISDA
ActualActualISMA
Thirty360EU
Thirty360Italian
Thirty360US

See Also

DayCounterBase Class | DayCounterBase Members | Stochastix.Business.DayCounters Namespace


Stochastix.Business.DayCountersHierarchy

An NDoc Documented Class Library

Stochastix.Business.DayCounters Hierarchy

System.Object
Stochastix.Business.DayCounters.DayCounterBase ---- Stochastix.Business.IDayCounter
Stochastix.Business.DayCounters.Actual360
Stochastix.Business.DayCounters.Actual365
Stochastix.Business.DayCounters.ActualActualAFB
Stochastix.Business.DayCounters.ActualActualISDA
Stochastix.Business.DayCounters.ActualActualISMA
Stochastix.Business.DayCounters.Thirty360EU
Stochastix.Business.DayCounters.Thirty360Italian
Stochastix.Business.DayCounters.Thirty360US
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Stochastix.Business.DayCounters.DayCounterBase.Convention

See Also

Stochastix.Business.DayCounters Namespace


Stochastix.BusinessHierarchy

An NDoc Documented Class Library

Stochastix.Business Hierarchy

System.Object
Stochastix.Business.IBusinessCalendar
Stochastix.Business.IDayCounter
System.ValueType
Stochastix.Business.Period
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Stochastix.Business.Currency
Stochastix.Business.RollingConvention
Stochastix.Business.TimeUnit

See Also

Stochastix.Business Namespace