CommodityStorage.Storage

An NDoc Documented Class Library

CommodityStorage.Storage Namespace

Namespace hierarchy

Classes

Class | Description
Storage | Class: Commodity storage class that values a storable commodity storage facility like natural gas storage or crude oil tank storage.

Structures

Structure | Description
Storage.CostStruct | Structure: Cost structure for injecting or withdrawing the physical commodity
Storage.DateStruct | Structure: DateStruc structure for storage date input
Storage.dynamic_vars | Structure: Dynamic_vars structure for dynamic variables: dates, market and path dependency variables
Storage.extrinsic | Structure: extrinsic structure for extrinsic valuation results
Storage.lincon | Structure: lincon structue for holding linear constraints
Storage.PrintFlagStruct | Structure: PrintFlagStruc structure of print flag inputs used for logging and debugging or for output of results for post valuation processing and analysis
Storage.Profit | Structure: Profit structure for revenue, expense and profits calculation results
Storage.Ratchets | Structure: Ratchets structure for holding injections and withdrawal ratchets
Storage.RiskAdjStruct | Structure: Lmoment RiskAdjStruct structure for risk adjusted cash flow results. This is not currrently implemented
Storage.s_trajectory | Structure: s_trajectory structure for holding optimization inputs and results
Storage.simcurve | Structure: simcurve structure for simulated prices
Storage.SS_inputs | Structure: SS_inputs structure for holding optimizer inputs of boundary conditions, linear constraints, objective function values, and other data
Storage.ss_results | Structure: ss_results structure for optimization results
Storage.StaticVars | Structure: StaticVars structure for static variables
Storage.storage_iter | Structure: storage_iter structure for holding temporary volume results over each iteration
Storage.trajectorycurve | Structure: trajectorycurve structure for trajectory curve variables and arrays
Storage.value | Structure: value structure for intrinsic, extrinsic and profit structures
Storage.volumesummary | Structure: volumesummary structure for results of physical volume transactions and statistics the summaries are by month and year

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage Class

Class: Commodity storage class that values a storable commodity storage facility like natural gas storage or crude oil tank storage.

For a list of all members of this type, see Storage Members.

System.Object
CommodityStorage.Storage.Storage

[Visual Basic]
Public Class Storage
[C#]
public class Storage
[C++]
public __gc class Storage
[JScript]
public class Storage

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

License: Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems and Economic Analytics, Limited 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 Financial.Seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is free software; you can redistribute it and/or modify it under the terms of the GNU Lesser General Public License as published by the Free Software Foundation; either version 2.1 of the License, or (at your option) any later version. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU Lesser General Public License for more details. You should have received a copy of the GNU Lesser General Public License along with this library; if not, write to the Free Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA Please email changes and enhancements to Financial.Seal@cox.net include name and email for developer recognition.

Requirements

Namespace: CommodityStorage.Storage

Assembly: CommodityStorage (in CommodityStorage.dll)

See Also

Storage Members | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage Members

Storage overview

Public Static (Shared) Fields

CONTRACTMMBTU | Constant: (public) CONTRACTMMBTU : Natural as contract size multiplier
deltastep |
LAMBDA | Constant: (public) LAMBDA : market price of risk default
LPsolveinf | Constant: (public) LPsolveinf : constant for value of infinity from lpsolve
NUMOFDAYSYEAR | Constant: (public) NUMOFDAYSYEAR : default days in year, using Stochastix.Net Business class to elimiate this variable
o_stochastix | Property: (public shared readonly) o_stochastix object for referencing Stochatix.net Business class
PriceUpperBND |
xldown | Constant: (public) xldown : constant for MSExcel xldown variable see MSDN for more information
xllastcell |
xltoright | Constant: (public) xltoright : constant for MSExcel xldown variable see MSDN for more information

Private Static Constructor

Storage Constructor Initializes the static fields of the Storage class.

Private Static (Shared) Fields

BIGPRICE | Constant: (private) BIGPRICE : Huge value to use in Linear optimizer objective function
MAXITER | Constant: (private) MAXITER : Linear optimizer time out limit
TOLER | Constant: (private) TOLER : Linear optimizer tolerance value

Public Instance Constructors

Storage Constructor Initializes a new instance of the Storage class.

Public Instance Fields

dumpconstraints | Property: (public) dumpconstraints file object debug output using logging class
dumpmembers | Property: (public) dumpmembers file object debug output using logging class
dumpobj | Property: (public) dumpobj file object debug output using logging class
dumppos | Property: (public) dumppos file object debug output using logging class
dumpresults | Property: (public) dumpresults file object debug output using logging class
dumprhs | Property: (public) dumprhs file object debug output using logging class
log | Property: (public) log object debug output using logging class
lpsolve | Property: (public) lpsolve object for referencing linear optimizer methods
m_position | Property: m_position is a class property array of the simulated book containing the results of the optimzation
m_storage_iter | Property: m_storage_iter is a class property array of storage_iter structures
m_trajectories | Property: m_trajectories is class property of the number of trajectories to calculate
m_trajectory | Property: m_strajectory is a class property array of s_trajectory structures
m_trajectoryvolumes | Property: m_trajectoryvolumes is a class property array of volumesummary structures
m_value | Property: m_storage_iter is a class property array of storage_iter structures
m_volumesummary | Property: m_value is a class property of the value structure
numofconstraints | Property: numofconstraints is class property of the number of linear constraints
positions | Property: (public) positions object for referencing position class
printflag | Property: printflag is class property for PrintFlagStruc structure
saveflag | Property: saveflag is property for saving the input worksheet
simcal | Property: (public) simcal object for referencing simcalendare class
storage_dynamic | Property: storage_dynamic is class property for dynamic_vars structure
storage_static | name="stats" Summary Stats array(mean,standard deviation)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
infinitycheck |
Main | Method: Main initial method to call Storage
statusandlogging | Method:
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Private Instance Fields

curve | Property: (private) curve object for curve class
extdate | Property: (private) extendeddates object for referencing extended dates methods
path | Property: (private) path property for default debug output path
solverpath | Property: (private) solverpath property for default lpsovle.dll
statistics | Property: (private) statistics object for referencing statistics methods

Private Instance Methods

calcResults | Method: calcResults : Calculates the results of the valuation model
checkgaddaily | Method:checkgaddaily
checkholiday | Method: checkholiday
colnames | Method: colnames
compileDelta |
compileVolumes | Method: compileVolumes
createConstraints | Method: createConstraints
createTrajectories | Method: createTrajectories
dumplog | Method: dumplog
dumpmember | Method: dumpmember
Main_storage | Method: Main_storage
maxconstraints | Method: maxconstraints
monthindexes | Method:Monthindexes
monthlyvolumes | Method: monthly volumes
outputclearResults |
outputDelta | Method: outputDelta
outputResults | Method: outputResults
outputVolumes |
readCsvSimulationData | Method: readCsvsimulationdata
readXcelData | Method: readXcelData: read from excel object commodity storage model inputs
readXcelRatchets | Method: readXcelRatchets
setContractDate | Method: setContractDate
setEndDate | Method: setEndDate
storage_basis | Method: Storage_basis to initialize a basis vector for the optimizer from previous day results
storage_constraint | Method: storage_constraint
storage_optimizer | Method: Storage_Optimizer
volumes | Method: volumes

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage Constructor

Initializes a new instance of the Storage class.

[Visual Basic]
Public Sub New()
[C#]
public Storage();
[C++]
public: Storage();
[JScript]
public function Storage();

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage Static Constructor

Initializes the static fields of the Storage class.

[Visual Basic]
Shared Sub New()
[C#]
static Storage();
[C++]
static Storage();
[JScript]
static function Storage();

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage Fields

The fields of the Storage class are listed below. For a complete list of Storage class members, see the Storage Members topic.

Public Static (Shared) Fields

CONTRACTMMBTU | Constant: (public) CONTRACTMMBTU : Natural as contract size multiplier
deltastep |
LAMBDA | Constant: (public) LAMBDA : market price of risk default
LPsolveinf | Constant: (public) LPsolveinf : constant for value of infinity from lpsolve
NUMOFDAYSYEAR | Constant: (public) NUMOFDAYSYEAR : default days in year, using Stochastix.Net Business class to elimiate this variable
o_stochastix | Property: (public shared readonly) o_stochastix object for referencing Stochatix.net Business class
PriceUpperBND |
xldown | Constant: (public) xldown : constant for MSExcel xldown variable see MSDN for more information
xllastcell |
xltoright | Constant: (public) xltoright : constant for MSExcel xldown variable see MSDN for more information

Private Static (Shared) Fields

BIGPRICE | Constant: (private) BIGPRICE : Huge value to use in Linear optimizer objective function
MAXITER | Constant: (private) MAXITER : Linear optimizer time out limit
TOLER | Constant: (private) TOLER : Linear optimizer tolerance value

Public Instance Fields

dumpconstraints | Property: (public) dumpconstraints file object debug output using logging class
dumpmembers | Property: (public) dumpmembers file object debug output using logging class
dumpobj | Property: (public) dumpobj file object debug output using logging class
dumppos | Property: (public) dumppos file object debug output using logging class
dumpresults | Property: (public) dumpresults file object debug output using logging class
dumprhs | Property: (public) dumprhs file object debug output using logging class
log | Property: (public) log object debug output using logging class
lpsolve | Property: (public) lpsolve object for referencing linear optimizer methods
m_position | Property: m_position is a class property array of the simulated book containing the results of the optimzation
m_storage_iter | Property: m_storage_iter is a class property array of storage_iter structures
m_trajectories | Property: m_trajectories is class property of the number of trajectories to calculate
m_trajectory | Property: m_strajectory is a class property array of s_trajectory structures
m_trajectoryvolumes | Property: m_trajectoryvolumes is a class property array of volumesummary structures
m_value | Property: m_storage_iter is a class property array of storage_iter structures
m_volumesummary | Property: m_value is a class property of the value structure
numofconstraints | Property: numofconstraints is class property of the number of linear constraints
positions | Property: (public) positions object for referencing position class
printflag | Property: printflag is class property for PrintFlagStruc structure
saveflag | Property: saveflag is property for saving the input worksheet
simcal | Property: (public) simcal object for referencing simcalendare class
storage_dynamic | Property: storage_dynamic is class property for dynamic_vars structure
storage_static | name="stats" Summary Stats array(mean,standard deviation)

Private Instance Fields

curve | Property: (private) curve object for curve class
extdate | Property: (private) extendeddates object for referencing extended dates methods
path | Property: (private) path property for default debug output path
solverpath | Property: (private) solverpath property for default lpsovle.dll
statistics | Property: (private) statistics object for referencing statistics methods

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.BIGPRICE Field

Constant: (private) BIGPRICE : Huge value to use in Linear optimizer objective function

[Visual Basic]
Private const BIGPRICE As Double = 999999
[C#]
private const double BIGPRICE = 999999;
[C++]
private: const double BIGPRICE = 999999;
[JScript]
private const var BIGPRICE: double = 999999;

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.CONTRACTMMBTU Field

Constant: (public) CONTRACTMMBTU : Natural as contract size multiplier

[Visual Basic]
Public const CONTRACTMMBTU As Double = 10000
[C#]
public const double CONTRACTMMBTU = 10000;
[C++]
public: const double CONTRACTMMBTU = 10000;
[JScript]
public const var CONTRACTMMBTU: double = 10000;

Remarks

need to set this as property based on commoditytype from curveclass

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.curve Field

Property: (private) curve object for curve class

[Visual Basic]
Private curve As CurveClass
[C#]
private CurveClass curve;
[C++]
private: CurveClass* curve;
[JScript]
private var curve: CurveClass;

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.deltastep Field

[Visual Basic]
Public const deltastep As Double = 0.01
[C#]
public const double deltastep = 0.01;
[C++]
public: const double deltastep = 0.01;
[JScript]
public const var deltastep: double = 0.01;

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.dumpconstraints Field

Property: (public) dumpconstraints file object debug output using logging class

[Visual Basic]
Public dumpconstraints As Object
[C#]
public object dumpconstraints;
[C++]
public: Object* dumpconstraints;
[JScript]
public var dumpconstraints: Object;

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.dumpmembers Field

Property: (public) dumpmembers file object debug output using logging class

[Visual Basic]
Public dumpmembers As Object
[C#]
public object dumpmembers;
[C++]
public: Object* dumpmembers;
[JScript]
public var dumpmembers: Object;

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.dumpobj Field

Property: (public) dumpobj file object debug output using logging class

[Visual Basic]
Public dumpobj As Object
[C#]
public object dumpobj;
[C++]
public: Object* dumpobj;
[JScript]
public var dumpobj: Object;

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.dumppos Field

Property: (public) dumppos file object debug output using logging class

[Visual Basic]
Public dumppos As Object
[C#]
public object dumppos;
[C++]
public: Object* dumppos;
[JScript]
public var dumppos: Object;

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.dumpresults Field

Property: (public) dumpresults file object debug output using logging class

[Visual Basic]
Public dumpresults As Object
[C#]
public object dumpresults;
[C++]
public: Object* dumpresults;
[JScript]
public var dumpresults: Object;

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.dumprhs Field

Property: (public) dumprhs file object debug output using logging class

[Visual Basic]
Public dumprhs As Object
[C#]
public object dumprhs;
[C++]
public: Object* dumprhs;
[JScript]
public var dumprhs: Object;

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.extdate Field

Property: (private) extendeddates object for referencing extended dates methods

[Visual Basic]
Private extdate As ExtendedDates
[C#]
private ExtendedDates extdate;
[C++]
private: ExtendedDates* extdate;
[JScript]
private var extdate: ExtendedDates;

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.LAMBDA Field

Constant: (public) LAMBDA : market price of risk default

[Visual Basic]
Public const LAMBDA As Double = 0.35
[C#]
public const double LAMBDA = 0.35;
[C++]
public: const double LAMBDA = 0.35;
[JScript]
public const var LAMBDA: double = 0.35;

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.log Field

Property: (public) log object debug output using logging class

[Visual Basic]
Public log As Object
[C#]
public object log;
[C++]
public: Object* log;
[JScript]
public var log: Object;

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.lpsolve Field

Property: (public) lpsolve object for referencing linear optimizer methods

[Visual Basic]
Public lpsolve As lpsolve51Class
[C#]
public lpsolve51Class lpsolve;
[C++]
public: lpsolve51Class* lpsolve;
[JScript]
public var lpsolve: lpsolve51Class;

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.LPsolveinf Field

Constant: (public) LPsolveinf : constant for value of infinity from lpsolve

[Visual Basic]
Public const LPsolveinf As Double = 1E+30
[C#]
public const double LPsolveinf = 1E+30;
[C++]
public: const double LPsolveinf = 1E+30;
[JScript]
public const var LPsolveinf: double = 1E+30;

Remarks

should be returned from lpsolve but it use a function that requires a lp model as a parameter

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.m_position Field

Property: m_position is a class property array of the simulated book containing the results of the optimzation

[Visual Basic]
Public m_position As BookStruct()
[C#]
public BookStruct[] m_position;
[C++]
public: BookStruct* m_position __gc[];
[JScript]
public var m_position: BookStruct[];

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.m_storage_iter Field

Property: m_storage_iter is a class property array of storage_iter structures

[Visual Basic]
Public m_storage_iter As storage_iter
[C#]
public storage_iter m_storage_iter;
[C++]
public: storage_iter m_storage_iter;
[JScript]
public var m_storage_iter: storage_iter;

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.m_trajectories Field

Property: m_trajectories is class property of the number of trajectories to calculate

[Visual Basic]
Public m_trajectories As Long
[C#]
public long m_trajectories;
[C++]
public: __int64 m_trajectories;
[JScript]
public var m_trajectories: long;

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.m_trajectory Field

Property: m_strajectory is a class property array of s_trajectory structures

[Visual Basic]
Public m_trajectory As s_trajectory()
[C#]
public s_trajectory[] m_trajectory;
[C++]
public: s_trajectory* m_trajectory __gc[];
[JScript]
public var m_trajectory: s_trajectory[];

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.m_trajectoryvolumes Field

Property: m_trajectoryvolumes is a class property array of volumesummary structures

[Visual Basic]
Public m_trajectoryvolumes As volumesummary(,)
[C#]
public volumesummary[,] m_trajectoryvolumes;
[C++]
public: volumesummary* m_trajectoryvolumes __gc[];
[JScript]
public var m_trajectoryvolumes: volumesummary[,];

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.m_value Field

Property: m_storage_iter is a class property array of storage_iter structures

[Visual Basic]
Public m_value As value
[C#]
public value m_value;
[C++]
public: value m_value;
[JScript]
public var m_value: value;

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.m_volumesummary Field

Property: m_value is a class property of the value structure

[Visual Basic]
Public m_volumesummary As volumesummary()
[C#]
public volumesummary[] m_volumesummary;
[C++]
public: volumesummary* m_volumesummary __gc[];
[JScript]
public var m_volumesummary: volumesummary[];

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.MAXITER Field

Constant: (private) MAXITER : Linear optimizer time out limit

[Visual Basic]
Private const MAXITER As Long = 300
[C#]
private const long MAXITER = 300;
[C++]
private: const __int64 MAXITER = 300;
[JScript]
private const var MAXITER: long = 300;

Remarks

need to set this as property in lpsolve class

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.numofconstraints Field

Property: numofconstraints is class property of the number of linear constraints

[Visual Basic]
Public numofconstraints As Integer
[C#]
public int numofconstraints;
[C++]
public: int numofconstraints;
[JScript]
public var numofconstraints: int;

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.NUMOFDAYSYEAR Field

Constant: (public) NUMOFDAYSYEAR : default days in year, using Stochastix.Net Business class to elimiate this variable

[Visual Basic]
Public const NUMOFDAYSYEAR As Double = 365.25
[C#]
public const double NUMOFDAYSYEAR = 365.25;
[C++]
public: const double NUMOFDAYSYEAR = 365.25;
[JScript]
public const var NUMOFDAYSYEAR: double = 365.25;

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.o_stochastix Field

Property: (public shared readonly) o_stochastix object for referencing Stochatix.net Business class

[Visual Basic]
Public Shared ReadOnly o_stochastix As Actual365
[C#]
public static readonly Actual365 o_stochastix;
[C++]
public: static const Actual365* o_stochastix;
[JScript]
public static const var o_stochastix: Actual365;

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.path Field

Property: (private) path property for default debug output path

[Visual Basic]
Private path As String
[C#]
private string path;
[C++]
private: String* path;
[JScript]
private var path: String;

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.positions Field

Property: (public) positions object for referencing position class

[Visual Basic]
Public positions As Positionclass
[C#]
public Positionclass positions;
[C++]
public: Positionclass* positions;
[JScript]
public var positions: Positionclass;

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.PriceUpperBND Field

[Visual Basic]
Public const PriceUpperBND As Double = 1E+20
[C#]
public const double PriceUpperBND = 1E+20;
[C++]
public: const double PriceUpperBND = 1E+20;
[JScript]
public const var PriceUpperBND: double = 1E+20;

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.printflag Field

Property: printflag is class property for PrintFlagStruc structure

[Visual Basic]
Public printflag As PrintFlagStruct
[C#]
public PrintFlagStruct printflag;
[C++]
public: PrintFlagStruct printflag;
[JScript]
public var printflag: PrintFlagStruct;

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.saveflag Field

Property: saveflag is property for saving the input worksheet

[Visual Basic]
Public saveflag As Boolean
[C#]
public bool saveflag;
[C++]
public: bool saveflag;
[JScript]
public var saveflag: bool;

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.simcal Field

Property: (public) simcal object for referencing simcalendare class

[Visual Basic]
Public simcal As simcalendar
[C#]
public simcalendar simcal;
[C++]
public: simcalendar* simcal;
[JScript]
public var simcal: simcalendar;

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.solverpath Field

Property: (private) solverpath property for default lpsovle.dll

[Visual Basic]
Private solverpath As String
[C#]
private string solverpath;
[C++]
private: String* solverpath;
[JScript]
private var solverpath: String;

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.statistics Field

Property: (private) statistics object for referencing statistics methods

[Visual Basic]
Private statistics As Statistics
[C#]
private Statistics statistics;
[C++]
private: Statistics* statistics;
[JScript]
private var statistics: Statistics;

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.storage_dynamic Field

Property: storage_dynamic is class property for dynamic_vars structure

[Visual Basic]
Public storage_dynamic As dynamic_vars
[C#]
public dynamic_vars storage_dynamic;
[C++]
public: dynamic_vars storage_dynamic;
[JScript]
public var storage_dynamic: dynamic_vars;

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.storage_static Field

name="stats" Summary Stats array(mean,standard deviation)

[Visual Basic]
Public storage_static As StaticVars
[C#]
public StaticVars storage_static;
[C++]
public: StaticVars storage_static;
[JScript]
public var storage_static: StaticVars;

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.TOLER Field

Constant: (private) TOLER : Linear optimizer tolerance value

[Visual Basic]
Private const TOLER As Double = 1E-06
[C#]
private const double TOLER = 1E-06;
[C++]
private: const double TOLER = 1E-06;
[JScript]
private const var TOLER: double = 1E-06;

Remarks

need to set this as property in lpsolve class

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.xldown Field

Constant: (public) xldown : constant for MSExcel xldown variable see MSDN for more information

[Visual Basic]
Public const xldown As Long = -4121
[C#]
public const long xldown = -4121;
[C++]
public: const __int64 xldown = -4121;
[JScript]
public const var xldown: long = -4121;

Remarks

This should be and enum but what the hell:) Link: http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vbaxl11/html/xlhowConstants_HV01049962.asp

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.xllastcell Field

[Visual Basic]
Public const xllastcell As Long = 11
[C#]
public const long xllastcell = 11;
[C++]
public: const __int64 xllastcell = 11;
[JScript]
public const var xllastcell: long = 11;

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.xltoright Field

Constant: (public) xltoright : constant for MSExcel xldown variable see MSDN for more information

[Visual Basic]
Public const xltoright As Long = -4161
[C#]
public const long xltoright = -4161;
[C++]
public: const __int64 xltoright = -4161;
[JScript]
public const var xltoright: long = -4161;

Remarks

This should be and enum but what the hell:) Link: http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vbaxl11/html/xlhowConstants_HV01049962.asp

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage Methods

The methods of the Storage class are listed below. For a complete list of Storage class members, see the Storage Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
infinitycheck |
Main | Method: Main initial method to call Storage
statusandlogging | Method:
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Private Instance Methods

calcResults | Method: calcResults : Calculates the results of the valuation model
checkgaddaily | Method:checkgaddaily
checkholiday | Method: checkholiday
colnames | Method: colnames
compileDelta |
compileVolumes | Method: compileVolumes
createConstraints | Method: createConstraints
createTrajectories | Method: createTrajectories
dumplog | Method: dumplog
dumpmember | Method: dumpmember
Main_storage | Method: Main_storage
maxconstraints | Method: maxconstraints
monthindexes | Method:Monthindexes
monthlyvolumes | Method: monthly volumes
outputclearResults |
outputDelta | Method: outputDelta
outputResults | Method: outputResults
outputVolumes |
readCsvSimulationData | Method: readCsvsimulationdata
readXcelData | Method: readXcelData: read from excel object commodity storage model inputs
readXcelRatchets | Method: readXcelRatchets
setContractDate | Method: setContractDate
setEndDate | Method: setEndDate
storage_basis | Method: Storage_basis to initialize a basis vector for the optimizer from previous day results
storage_constraint | Method: storage_constraint
storage_optimizer | Method: Storage_Optimizer
volumes | Method: volumes

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.calcResults Method

Method: calcResults : Calculates the results of the valuation model

[Visual Basic]
Private Sub calcResults( _
   ByRef model As Object _
)
[C#]
private void calcResults(
   ref object model
);
[C++]
private: void calcResults(
   * Object* model
);
[JScript]
private function calcResults(
   Object model
);

Parameters

model
Calling object

Remarks

Calculates the trajectory marginal revenues and expenses TODO: volume statistics and deltas from LP sensitivities

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.checkgaddaily Method

Method:checkgaddaily

[Visual Basic]
Private Function checkgaddaily( _
   ByVal gad As Double, _
   ByVal gaddaily As Double _
) As Double
[C#]
private double checkgaddaily(
   double gad,
   double gaddaily
);
[C++]
private: double checkgaddaily(
   double gad,
   double gaddaily
);
[JScript]
private function checkgaddaily(
   double gad,
   double gaddaily
): double;

Parameters

gad
gaddaily

Return Value

Double

Remarks

check if gaddaily>gad

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.checkholiday Method

Method: checkholiday

[Visual Basic]
Private Function checkholiday( _
   ByVal holarray As Object, _
   ByVal Curdate As Date _
) As Date
[C#]
private DateTime checkholiday(
   object holarray,
   DateTime Curdate
);
[C++]
private: DateTime checkholiday(
   Object* holarray,
   DateTime Curdate
);
[JScript]
private function checkholiday(
   Object holarray,
   DateTime Curdate
): DateTime;

Parameters

holarray
Array of dates corresponding to holidays
Curdate
Current date

Return Value

Date

Remarks

determines if the curdate is a holiday, requires a simcalendar and curve class to be built

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.colnames Method

Method: colnames

[Visual Basic]
Private Function colnames( _
   ByVal c As Long _
) As String
[C#]
private string colnames(
   long c
);
[C++]
private: String* colnames(
   __int64 c
);
[JScript]
private function colnames(
   long c
): String;

Parameters

c
Current tenor integer ID

Return Value

String

Remarks

Create column names

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.compileDelta Method

[Visual Basic]
Private Function compileDelta( _
   ByRef volumes As Object, _
   ByVal dayctr As Long, _
   ByVal month As Long, _
   ByVal type As Boolean, _
   ByVal type2 As Boolean _
) As Double
[C#]
private double compileDelta(
   ref object volumes,
   long dayctr,
   long month,
   bool type,
   bool type2
);
[C++]
private: double compileDelta(
   * Object* volumes,
   __int64 dayctr,
   __int64 month,
   bool type,
   bool type2
);
[JScript]
private function compileDelta(
   Object volumes,
   long dayctr,
   long month,
   bool type,
   bool type2
): double;

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.compileVolumes Method

Method: compileVolumes

[Visual Basic]
Private Sub compileVolumes( _
   ByVal currentperiod As Integer, _
   ByVal mon As Long, _
   ByVal yr As Long, _
   ByVal traj As Integer, _
   ByVal position As Double, _
   ByVal gadd As Double, _
   ByVal gig As Double, _
   ByVal Type As Integer _
)
[C#]
private void compileVolumes(
   int currentperiod,
   long mon,
   long yr,
   int traj,
   double position,
   double gadd,
   double gig,
   int Type
);
[C++]
private: void compileVolumes(
   int currentperiod,
   __int64 mon,
   __int64 yr,
   int traj,
   double position,
   double gadd,
   double gig,
   int Type
);
[JScript]
private function compileVolumes(
   int currentperiod,
   long mon,
   long yr,
   int traj,
   double position,
   double gadd,
   double gig,
   int Type
);

Parameters

currentperiod
Current period counter
mon
Trajectory month
yr
Trajectory year
traj
Current Trajectory
position
Transacted volumes both physical and financial
gadd
Physical commodity delivered on the current date
gig
Type

Return Value

NA

Remarks

Compile the physical volumes transacted and the financial hedges traded in the bought/sold/delivered objects by trajectory and transaction month

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.createConstraints Method

Method: createConstraints

[Visual Basic]
Private Sub createConstraints()
[C#]
private void createConstraints();
[C++]
private: void createConstraints();
[JScript]
private function createConstraints();

Parameters

Return Value

NA

Remarks

Build the constraints matrices and fill with default constraints

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.createTrajectories Method

Method: createTrajectories

[Visual Basic]
Private Sub createTrajectories( _
   ByVal model As Object _
)
[C#]
private void createTrajectories(
   object model
);
[C++]
private: void createTrajectories(
   Object* model
);
[JScript]
private function createTrajectories(
   Object model
);

Parameters

model
Calling object, currently excel workbook

Return Value

NA

Remarks

Initialize the trajectory structure and build defaults sizes

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.dumplog Method

Method: dumplog

[Visual Basic]
Private Sub dumplog( _
   ByVal ar1 As Object, _
   ByRef obj As Object, _
   ByVal dims As Long, _
   ByVal rank As Long, _
   ByVal start As Boolean, _
   ByVal traj As Long, _
   Optional ByVal filenm As String = "Nothing", _
   Optional ByVal dir As String = "Nothing" _
)
[C#]
private void dumplog(
   object ar1,
   ref object obj,
   long dims,
   long rank,
   bool start,
   long traj,
   string filenm,
   string dir
);
[C++]
private: void dumplog(
   Object* ar1,
   * Object* obj,
   __int64 dims,
   __int64 rank,
   bool start,
   __int64 traj,
   String* filenm,
   String* dir
);
[JScript]
private function dumplog(
   Object ar1,
   Object obj,
   long dims,
   long rank,
   bool start,
   long traj,
   String filenm,
   String dir
);

Parameters

ar1
Array obj holding interim trajectory data
obj
Logging Object to dump output
dims
Dimension of ar1
rank
Rank of ar1
start
Flag to instantiate a new logging object: requires filenm not null
traj
Current Trajectory
filenm
Optional file name, required if start=true
dir
Options directory location

Return Value

NA

Remarks

Method to output trajectory results using filelogger class

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.dumpmember Method

Method: dumpmember

[Visual Basic]
Private Sub dumpmember( _
   ByVal membertype As String, _
   ByVal member As Object, _
   ByRef obj As Object, _
   ByVal d As Date, _
   ByVal traj As Long, _
   Optional ByVal start As Boolean = False, _
   Optional ByVal filenm As String = "Nothing", _
   Optional ByVal dir As String = "Nothing" _
)
[C#]
private void dumpmember(
   string membertype,
   object member,
   ref object obj,
   DateTime d,
   long traj,
   bool start,
   string filenm,
   string dir
);
[C++]
private: void dumpmember(
   String* membertype,
   Object* member,
   * Object* obj,
   DateTime d,
   __int64 traj,
   bool start,
   String* filenm,
   String* dir
);
[JScript]
private function dumpmember(
   String membertype,
   Object member,
   Object obj,
   DateTime d,
   long traj,
   bool start,
   String filenm,
   String dir
);

Parameters

membertype
Type of member(dailyvolumes,values)
member
Object of data to output
obj
Logging Object to dump output
d
Date in current trajectory
traj
Current Trajectory
start
Flag to instantiate a new logging object: requires filenm not null
filenm
Optional file name, required if start=true
dir
Options directory location

Return Value

NA

Remarks

Method to ouput the results of the member object

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.Finalize Method

[C#] In C#, finalizers are expressed using destructor syntax.

[C++] In C++, finalizers are expressed using destructor syntax.

[Visual Basic]
Overrides Protected Sub Finalize()
[C#]
~Storage();
[C++]
~Storage();
[JScript]
protected override function Finalize();

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.infinitycheck Method

[Visual Basic]
Public Function infinitycheck( _
   ByVal value1 As Double, _
   Optional ByVal value2 As Double = 0 _
) As Object
[C#]
public object infinitycheck(
   double value1,
   double value2
);
[C++]
public: Object* infinitycheck(
   double value1,
   double value2
);
[JScript]
public function infinitycheck(
   double value1,
   double value2
): Object;

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.Main Method

Method: Main initial method to call Storage

[Visual Basic]
Public Sub Main( _
   ByVal storagemodel As Object _
)
[C#]
public void Main(
   object storagemodel
);
[C++]
public: void Main(
   Object* storagemodel
);
[JScript]
public function Main(
   Object storagemodel
);

Parameters

storagemodel
Calling object, currently excel workbook

Return Value

NA

Remarks

Commodity storage model main method

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.Main_storage Method

Method: Main_storage

[Visual Basic]
Private Sub Main_storage( _
   ByRef storagemodel As Object _
)
[C#]
private void Main_storage(
   ref object storagemodel
);
[C++]
private: void Main_storage(
   * Object* storagemodel
);
[JScript]
private function Main_storage(
   Object storagemodel
);

Parameters

storagemodel
Calling object, currently excel workbook

Return Value

NA

Remarks

Name: main Storagecall Date: Sequence: Executed when all pre-processing is completed Object Requirements: begin: markdate to run the valuation end: ending simulation date trajectories: number of trajectories in the simulation file initgig: gas in ground, current storage level initgad: gas available for delivery, current month baseload can be positive for injection, negative for withdrawals. initgadnext: gas available for delivery in next month if date is between contract expiration and end of month. Needed for Constraints, and can be positive or negative as with GAD. Description: Main Storage macro examples Intrinsic only: %storage(6/25/02,6/25/02,0,50,0,0,3.45,3.55) Intinsic and Extrinsic: %storage(6/25/02,3/31/04,10,50,0,0,3.45,3.55)

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.maxconstraints Method

Method: maxconstraints

[Visual Basic]
Private Function maxconstraints() As Integer
[C#]
private int maxconstraints();
[C++]
private: int maxconstraints();
[JScript]
private function maxconstraints(): int;

Return Value

Integer

Remarks

Calculate the maximum number of constraints based on number of years number of months time 2, one for no injections in the last period, and the number empty by march flag time the number of years

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.monthindexes Method

Method:Monthindexes

[Visual Basic]
Private Sub monthindexes( _
   ByVal dataset As Object _
)
[C#]
private void monthindexes(
   object dataset
);
[C++]
private: void monthindexes(
   Object* dataset
);
[JScript]
private function monthindexes(
   Object dataset
);

Parameters

dataset
Object holding simulated forward prices

Return Value

NA

Remarks

average the last 4 days of the month to get the simulated month index price does not work, need to work on this later.

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.monthlyvolumes Method

Method: monthly volumes

[Visual Basic]
Private Sub monthlyvolumes( _
   ByVal period As Long, _
   ByVal contractdate As Date, _
   ByVal enddate As Date, _
   ByRef mmwq As Double, _
   ByRef mmiq As Double _
)
[C#]
private void monthlyvolumes(
   long period,
   DateTime contractdate,
   DateTime enddate,
   ref double mmwq,
   ref double mmiq
);
[C++]
private: void monthlyvolumes(
   __int64 period,
   DateTime contractdate,
   DateTime enddate,
   * double mmwq,
   * double mmiq
);
[JScript]
private function monthlyvolumes(
   long period,
   DateTime contractdate,
   DateTime enddate,
   double mmwq,
   double mmiq
);

Parameters

period
Trajectory period
contractdate
Contract beginning flow date
enddate
Contract ending flow date
mmwq
Maximum tenor withdrawal rate
mmiq
Maximum tenor injection rate

Return Value

NA

Remarks

calculates the allowable flow volume for the contract from the contractdate to the enddate under the gas available for deliver, gas in ground, maximum storage quantity, and daily ratchets. TODO: add volumetric calculations based on gas in ground

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.outputclearResults Method

[Visual Basic]
Private Sub outputclearResults( _
   ByRef model As Object _
)
[C#]
private void outputclearResults(
   ref object model
);
[C++]
private: void outputclearResults(
   * Object* model
);
[JScript]
private function outputclearResults(
   Object model
);

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.outputDelta Method

Method: outputDelta

[Visual Basic]
Private Sub outputDelta( _
   ByRef model As Object _
)
[C#]
private void outputDelta(
   ref object model
);
[C++]
private: void outputDelta(
   * Object* model
);
[JScript]
private function outputDelta(
   Object model
);

Parameters

model
Calling object

Return Value

NA

Remarks

Output final results to the calling model object

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.outputResults Method

Method: outputResults

[Visual Basic]
Private Sub outputResults( _
   ByRef model As Object _
)
[C#]
private void outputResults(
   ref object model
);
[C++]
private: void outputResults(
   * Object* model
);
[JScript]
private function outputResults(
   Object model
);

Parameters

model
Calling object

Return Value

NA

Remarks

Output final results to the calling model object

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.outputVolumes Method

[Visual Basic]
Private Sub outputVolumes( _
   ByVal model As Object, _
   ByVal Type As Integer _
)
[C#]
private void outputVolumes(
   object model,
   int Type
);
[C++]
private: void outputVolumes(
   Object* model,
   int Type
);
[JScript]
private function outputVolumes(
   Object model,
   int Type
);

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.readCsvSimulationData Method

Method: readCsvsimulationdata

[Visual Basic]
Private Sub readCsvSimulationData( _
   ByVal dataloc As Object, _
   ByVal simvalue As String, _
   ByVal model As Object _
)
[C#]
private void readCsvSimulationData(
   object dataloc,
   string simvalue,
   object model
);
[C++]
private: void readCsvSimulationData(
   Object* dataloc,
   String* simvalue,
   Object* model
);
[JScript]
private function readCsvSimulationData(
   Object dataloc,
   String simvalue,
   Object model
);

Parameters

dataloc
location of csv file
simvalue
model
Calling object, currently excel workbook

Return Value

NA

Remarks

reads in the simulated data set from a csv file, ToDO: need to add basis to at sometime

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.readXcelData Method

Method: readXcelData: read from excel object commodity storage model inputs

[Visual Basic]
Private Sub readXcelData( _
   ByRef storagemodel As Object _
)
[C#]
private void readXcelData(
   ref object storagemodel
);
[C++]
private: void readXcelData(
   * Object* storagemodel
);
[JScript]
private function readXcelData(
   Object storagemodel
);

Parameters

storagemodel
Calling object, currently excel workbook

Return Value

NA

Remarks

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.readXcelRatchets Method

Method: readXcelRatchets

[Visual Basic]
Private Sub readXcelRatchets( _
   ByVal storagemodel As Object, _
   ByVal type As String _
)
[C#]
private void readXcelRatchets(
   object storagemodel,
   string type
);
[C++]
private: void readXcelRatchets(
   Object* storagemodel,
   String* type
);
[JScript]
private function readXcelRatchets(
   Object storagemodel,
   String type
);

Parameters

storagemodel
Calling object, currently excel workbook
type

Return Value

NA

Remarks

Date: Sequence: Inputs: Master Daily Ratchet table read Description: This retreives the dailyratchets for the deal being valued from the master facility ratchet table/database from the storage master file library. Can be replaced with a sql query to a database containing the data or from a SAS server where the storage master files are stored. Output: Working daily ratchet table with monthly index. Written by Joe W. Byers

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.setContractDate Method

Method: setContractDate

[Visual Basic]
Private Function setContractDate( _
   ByVal curdate As Date, _
   ByVal daytype As String, _
   Optional ByVal holarray As Object = Nothing _
) As Date
[C#]
private DateTime setContractDate(
   DateTime curdate,
   string daytype,
   object holarray
);
[C++]
private: DateTime setContractDate(
   DateTime curdate,
   String* daytype,
   Object* holarray
);
[JScript]
private function setContractDate(
   DateTime curdate,
   String daytype,
   Object holarray
): DateTime;

Parameters

curdate
Current Date
daytype
Type paramter (spot,balmo,month,..)
holarray
Array of dates corresponding to holidays

Return Value

Date

Remarks

Calculates the physical volume flow dates for a contract

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.setEndDate Method

Method: setEndDate

[Visual Basic]
Private Function setEndDate( _
   ByVal curdate As Date, _
   ByVal daytype As String, _
   ByVal holarray As Object _
) As Date
[C#]
private DateTime setEndDate(
   DateTime curdate,
   string daytype,
   object holarray
);
[C++]
private: DateTime setEndDate(
   DateTime curdate,
   String* daytype,
   Object* holarray
);
[JScript]
private function setEndDate(
   DateTime curdate,
   String daytype,
   Object holarray
): DateTime;

Parameters

curdate
Current Date
daytype
Type paramter (spot,balmo,month,..)
holarray

Return Value

Date

Remarks

Calculates the ending flow date for a contract tenor

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.statusandlogging Method

Method:

[Visual Basic]
Public Sub statusandlogging( _
   ByVal operation As String, _
   ByRef obj As Object, _
   Optional ByVal messagetxt As String = "Nothing", _
   Optional ByVal filenm As String = "Nothing", _
   Optional ByVal dir As String = "Nothing" _
)
[C#]
public void statusandlogging(
   string operation,
   ref object obj,
   string messagetxt,
   string filenm,
   string dir
);
[C++]
public: void statusandlogging(
   String* operation,
   * Object* obj,
   String* messagetxt,
   String* filenm,
   String* dir
);
[JScript]
public function statusandlogging(
   String operation,
   Object obj,
   String messagetxt,
   String filenm,
   String dir
);

Parameters

operation
Operation to perform(excelstart,newlog,statusbar,excelend
obj
Logging Object to dump output
messagetxt
Text to display on status bar
filenm
Optional file name, required if start=true
dir
Options directory location

Return Value

NA

Remarks

Updates excel or other component's status bar and file event logging Excel is the only component currently implemented. Excelstart and Excelend resets application states to defaults. newlog instantiates a new logging object. statusbar updates the calling application statusbar.

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.storage_basis Method

Method: Storage_basis to initialize a basis vector for the optimizer from previous day results

[Visual Basic]
Private Sub storage_basis( _
   ByRef basis As Double(), _
   ByVal j As Integer, _
   ByVal dayctr As Integer _
)
[C#]
private void storage_basis(
   ref double[] basis,
   int j,
   int dayctr
);
[C++]
private: void storage_basis(
   * double basis __gc[],
   int j,
   int dayctr
);
[JScript]
private function storage_basis(
   double[] basis,
   int j,
   int dayctr
);

Parameters

basis
Basis array of double
j
j index variable for trajectory
dayctr
index variable for day

Return Value

Implements byref on Basis array for return

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.storage_constraint Method

Method: storage_constraint

[Visual Basic]
Private Sub storage_constraint( _
   ByVal Valuation As String, _
   ByVal traj As Integer, _
   ByVal dayctr As Integer _
)
[C#]
private void storage_constraint(
   string Valuation,
   int traj,
   int dayctr
);
[C++]
private: void storage_constraint(
   String* Valuation,
   int traj,
   int dayctr
);
[JScript]
private function storage_constraint(
   String Valuation,
   int traj,
   int dayctr
);

Parameters

Valuation
traj
Current Trajectory
dayctr
Counter for days

Return Value

NA

Remarks

'Name: Storage_Contraints Sequence: call from storagecall macro. Inputs: Macro(Variables) Passed: valuation - method of valuation (Intrinsic/Extrinsic) modelfile - macro variable of name for dataset containing the facility inputs trajectory - trajectory to evaluate counterparty() evaldate - current date to evaluate lastdate - last evaluation date to handle weekends and holidays Datasets: Description: This is the constraint construction and price build program requires the constraints dataset and crv_storage price input dataset. This builds the contraints inest datasets for proc nlp. The macro is called after each interation of the optimizer to update the inest dataset. Valuation = Intrinsic Or Extrinsic uses the curve to calc the intrinsic value or written by joe byers build the LP input data set variables

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.storage_optimizer Method

Method: Storage_Optimizer

[Visual Basic]
Private Sub storage_optimizer( _
   ByVal traj As Integer, _
   ByVal dayctr As Integer, _
   Optional ByVal basis As Double() = Nothing, _
   Optional ByVal start As Boolean = False, _
   Optional ByVal last As Boolean = False _
)
[C#]
private void storage_optimizer(
   int traj,
   int dayctr,
   double[] basis,
   bool start,
   bool last
);
[C++]
private: void storage_optimizer(
   int traj,
   int dayctr,
   double basis __gc[],
   bool start,
   bool last
);
[JScript]
private function storage_optimizer(
   int traj,
   int dayctr,
   double[] basis,
   bool start,
   bool last
);

Parameters

traj
dayctr
Time increment or day counter index
basis
start
Optional Used to set lpsolve init path on first call
last
Optional

Return Value

NA

Remarks

The main commodity optimization routine that calls lpsolve com ojbect

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.volumes Method

Method: volumes

[Visual Basic]
Private Sub volumes( _
   ByVal daytype As String, _
   ByVal curdate As Date, _
   ByVal traj As Integer, _
   ByVal dayctr As Integer _
)
[C#]
private void volumes(
   string daytype,
   DateTime curdate,
   int traj,
   int dayctr
);
[C++]
private: void volumes(
   String* daytype,
   DateTime curdate,
   int traj,
   int dayctr
);
[JScript]
private function volumes(
   String daytype,
   DateTime curdate,
   int traj,
   int dayctr
);

Parameters

daytype
Type variable specifically to designate a weekend or holiday
curdate
Current Date
traj
Current Trajectory
dayctr
Counter for days

Return Value

NA

Remarks

Type: Macro to roll the volumes each day Sequence: called from storage optimizer after optimization called from storage contraint before setting constraints to get the last values. no user call required! Inputs: Description: keeps track of the volume transactions for buying, selling and delivering gas Output: Written by Joe W. Byers

See Also

Storage Class | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.CostStruct Structure

Structure: Cost structure for injecting or withdrawing the physical commodity

For a list of all members of this type, see Storage.CostStruct Members.

System.Object
System.ValueType
CommodityStorage.Storage.Storage.CostStruct

[Visual Basic]
Public Structure Storage.CostStruct
[C#]
public struct Storage.CostStruct
[C++]
public __value struct Storage.CostStruct

[JScript] In JScript, you can use the structures defined by a type, but you cannot define your own.

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: CommodityStorage.Storage

Assembly: CommodityStorage (in CommodityStorage.dll)

See Also

Storage.CostStruct Members | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.CostStruct Members

Storage.CostStruct overview

Public Instance Fields

injection_fuel | name="Injection_Fuel" Percentage Fuel cost of injecting commodity
Injection_tariff | name="Injection_Tariff" Tariff cost of injecting one unit fo commodity
Roll | name="Roll" Hedge Roll cost per unit of transaction
withdrawal_fuel | name="Withdrawal_Fuel" Percentage Fuel cost of withdrawing commodity
Withdrawal_tariff | name="Withdrawal_Tariff" Tariff cost of withdrawing one unit fo commodity

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

Storage.CostStruct Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.CostStruct Fields

The fields of the Storage.CostStruct structure are listed below. For a complete list of Storage.CostStruct structure members, see the Storage.CostStruct Members topic.

Public Instance Fields

injection_fuel | name="Injection_Fuel" Percentage Fuel cost of injecting commodity
Injection_tariff | name="Injection_Tariff" Tariff cost of injecting one unit fo commodity
Roll | name="Roll" Hedge Roll cost per unit of transaction
withdrawal_fuel | name="Withdrawal_Fuel" Percentage Fuel cost of withdrawing commodity
Withdrawal_tariff | name="Withdrawal_Tariff" Tariff cost of withdrawing one unit fo commodity

See Also

Storage.CostStruct Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.CostStruct.injection_fuel Field

name="Injection_Fuel" Percentage Fuel cost of injecting commodity

[Visual Basic]
Public injection_fuel As Double
[C#]
public double injection_fuel;
[C++]
public: double injection_fuel;
[JScript]
public var injection_fuel: double;

See Also

Storage.CostStruct Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.CostStruct.Injection_tariff Field

name="Injection_Tariff" Tariff cost of injecting one unit fo commodity

[Visual Basic]
Public Injection_tariff As Double
[C#]
public double Injection_tariff;
[C++]
public: double Injection_tariff;
[JScript]
public var Injection_tariff: double;

See Also

Storage.CostStruct Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.CostStruct.Roll Field

name="Roll" Hedge Roll cost per unit of transaction

[Visual Basic]
Public Roll As Double
[C#]
public double Roll;
[C++]
public: double Roll;
[JScript]
public var Roll: double;

See Also

Storage.CostStruct Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.CostStruct.withdrawal_fuel Field

name="Withdrawal_Fuel" Percentage Fuel cost of withdrawing commodity

[Visual Basic]
Public withdrawal_fuel As Double
[C#]
public double withdrawal_fuel;
[C++]
public: double withdrawal_fuel;
[JScript]
public var withdrawal_fuel: double;

See Also

Storage.CostStruct Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.CostStruct.Withdrawal_tariff Field

name="Withdrawal_Tariff" Tariff cost of withdrawing one unit fo commodity

[Visual Basic]
Public Withdrawal_tariff As Double
[C#]
public double Withdrawal_tariff;
[C++]
public: double Withdrawal_tariff;
[JScript]
public var Withdrawal_tariff: double;

See Also

Storage.CostStruct Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.DateStruct Structure

Structure: DateStruc structure for storage date input

For a list of all members of this type, see Storage.DateStruct Members.

System.Object
System.ValueType
CommodityStorage.Storage.Storage.DateStruct

[Visual Basic]
Public Structure Storage.DateStruct
[C#]
public struct Storage.DateStruct
[C++]
public __value struct Storage.DateStruct

[JScript] In JScript, you can use the structures defined by a type, but you cannot define your own.

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: CommodityStorage.Storage

Assembly: CommodityStorage (in CommodityStorage.dll)

See Also

Storage.DateStruct Members | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.DateStruct Members

Storage.DateStruct overview

Public Instance Fields

Curve_Date | name="Curve_Date" Current curve date.
firstcontract | name="firstcontract" Current prompt contract
MarkDate | name="MarkDate" Mark to Market Date.
months | name="months" Number of month in the deal: deal periods.
numberofyears | name="numberofyears" Number of years in the deal.
Start_of_Year | name="Start_of_Year" Deal beginning of year since commodity cylces do not follow a calendar year.
StartDate | name="StartDate" Deal start date.
transactiondate | name="transactiondate" Transaction date

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

Storage.DateStruct Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.DateStruct Fields

The fields of the Storage.DateStruct structure are listed below. For a complete list of Storage.DateStruct structure members, see the Storage.DateStruct Members topic.

Public Instance Fields

Curve_Date | name="Curve_Date" Current curve date.
firstcontract | name="firstcontract" Current prompt contract
MarkDate | name="MarkDate" Mark to Market Date.
months | name="months" Number of month in the deal: deal periods.
numberofyears | name="numberofyears" Number of years in the deal.
Start_of_Year | name="Start_of_Year" Deal beginning of year since commodity cylces do not follow a calendar year.
StartDate | name="StartDate" Deal start date.
transactiondate | name="transactiondate" Transaction date

See Also

Storage.DateStruct Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.DateStruct.Curve_Date Field

name="Curve_Date" Current curve date.

[Visual Basic]
Public Curve_Date As Date
[C#]
public DateTime Curve_Date;
[C++]
public: DateTime Curve_Date;
[JScript]
public var Curve_Date: DateTime;

See Also

Storage.DateStruct Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.DateStruct.firstcontract Field

name="firstcontract" Current prompt contract

[Visual Basic]
Public firstcontract As Date
[C#]
public DateTime firstcontract;
[C++]
public: DateTime firstcontract;
[JScript]
public var firstcontract: DateTime;

See Also

Storage.DateStruct Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.DateStruct.MarkDate Field

name="MarkDate" Mark to Market Date.

[Visual Basic]
Public MarkDate As Date
[C#]
public DateTime MarkDate;
[C++]
public: DateTime MarkDate;
[JScript]
public var MarkDate: DateTime;

See Also

Storage.DateStruct Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.DateStruct.months Field

name="months" Number of month in the deal: deal periods.

[Visual Basic]
Public months As Long
[C#]
public long months;
[C++]
public: __int64 months;
[JScript]
public var months: long;

See Also

Storage.DateStruct Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.DateStruct.numberofyears Field

name="numberofyears" Number of years in the deal.

[Visual Basic]
Public numberofyears As Long
[C#]
public long numberofyears;
[C++]
public: __int64 numberofyears;
[JScript]
public var numberofyears: long;

See Also

Storage.DateStruct Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.DateStruct.Start_of_Year Field

name="Start_of_Year" Deal beginning of year since commodity cylces do not follow a calendar year.

[Visual Basic]
Public Start_of_Year As Date
[C#]
public DateTime Start_of_Year;
[C++]
public: DateTime Start_of_Year;
[JScript]
public var Start_of_Year: DateTime;

See Also

Storage.DateStruct Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.DateStruct.StartDate Field

name="StartDate" Deal start date.

[Visual Basic]
Public StartDate As Date
[C#]
public DateTime StartDate;
[C++]
public: DateTime StartDate;
[JScript]
public var StartDate: DateTime;

See Also

Storage.DateStruct Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.DateStruct.transactiondate Field

name="transactiondate" Transaction date

[Visual Basic]
Public transactiondate As Date
[C#]
public DateTime transactiondate;
[C++]
public: DateTime transactiondate;
[JScript]
public var transactiondate: DateTime;

See Also

Storage.DateStruct Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.dynamic_vars Structure

Structure: Dynamic_vars structure for dynamic variables: dates, market and path dependency variables

For a list of all members of this type, see Storage.dynamic_vars Members.

System.Object
System.ValueType
CommodityStorage.Storage.Storage.dynamic_vars

[Visual Basic]
Public Structure Storage.dynamic_vars
[C#]
public struct Storage.dynamic_vars
[C++]
public __value struct Storage.dynamic_vars

[JScript] In JScript, you can use the structures defined by a type, but you cannot define your own.

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: CommodityStorage.Storage

Assembly: CommodityStorage (in CommodityStorage.dll)

See Also

Storage.dynamic_vars Members | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.dynamic_vars Members

Storage.dynamic_vars overview

Public Instance Fields

BalMo | name="BalMo" Current Balance of the month price
CurveSize | name="CurveSize" Size of financial arrays
dates | name="dates" DateStruct Field holding the current valuation dates
GAD | name="GAD" Physical commodity volume delivered in the current tenor
GADnext | name="GADnext" Physical commodity volume delivered in the next tenor
GDD | name="GDD" Current physical (spot/cash) price
GIG | name="GIG" Current inventory level of commodity
gigeom | name="GIGEOM" Inventory level at the end of the month or tenor
MonthIndex | name="MonthIndex" Current monthly index price

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

Storage.dynamic_vars Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.dynamic_vars Fields

The fields of the Storage.dynamic_vars structure are listed below. For a complete list of Storage.dynamic_vars structure members, see the Storage.dynamic_vars Members topic.

Public Instance Fields

BalMo | name="BalMo" Current Balance of the month price
CurveSize | name="CurveSize" Size of financial arrays
dates | name="dates" DateStruct Field holding the current valuation dates
GAD | name="GAD" Physical commodity volume delivered in the current tenor
GADnext | name="GADnext" Physical commodity volume delivered in the next tenor
GDD | name="GDD" Current physical (spot/cash) price
GIG | name="GIG" Current inventory level of commodity
gigeom | name="GIGEOM" Inventory level at the end of the month or tenor
MonthIndex | name="MonthIndex" Current monthly index price

See Also

Storage.dynamic_vars Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.dynamic_vars.BalMo Field

name="BalMo" Current Balance of the month price

[Visual Basic]
Public BalMo As Double
[C#]
public double BalMo;
[C++]
public: double BalMo;
[JScript]
public var BalMo: double;

See Also

Storage.dynamic_vars Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.dynamic_vars.CurveSize Field

name="CurveSize" Size of financial arrays

[Visual Basic]
Public CurveSize As Double
[C#]
public double CurveSize;
[C++]
public: double CurveSize;
[JScript]
public var CurveSize: double;

See Also

Storage.dynamic_vars Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.dynamic_vars.dates Field

name="dates" DateStruct Field holding the current valuation dates

[Visual Basic]
Public dates As DateStruct
[C#]
public DateStruct dates;
[C++]
public: DateStruct dates;
[JScript]
public var dates: DateStruct;

See Also

Storage.dynamic_vars Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.dynamic_vars.GAD Field

name="GAD" Physical commodity volume delivered in the current tenor

[Visual Basic]
Public GAD As Double
[C#]
public double GAD;
[C++]
public: double GAD;
[JScript]
public var GAD: double;

See Also

Storage.dynamic_vars Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.dynamic_vars.GADnext Field

name="GADnext" Physical commodity volume delivered in the next tenor

[Visual Basic]
Public GADnext As Double
[C#]
public double GADnext;
[C++]
public: double GADnext;
[JScript]
public var GADnext: double;

See Also

Storage.dynamic_vars Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.dynamic_vars.GDD Field

name="GDD" Current physical (spot/cash) price

[Visual Basic]
Public GDD As Double
[C#]
public double GDD;
[C++]
public: double GDD;
[JScript]
public var GDD: double;

See Also

Storage.dynamic_vars Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.dynamic_vars.GIG Field

name="GIG" Current inventory level of commodity

[Visual Basic]
Public GIG As Double
[C#]
public double GIG;
[C++]
public: double GIG;
[JScript]
public var GIG: double;

See Also

Storage.dynamic_vars Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.dynamic_vars.gigeom Field

name="GIGEOM" Inventory level at the end of the month or tenor

[Visual Basic]
Public gigeom As Double
[C#]
public double gigeom;
[C++]
public: double gigeom;
[JScript]
public var gigeom: double;

See Also

Storage.dynamic_vars Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.dynamic_vars.MonthIndex Field

name="MonthIndex" Current monthly index price

[Visual Basic]
Public MonthIndex As Double
[C#]
public double MonthIndex;
[C++]
public: double MonthIndex;
[JScript]
public var MonthIndex: double;

See Also

Storage.dynamic_vars Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.extrinsic Structure

Structure: extrinsic structure for extrinsic valuation results

For a list of all members of this type, see Storage.extrinsic Members.

System.Object
System.ValueType
CommodityStorage.Storage.Storage.extrinsic

[Visual Basic]
Public Structure Storage.extrinsic
[C#]
public struct Storage.extrinsic
[C++]
public __value struct Storage.extrinsic

[JScript] In JScript, you can use the structures defined by a type, but you cannot define your own.

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: CommodityStorage.Storage

Assembly: CommodityStorage (in CommodityStorage.dll)

See Also

Storage.extrinsic Members | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.extrinsic Members

Storage.extrinsic overview

Public Instance Fields

extrinsicMAX | name="extrinsicMAX" Extrinsic Maximum value
extrinsicMean | name="extrinsicMean" Extrinsic Mean
extrinsicMIN | name="extrinsicMIN" Extrinsic Minimum value
extrinsicSTDDEV | name="extrinsicSTDDEV" Extrinsic Standard Deviation
TotalProfit | name="TotalProfit" Total Profit results array

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

Storage.extrinsic Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.extrinsic Fields

The fields of the Storage.extrinsic structure are listed below. For a complete list of Storage.extrinsic structure members, see the Storage.extrinsic Members topic.

Public Instance Fields

extrinsicMAX | name="extrinsicMAX" Extrinsic Maximum value
extrinsicMean | name="extrinsicMean" Extrinsic Mean
extrinsicMIN | name="extrinsicMIN" Extrinsic Minimum value
extrinsicSTDDEV | name="extrinsicSTDDEV" Extrinsic Standard Deviation
TotalProfit | name="TotalProfit" Total Profit results array

See Also

Storage.extrinsic Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.extrinsic.extrinsicMAX Field

name="extrinsicMAX" Extrinsic Maximum value

[Visual Basic]
Public extrinsicMAX As Double
[C#]
public double extrinsicMAX;
[C++]
public: double extrinsicMAX;
[JScript]
public var extrinsicMAX: double;

See Also

Storage.extrinsic Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.extrinsic.extrinsicMean Field

name="extrinsicMean" Extrinsic Mean

[Visual Basic]
Public extrinsicMean As Double
[C#]
public double extrinsicMean;
[C++]
public: double extrinsicMean;
[JScript]
public var extrinsicMean: double;

See Also

Storage.extrinsic Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.extrinsic.extrinsicMIN Field

name="extrinsicMIN" Extrinsic Minimum value

[Visual Basic]
Public extrinsicMIN As Double
[C#]
public double extrinsicMIN;
[C++]
public: double extrinsicMIN;
[JScript]
public var extrinsicMIN: double;

See Also

Storage.extrinsic Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.extrinsic.extrinsicSTDDEV Field

name="extrinsicSTDDEV" Extrinsic Standard Deviation

[Visual Basic]
Public extrinsicSTDDEV As Double
[C#]
public double extrinsicSTDDEV;
[C++]
public: double extrinsicSTDDEV;
[JScript]
public var extrinsicSTDDEV: double;

See Also

Storage.extrinsic Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.extrinsic.TotalProfit Field

name="TotalProfit" Total Profit results array

[Visual Basic]
Public TotalProfit As Double()
[C#]
public double[] TotalProfit;
[C++]
public: double TotalProfit __gc[];
[JScript]
public var TotalProfit: double[];

See Also

Storage.extrinsic Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.lincon Structure

Structure: lincon structue for holding linear constraints

For a list of all members of this type, see Storage.lincon Members.

System.Object
System.ValueType
CommodityStorage.Storage.Storage.lincon

[Visual Basic]
Public Structure Storage.lincon
[C#]
public struct Storage.lincon
[C++]
public __value struct Storage.lincon

[JScript] In JScript, you can use the structures defined by a type, but you cannot define your own.

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: CommodityStorage.Storage

Assembly: CommodityStorage (in CommodityStorage.dll)

See Also

Storage.lincon Members | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.lincon Members

Storage.lincon overview

Public Instance Fields

cons | name="cons" What is this?
conslhs | name="conslhs" Left hand side of the linear constraints.
consnames | name="consnames" Linear constraints names
consrhs | name="consrhs" Right hand side of the linear constriaints.

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

Storage.lincon Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.lincon Fields

The fields of the Storage.lincon structure are listed below. For a complete list of Storage.lincon structure members, see the Storage.lincon Members topic.

Public Instance Fields

cons | name="cons" What is this?
conslhs | name="conslhs" Left hand side of the linear constraints.
consnames | name="consnames" Linear constraints names
consrhs | name="consrhs" Right hand side of the linear constriaints.

See Also

Storage.lincon Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.lincon.cons Field

name="cons" What is this?

[Visual Basic]
Public cons As Integer()
[C#]
public int[] cons;
[C++]
public: int cons __gc[];
[JScript]
public var cons: int[];

See Also

Storage.lincon Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.lincon.conslhs Field

name="conslhs" Left hand side of the linear constraints.

[Visual Basic]
Public conslhs As Double(,)
[C#]
public double[,] conslhs;
[C++]
public: double conslhs __gc[];
[JScript]
public var conslhs: double[,];

See Also

Storage.lincon Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.lincon.consnames Field

name="consnames" Linear constraints names

[Visual Basic]
Public consnames As String()
[C#]
public string[] consnames;
[C++]
public: String* consnames __gc[];
[JScript]
public var consnames: String[];

See Also

Storage.lincon Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.lincon.consrhs Field

name="consrhs" Right hand side of the linear constriaints.

[Visual Basic]
Public consrhs As Double()
[C#]
public double[] consrhs;
[C++]
public: double consrhs __gc[];
[JScript]
public var consrhs: double[];

See Also

Storage.lincon Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.PrintFlagStruct Structure

Structure: PrintFlagStruc structure of print flag inputs used for logging and debugging or for output of results for post valuation processing and analysis

For a list of all members of this type, see Storage.PrintFlagStruct Members.

System.Object
System.ValueType
CommodityStorage.Storage.Storage.PrintFlagStruct

[Visual Basic]
Public Structure Storage.PrintFlagStruct
[C#]
public struct Storage.PrintFlagStruct
[C++]
public __value struct Storage.PrintFlagStruct

[JScript] In JScript, you can use the structures defined by a type, but you cannot define your own.

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: CommodityStorage.Storage

Assembly: CommodityStorage (in CommodityStorage.dll)

See Also

Storage.PrintFlagStruct Members | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.PrintFlagStruct Members

Storage.PrintFlagStruct overview

Public Instance Fields

Correlated | name="Correlated" Will be deleted!
DB | name="DB" Flag to print to a database or text files
Debug | name="Debug" Will be deleted!
IterationValues | name="IterationValues" Output the iteration values transacted across all trajectories.
Log | name="Log" Generate run log: Can cause memory overflow exception if running 400+ Trajectories!
Prices | name="Prices" Will be deleted!
PrintAll | name="PrintAll" Output the everything across all trajectories.
Profits | name="Profits" Output the revenues and expenses transacted across all trajectories.
Random | name="Random" Will be deleted!
RAROC | name="RAROC" Output the RAROC details Not implemented yet!
Volume | name="Volume" Output the volumes transacted across all trajectories.

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

Storage.PrintFlagStruct Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.PrintFlagStruct Fields

The fields of the Storage.PrintFlagStruct structure are listed below. For a complete list of Storage.PrintFlagStruct structure members, see the Storage.PrintFlagStruct Members topic.

Public Instance Fields

Correlated | name="Correlated" Will be deleted!
DB | name="DB" Flag to print to a database or text files
Debug | name="Debug" Will be deleted!
IterationValues | name="IterationValues" Output the iteration values transacted across all trajectories.
Log | name="Log" Generate run log: Can cause memory overflow exception if running 400+ Trajectories!
Prices | name="Prices" Will be deleted!
PrintAll | name="PrintAll" Output the everything across all trajectories.
Profits | name="Profits" Output the revenues and expenses transacted across all trajectories.
Random | name="Random" Will be deleted!
RAROC | name="RAROC" Output the RAROC details Not implemented yet!
Volume | name="Volume" Output the volumes transacted across all trajectories.

See Also

Storage.PrintFlagStruct Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.PrintFlagStruct.Correlated Field

name="Correlated" Will be deleted!

[Visual Basic]
Public Correlated As Boolean
[C#]
public bool Correlated;
[C++]
public: bool Correlated;
[JScript]
public var Correlated: bool;

See Also

Storage.PrintFlagStruct Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.PrintFlagStruct.DB Field

name="DB" Flag to print to a database or text files

[Visual Basic]
Public DB As Boolean
[C#]
public bool DB;
[C++]
public: bool DB;
[JScript]
public var DB: bool;

See Also

Storage.PrintFlagStruct Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.PrintFlagStruct.Debug Field

name="Debug" Will be deleted!

[Visual Basic]
Public Debug As Boolean
[C#]
public bool Debug;
[C++]
public: bool Debug;
[JScript]
public var Debug: bool;

See Also

Storage.PrintFlagStruct Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.PrintFlagStruct.IterationValues Field

name="IterationValues" Output the iteration values transacted across all trajectories.

[Visual Basic]
Public IterationValues As Boolean
[C#]
public bool IterationValues;
[C++]
public: bool IterationValues;
[JScript]
public var IterationValues: bool;

See Also

Storage.PrintFlagStruct Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.PrintFlagStruct.Log Field

name="Log" Generate run log: Can cause memory overflow exception if running 400+ Trajectories!

[Visual Basic]
Public Log As Boolean
[C#]
public bool Log;
[C++]
public: bool Log;
[JScript]
public var Log: bool;

See Also

Storage.PrintFlagStruct Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.PrintFlagStruct.Prices Field

name="Prices" Will be deleted!

[Visual Basic]
Public Prices As Boolean
[C#]
public bool Prices;
[C++]
public: bool Prices;
[JScript]
public var Prices: bool;

See Also

Storage.PrintFlagStruct Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.PrintFlagStruct.PrintAll Field

name="PrintAll" Output the everything across all trajectories.

[Visual Basic]
Public PrintAll As Boolean
[C#]
public bool PrintAll;
[C++]
public: bool PrintAll;
[JScript]
public var PrintAll: bool;

See Also

Storage.PrintFlagStruct Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.PrintFlagStruct.Profits Field

name="Profits" Output the revenues and expenses transacted across all trajectories.

[Visual Basic]
Public Profits As Boolean
[C#]
public bool Profits;
[C++]
public: bool Profits;
[JScript]
public var Profits: bool;

See Also

Storage.PrintFlagStruct Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.PrintFlagStruct.Random Field

name="Random" Will be deleted!

[Visual Basic]
Public Random As Boolean
[C#]
public bool Random;
[C++]
public: bool Random;
[JScript]
public var Random: bool;

See Also

Storage.PrintFlagStruct Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.PrintFlagStruct.RAROC Field

name="RAROC" Output the RAROC details Not implemented yet!

[Visual Basic]
Public RAROC As Boolean
[C#]
public bool RAROC;
[C++]
public: bool RAROC;
[JScript]
public var RAROC: bool;

See Also

Storage.PrintFlagStruct Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.PrintFlagStruct.Volume Field

name="Volume" Output the volumes transacted across all trajectories.

[Visual Basic]
Public Volume As Boolean
[C#]
public bool Volume;
[C++]
public: bool Volume;
[JScript]
public var Volume: bool;

See Also

Storage.PrintFlagStruct Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.Profit Structure

Structure: Profit structure for revenue, expense and profits calculation results

For a list of all members of this type, see Storage.Profit Members.

System.Object
System.ValueType
CommodityStorage.Storage.Storage.Profit

[Visual Basic]
Public Structure Storage.Profit
[C#]
public struct Storage.Profit
[C++]
public __value struct Storage.Profit

[JScript] In JScript, you can use the structures defined by a type, but you cannot define your own.

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: CommodityStorage.Storage

Assembly: CommodityStorage (in CommodityStorage.dll)

See Also

Storage.Profit Members | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.Profit Members

Storage.Profit overview

Public Instance Fields

Costs | name="Costs" Costs
marginalExpenses | name="marginalExpenses" Marginal Expenses
marginalProfit | name="marginalProfit" Marginal Profit
marginalRevenue | name="marginalRevenue" Marginal Revenue

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

Storage.Profit Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.Profit Fields

The fields of the Storage.Profit structure are listed below. For a complete list of Storage.Profit structure members, see the Storage.Profit Members topic.

Public Instance Fields

Costs | name="Costs" Costs
marginalExpenses | name="marginalExpenses" Marginal Expenses
marginalProfit | name="marginalProfit" Marginal Profit
marginalRevenue | name="marginalRevenue" Marginal Revenue

See Also

Storage.Profit Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.Profit.Costs Field

name="Costs" Costs

[Visual Basic]
Public Costs As Double
[C#]
public double Costs;
[C++]
public: double Costs;
[JScript]
public var Costs: double;

See Also

Storage.Profit Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.Profit.marginalExpenses Field

name="marginalExpenses" Marginal Expenses

[Visual Basic]
Public marginalExpenses As Double
[C#]
public double marginalExpenses;
[C++]
public: double marginalExpenses;
[JScript]
public var marginalExpenses: double;

See Also

Storage.Profit Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.Profit.marginalProfit Field

name="marginalProfit" Marginal Profit

[Visual Basic]
Public marginalProfit As Double
[C#]
public double marginalProfit;
[C++]
public: double marginalProfit;
[JScript]
public var marginalProfit: double;

See Also

Storage.Profit Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.Profit.marginalRevenue Field

name="marginalRevenue" Marginal Revenue

[Visual Basic]
Public marginalRevenue As Double
[C#]
public double marginalRevenue;
[C++]
public: double marginalRevenue;
[JScript]
public var marginalRevenue: double;

See Also

Storage.Profit Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.Ratchets Structure

Structure: Ratchets structure for holding injections and withdrawal ratchets

For a list of all members of this type, see Storage.Ratchets Members.

System.Object
System.ValueType
CommodityStorage.Storage.Storage.Ratchets

[Visual Basic]
Public Structure Storage.Ratchets
[C#]
public struct Storage.Ratchets
[C++]
public __value struct Storage.Ratchets

[JScript] In JScript, you can use the structures defined by a type, but you cannot define your own.

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: CommodityStorage.Storage

Assembly: CommodityStorage (in CommodityStorage.dll)

See Also

Storage.Ratchets Members | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.Ratchets Members

Storage.Ratchets overview

Public Instance Fields

mdiq | name="MDIQ" Maximum daily injection quantity
mdwq | name="MDWQ" Maximum daily withdrawal quantity

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

Storage.Ratchets Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.Ratchets Fields

The fields of the Storage.Ratchets structure are listed below. For a complete list of Storage.Ratchets structure members, see the Storage.Ratchets Members topic.

Public Instance Fields

mdiq | name="MDIQ" Maximum daily injection quantity
mdwq | name="MDWQ" Maximum daily withdrawal quantity

See Also

Storage.Ratchets Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.Ratchets.mdiq Field

name="MDIQ" Maximum daily injection quantity

[Visual Basic]
Public mdiq As Double
[C#]
public double mdiq;
[C++]
public: double mdiq;
[JScript]
public var mdiq: double;

See Also

Storage.Ratchets Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.Ratchets.mdwq Field

name="MDWQ" Maximum daily withdrawal quantity

[Visual Basic]
Public mdwq As Double
[C#]
public double mdwq;
[C++]
public: double mdwq;
[JScript]
public var mdwq: double;

See Also

Storage.Ratchets Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.RiskAdjStruct Structure

Structure: Lmoment RiskAdjStruct structure for risk adjusted cash flow results. This is not currrently implemented

For a list of all members of this type, see Storage.RiskAdjStruct Members.

System.Object
System.ValueType
CommodityStorage.Storage.Storage.RiskAdjStruct

[Visual Basic]
Public Structure Storage.RiskAdjStruct
[C#]
public struct Storage.RiskAdjStruct
[C++]
public __value struct Storage.RiskAdjStruct

[JScript] In JScript, you can use the structures defined by a type, but you cannot define your own.

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: CommodityStorage.Storage

Assembly: CommodityStorage (in CommodityStorage.dll)

See Also

Storage.RiskAdjStruct Members | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.RiskAdjStruct Members

Storage.RiskAdjStruct overview

Public Instance Fields

L | name="L" array for lmoments calculations
M | name="M" array for lmoments calcuations
Sigma | name="Sigma" Lmoment standard deviation
Tau3 | name="Tau3" Lmoment Tau3 skewness coefficient
Value | name="Value" Lmoment risk adjusted value

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

Storage.RiskAdjStruct Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.RiskAdjStruct Fields

The fields of the Storage.RiskAdjStruct structure are listed below. For a complete list of Storage.RiskAdjStruct structure members, see the Storage.RiskAdjStruct Members topic.

Public Instance Fields

L | name="L" array for lmoments calculations
M | name="M" array for lmoments calcuations
Sigma | name="Sigma" Lmoment standard deviation
Tau3 | name="Tau3" Lmoment Tau3 skewness coefficient
Value | name="Value" Lmoment risk adjusted value

See Also

Storage.RiskAdjStruct Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.RiskAdjStruct.L Field

name="L" array for lmoments calculations

[Visual Basic]
Public L As Array
[C#]
public Array L;
[C++]
public: Array* L;
[JScript]
public var L: Array;

See Also

Storage.RiskAdjStruct Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.RiskAdjStruct.M Field

name="M" array for lmoments calcuations

[Visual Basic]
Public M As Array
[C#]
public Array M;
[C++]
public: Array* M;
[JScript]
public var M: Array;

See Also

Storage.RiskAdjStruct Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.RiskAdjStruct.Sigma Field

name="Sigma" Lmoment standard deviation

[Visual Basic]
Public Sigma As Double
[C#]
public double Sigma;
[C++]
public: double Sigma;
[JScript]
public var Sigma: double;

See Also

Storage.RiskAdjStruct Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.RiskAdjStruct.Tau3 Field

name="Tau3" Lmoment Tau3 skewness coefficient

[Visual Basic]
Public Tau3 As Double
[C#]
public double Tau3;
[C++]
public: double Tau3;
[JScript]
public var Tau3: double;

See Also

Storage.RiskAdjStruct Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.RiskAdjStruct.Value Field

name="Value" Lmoment risk adjusted value

[Visual Basic]
Public Value As Double
[C#]
public double Value;
[C++]
public: double Value;
[JScript]
public var Value: double;

See Also

Storage.RiskAdjStruct Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.s_trajectory Structure

Structure: s_trajectory structure for holding optimization inputs and results

For a list of all members of this type, see Storage.s_trajectory Members.

System.Object
System.ValueType
CommodityStorage.Storage.Storage.s_trajectory

[Visual Basic]
Public Structure Storage.s_trajectory
[C#]
public struct Storage.s_trajectory
[C++]
public __value struct Storage.s_trajectory

[JScript] In JScript, you can use the structures defined by a type, but you cannot define your own.

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: CommodityStorage.Storage

Assembly: CommodityStorage (in CommodityStorage.dll)

See Also

Storage.s_trajectory Members | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.s_trajectory Members

Storage.s_trajectory overview

Public Instance Fields

dailyvolumes | name="dailyvolumes" Daily volumes object
day | name="day" Day
discountfactor | name="discountfactor" Discountfactor
interest | name="interest" Interest rate
maturity | name="maturity" Maturity in percentage of years
month | name="month" Month
simprices | name="simprice" Simulated price curve object
ssi | name="ssi" Optimization inputs object
ssr | name="ssr" Optimization results object
trajectory | name="trajectory" Trajectory curve object of initial inputs
transactiondate | name="transactiondate" Transaction date
year | name="year" Year

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

Storage.s_trajectory Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.s_trajectory Fields

The fields of the Storage.s_trajectory structure are listed below. For a complete list of Storage.s_trajectory structure members, see the Storage.s_trajectory Members topic.

Public Instance Fields

dailyvolumes | name="dailyvolumes" Daily volumes object
day | name="day" Day
discountfactor | name="discountfactor" Discountfactor
interest | name="interest" Interest rate
maturity | name="maturity" Maturity in percentage of years
month | name="month" Month
simprices | name="simprice" Simulated price curve object
ssi | name="ssi" Optimization inputs object
ssr | name="ssr" Optimization results object
trajectory | name="trajectory" Trajectory curve object of initial inputs
transactiondate | name="transactiondate" Transaction date
year | name="year" Year

See Also

Storage.s_trajectory Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.s_trajectory.dailyvolumes Field

name="dailyvolumes" Daily volumes object

[Visual Basic]
Public dailyvolumes As storage_iter()
[C#]
public storage_iter[] dailyvolumes;
[C++]
public: storage_iter* dailyvolumes __gc[];
[JScript]
public var dailyvolumes: storage_iter[];

See Also

Storage.s_trajectory Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.s_trajectory.day Field

name="day" Day

[Visual Basic]
Public day As Long
[C#]
public long day;
[C++]
public: __int64 day;
[JScript]
public var day: long;

See Also

Storage.s_trajectory Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.s_trajectory.discountfactor Field

name="discountfactor" Discountfactor

[Visual Basic]
Public discountfactor As Double
[C#]
public double discountfactor;
[C++]
public: double discountfactor;
[JScript]
public var discountfactor: double;

See Also

Storage.s_trajectory Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.s_trajectory.interest Field

name="interest" Interest rate

[Visual Basic]
Public interest As Double
[C#]
public double interest;
[C++]
public: double interest;
[JScript]
public var interest: double;

See Also

Storage.s_trajectory Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.s_trajectory.maturity Field

name="maturity" Maturity in percentage of years

[Visual Basic]
Public maturity As Double
[C#]
public double maturity;
[C++]
public: double maturity;
[JScript]
public var maturity: double;

See Also

Storage.s_trajectory Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.s_trajectory.month Field

name="month" Month

[Visual Basic]
Public month As Long
[C#]
public long month;
[C++]
public: __int64 month;
[JScript]
public var month: long;

See Also

Storage.s_trajectory Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.s_trajectory.simprices Field

name="simprice" Simulated price curve object

[Visual Basic]
Public simprices As simcurve()
[C#]
public simcurve[] simprices;
[C++]
public: simcurve* simprices __gc[];
[JScript]
public var simprices: simcurve[];

See Also

Storage.s_trajectory Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.s_trajectory.ssi Field

name="ssi" Optimization inputs object

[Visual Basic]
Public ssi As SS_inputs
[C#]
public SS_inputs ssi;
[C++]
public: SS_inputs ssi;
[JScript]
public var ssi: SS_inputs;

See Also

Storage.s_trajectory Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.s_trajectory.ssr Field

name="ssr" Optimization results object

[Visual Basic]
Public ssr As ss_results()
[C#]
public ss_results[] ssr;
[C++]
public: ss_results* ssr __gc[];
[JScript]
public var ssr: ss_results[];

See Also

Storage.s_trajectory Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.s_trajectory.trajectory Field

name="trajectory" Trajectory curve object of initial inputs

[Visual Basic]
Public trajectory As trajectorycurve
[C#]
public trajectorycurve trajectory;
[C++]
public: trajectorycurve trajectory;
[JScript]
public var trajectory: trajectorycurve;

See Also

Storage.s_trajectory Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.s_trajectory.transactiondate Field

name="transactiondate" Transaction date

[Visual Basic]
Public transactiondate As Date
[C#]
public DateTime transactiondate;
[C++]
public: DateTime transactiondate;
[JScript]
public var transactiondate: DateTime;

See Also

Storage.s_trajectory Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.s_trajectory.year Field

name="year" Year

[Visual Basic]
Public year As Long
[C#]
public long year;
[C++]
public: __int64 year;
[JScript]
public var year: long;

See Also

Storage.s_trajectory Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.simcurve Structure

Structure: simcurve structure for simulated prices

For a list of all members of this type, see Storage.simcurve Members.

System.Object
System.ValueType
CommodityStorage.Storage.Storage.simcurve

[Visual Basic]
Public Structure Storage.simcurve
[C#]
public struct Storage.simcurve
[C++]
public __value struct Storage.simcurve

[JScript] In JScript, you can use the structures defined by a type, but you cannot define your own.

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: CommodityStorage.Storage

Assembly: CommodityStorage (in CommodityStorage.dll)

See Also

Storage.simcurve Members | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.simcurve Members

Storage.simcurve overview

Public Instance Fields

Forward name="Price" Prices array across all contract expirations array.

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

Storage.simcurve Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.simcurve Fields

The fields of the Storage.simcurve structure are listed below. For a complete list of Storage.simcurve structure members, see the Storage.simcurve Members topic.

Public Instance Fields

Forward name="Price" Prices array across all contract expirations array.

See Also

Storage.simcurve Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.simcurve.Forward Field

name="Price" Prices array across all contract expirations array.

[Visual Basic]
Public Forward As Double()
[C#]
public double[] Forward;
[C++]
public: double Forward __gc[];
[JScript]
public var Forward: double[];

See Also

Storage.simcurve Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.SS_inputs Structure

Structure: SS_inputs structure for holding optimizer inputs of boundary conditions, linear constraints, objective function values, and other data

For a list of all members of this type, see Storage.SS_inputs Members.

System.Object
System.ValueType
CommodityStorage.Storage.Storage.SS_inputs

[Visual Basic]
Public Structure Storage.SS_inputs
[C#]
public struct Storage.SS_inputs
[C++]
public __value struct Storage.SS_inputs

[JScript] In JScript, you can use the structures defined by a type, but you cannot define your own.

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: CommodityStorage.Storage

Assembly: CommodityStorage (in CommodityStorage.dll)

See Also

Storage.SS_inputs Members | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.SS_inputs Members

Storage.SS_inputs overview

Public Instance Fields

flaggedcon | name="flaggedcon" Initial constraints array for the day, see paper on www.financialseal.com for detials.
lincon1 | name="lincon1" Initial constraints array for the day, see paper on www.financialseal.com for detials.
lincon2 | name="lincon2" Initial constraints array for the day, see paper on www.financialseal.com for detials.
lowerbd | name="lowerbd" Lower boundary array for the day.
master | name="master" Initial constraints array for the day, see paper on www.financialseal.com for detials.
obj | name="obj" Objective function
upperbd | name="upperbd" Upper boundary array for the day.
var | name="var" Initial values for starting the optimization, beginning of day postions.

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

Storage.SS_inputs Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.SS_inputs Fields

The fields of the Storage.SS_inputs structure are listed below. For a complete list of Storage.SS_inputs structure members, see the Storage.SS_inputs Members topic.

Public Instance Fields

flaggedcon | name="flaggedcon" Initial constraints array for the day, see paper on www.financialseal.com for detials.
lincon1 | name="lincon1" Initial constraints array for the day, see paper on www.financialseal.com for detials.
lincon2 | name="lincon2" Initial constraints array for the day, see paper on www.financialseal.com for detials.
lowerbd | name="lowerbd" Lower boundary array for the day.
master | name="master" Initial constraints array for the day, see paper on www.financialseal.com for detials.
obj | name="obj" Objective function
upperbd | name="upperbd" Upper boundary array for the day.
var | name="var" Initial values for starting the optimization, beginning of day postions.

See Also

Storage.SS_inputs Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.SS_inputs.flaggedcon Field

name="flaggedcon" Initial constraints array for the day, see paper on www.financialseal.com for detials.

[Visual Basic]
Public flaggedcon As lincon
[C#]
public lincon flaggedcon;
[C++]
public: lincon flaggedcon;
[JScript]
public var flaggedcon: lincon;

See Also

Storage.SS_inputs Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.SS_inputs.lincon1 Field

name="lincon1" Initial constraints array for the day, see paper on www.financialseal.com for detials.

[Visual Basic]
Public lincon1 As lincon
[C#]
public lincon lincon1;
[C++]
public: lincon lincon1;
[JScript]
public var lincon1: lincon;

See Also

Storage.SS_inputs Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.SS_inputs.lincon2 Field

name="lincon2" Initial constraints array for the day, see paper on www.financialseal.com for detials.

[Visual Basic]
Public lincon2 As lincon
[C#]
public lincon lincon2;
[C++]
public: lincon lincon2;
[JScript]
public var lincon2: lincon;

See Also

Storage.SS_inputs Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.SS_inputs.lowerbd Field

name="lowerbd" Lower boundary array for the day.

[Visual Basic]
Public lowerbd As Double()
[C#]
public double[] lowerbd;
[C++]
public: double lowerbd __gc[];
[JScript]
public var lowerbd: double[];

See Also

Storage.SS_inputs Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.SS_inputs.master Field

name="master" Initial constraints array for the day, see paper on www.financialseal.com for detials.

[Visual Basic]
Public master As lincon
[C#]
public lincon master;
[C++]
public: lincon master;
[JScript]
public var master: lincon;

See Also

Storage.SS_inputs Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.SS_inputs.obj Field

name="obj" Objective function

[Visual Basic]
Public obj As Double()
[C#]
public double[] obj;
[C++]
public: double obj __gc[];
[JScript]
public var obj: double[];

See Also

Storage.SS_inputs Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.SS_inputs.upperbd Field

name="upperbd" Upper boundary array for the day.

[Visual Basic]
Public upperbd As Double()
[C#]
public double[] upperbd;
[C++]
public: double upperbd __gc[];
[JScript]
public var upperbd: double[];

See Also

Storage.SS_inputs Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.SS_inputs.var Field

name="var" Initial values for starting the optimization, beginning of day postions.

[Visual Basic]
Public var As String()
[C#]
public string[] var;
[C++]
public: String* var __gc[];
[JScript]
public var var: String[];

See Also

Storage.SS_inputs Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.ss_results Structure

Structure: ss_results structure for optimization results

For a list of all members of this type, see Storage.ss_results Members.

System.Object
System.ValueType
CommodityStorage.Storage.Storage.ss_results

[Visual Basic]
Public Structure Storage.ss_results
[C#]
public struct Storage.ss_results
[C++]
public __value struct Storage.ss_results

[JScript] In JScript, you can use the structures defined by a type, but you cannot define your own.

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: CommodityStorage.Storage

Assembly: CommodityStorage (in CommodityStorage.dll)

See Also

Storage.ss_results Members | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.ss_results Members

Storage.ss_results overview

Public Instance Fields

cons_results | name="cons_results" Contraint results array, shadow prices: can be used to determine delta.
lower | name="constraints" Initial constraints array for the day.
objective | name="objective" Objective functions returned value.
upper | name="upper" Upper boundary array for the day.
var_results | name="var_results" Variable results array.

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

Storage.ss_results Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.ss_results Fields

The fields of the Storage.ss_results structure are listed below. For a complete list of Storage.ss_results structure members, see the Storage.ss_results Members topic.

Public Instance Fields

cons_results | name="cons_results" Contraint results array, shadow prices: can be used to determine delta.
lower | name="constraints" Initial constraints array for the day.
objective | name="objective" Objective functions returned value.
upper | name="upper" Upper boundary array for the day.
var_results | name="var_results" Variable results array.

See Also

Storage.ss_results Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.ss_results.cons_results Field

name="cons_results" Contraint results array, shadow prices: can be used to determine delta.

[Visual Basic]
Public cons_results As Double()
[C#]
public double[] cons_results;
[C++]
public: double cons_results __gc[];
[JScript]
public var cons_results: double[];

See Also

Storage.ss_results Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.ss_results.lower Field

name="constraints" Initial constraints array for the day.

[Visual Basic]
Public lower As Double()
[C#]
public double[] lower;
[C++]
public: double lower __gc[];
[JScript]
public var lower: double[];

See Also

Storage.ss_results Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.ss_results.objective Field

name="objective" Objective functions returned value.

[Visual Basic]
Public objective As Double
[C#]
public double objective;
[C++]
public: double objective;
[JScript]
public var objective: double;

See Also

Storage.ss_results Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.ss_results.upper Field

name="upper" Upper boundary array for the day.

[Visual Basic]
Public upper As Double()
[C#]
public double[] upper;
[C++]
public: double upper __gc[];
[JScript]
public var upper: double[];

See Also

Storage.ss_results Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.ss_results.var_results Field

name="var_results" Variable results array.

[Visual Basic]
Public var_results As Double()
[C#]
public double[] var_results;
[C++]
public: double var_results __gc[];
[JScript]
public var var_results: double[];

See Also

Storage.ss_results Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.StaticVars Structure

Structure: StaticVars structure for static variables

For a list of all members of this type, see Storage.StaticVars Members.

System.Object
System.ValueType
CommodityStorage.Storage.Storage.StaticVars

[Visual Basic]
Public Structure Storage.StaticVars
[C#]
public struct Storage.StaticVars
[C++]
public __value struct Storage.StaticVars

[JScript] In JScript, you can use the structures defined by a type, but you cannot define your own.

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: CommodityStorage.Storage

Assembly: CommodityStorage (in CommodityStorage.dll)

See Also

Storage.StaticVars Members | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.StaticVars Members

Storage.StaticVars overview

Public Instance Fields

BookName | name="BookName " Name of excel file for end of run reporting. A date will be appended.
BTUFactor | name="BTUFactor" BTU factor for gas in facility
commodity_type | name="Commodity Type " Commodity type based on NYMEX abbreviations
contractsize | name="Contractsize" Volume per contract of commodity
counterparty | name="counterparty" Storage Facility ID
counterparty_name | name="counterparty_name" Storage Facility Name
Curve | name="curve" Curve ID structure for downloading from database connection
dailyratchets | name="dailyratchets" Array variable of injection and withdrawal ratchets
dataloc | name="dataloc" Physical directory location of simulation and input files
DaysIn | name="DaysIn" Number of days to fill the storage facility to MSQ
DaysOut | name="DaysOut" Number of days to empty storage facility
DealStartDate | name="DealStartDate" Contractual start date of storage facility
emtbymarflag | name="emtbymarflag" Boolean flag to specify storage facility empty by the end of March
enddate | name="enddate" Contractual termination date of storage facility
fullbynovflag | name="fullbynovflag" Boolean flag to specify storage facility full by the 1st day of November
MSQ | name="MSQ" Maximum storage capacty of the facility
projectlife | name="projectlife" Contractual remaining life of deal, could be calculated
simvalue | name="simvalue" Physical file of simulation data
Storagecosts | name="Storagecost" variable of the storage facility cost structure

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

Storage.StaticVars Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.StaticVars Fields

The fields of the Storage.StaticVars structure are listed below. For a complete list of Storage.StaticVars structure members, see the Storage.StaticVars Members topic.

Public Instance Fields

BookName | name="BookName " Name of excel file for end of run reporting. A date will be appended.
BTUFactor | name="BTUFactor" BTU factor for gas in facility
commodity_type | name="Commodity Type " Commodity type based on NYMEX abbreviations
contractsize | name="Contractsize" Volume per contract of commodity
counterparty | name="counterparty" Storage Facility ID
counterparty_name | name="counterparty_name" Storage Facility Name
Curve | name="curve" Curve ID structure for downloading from database connection
dailyratchets | name="dailyratchets" Array variable of injection and withdrawal ratchets
dataloc | name="dataloc" Physical directory location of simulation and input files
DaysIn | name="DaysIn" Number of days to fill the storage facility to MSQ
DaysOut | name="DaysOut" Number of days to empty storage facility
DealStartDate | name="DealStartDate" Contractual start date of storage facility
emtbymarflag | name="emtbymarflag" Boolean flag to specify storage facility empty by the end of March
enddate | name="enddate" Contractual termination date of storage facility
fullbynovflag | name="fullbynovflag" Boolean flag to specify storage facility full by the 1st day of November
MSQ | name="MSQ" Maximum storage capacty of the facility
projectlife | name="projectlife" Contractual remaining life of deal, could be calculated
simvalue | name="simvalue" Physical file of simulation data
Storagecosts | name="Storagecost" variable of the storage facility cost structure

See Also

Storage.StaticVars Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.StaticVars.BookName Field

name="BookName " Name of excel file for end of run reporting. A date will be appended.

[Visual Basic]
Public BookName As String
[C#]
public string BookName;
[C++]
public: String* BookName;
[JScript]
public var BookName: String;

See Also

Storage.StaticVars Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.StaticVars.BTUFactor Field

name="BTUFactor" BTU factor for gas in facility

[Visual Basic]
Public BTUFactor As Double
[C#]
public double BTUFactor;
[C++]
public: double BTUFactor;
[JScript]
public var BTUFactor: double;

See Also

Storage.StaticVars Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.StaticVars.commodity_type Field

name="Commodity Type " Commodity type based on NYMEX abbreviations

[Visual Basic]
Public commodity_type As String
[C#]
public string commodity_type;
[C++]
public: String* commodity_type;
[JScript]
public var commodity_type: String;

See Also

Storage.StaticVars Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.StaticVars.contractsize Field

name="Contractsize" Volume per contract of commodity

[Visual Basic]
Public contractsize As Double
[C#]
public double contractsize;
[C++]
public: double contractsize;
[JScript]
public var contractsize: double;

See Also

Storage.StaticVars Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.StaticVars.counterparty Field

name="counterparty" Storage Facility ID

[Visual Basic]
Public counterparty As String
[C#]
public string counterparty;
[C++]
public: String* counterparty;
[JScript]
public var counterparty: String;

See Also

Storage.StaticVars Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.StaticVars.counterparty_name Field

name="counterparty_name" Storage Facility Name

[Visual Basic]
Public counterparty_name As String
[C#]
public string counterparty_name;
[C++]
public: String* counterparty_name;
[JScript]
public var counterparty_name: String;

See Also

Storage.StaticVars Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.StaticVars.Curve Field

name="curve" Curve ID structure for downloading from database connection

[Visual Basic]
Public Curve As CurveIDStruct
[C#]
public CurveIDStruct Curve;
[C++]
public: CurveIDStruct Curve;
[JScript]
public var Curve: CurveIDStruct;

See Also

Storage.StaticVars Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.StaticVars.dailyratchets Field

name="dailyratchets" Array variable of injection and withdrawal ratchets

[Visual Basic]
Public dailyratchets As Ratchets()
[C#]
public Ratchets[] dailyratchets;
[C++]
public: Ratchets* dailyratchets __gc[];
[JScript]
public var dailyratchets: Ratchets[];

See Also

Storage.StaticVars Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.StaticVars.dataloc Field

name="dataloc" Physical directory location of simulation and input files

[Visual Basic]
Public dataloc As String
[C#]
public string dataloc;
[C++]
public: String* dataloc;
[JScript]
public var dataloc: String;

See Also

Storage.StaticVars Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.StaticVars.DaysIn Field

name="DaysIn" Number of days to fill the storage facility to MSQ

[Visual Basic]
Public DaysIn As Double
[C#]
public double DaysIn;
[C++]
public: double DaysIn;
[JScript]
public var DaysIn: double;

See Also

Storage.StaticVars Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.StaticVars.DaysOut Field

name="DaysOut" Number of days to empty storage facility

[Visual Basic]
Public DaysOut As Double
[C#]
public double DaysOut;
[C++]
public: double DaysOut;
[JScript]
public var DaysOut: double;

See Also

Storage.StaticVars Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.StaticVars.DealStartDate Field

name="DealStartDate" Contractual start date of storage facility

[Visual Basic]
Public DealStartDate As Date
[C#]
public DateTime DealStartDate;
[C++]
public: DateTime DealStartDate;
[JScript]
public var DealStartDate: DateTime;

See Also

Storage.StaticVars Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.StaticVars.emtbymarflag Field

name="emtbymarflag" Boolean flag to specify storage facility empty by the end of March

[Visual Basic]
Public emtbymarflag As Boolean
[C#]
public bool emtbymarflag;
[C++]
public: bool emtbymarflag;
[JScript]
public var emtbymarflag: bool;

See Also

Storage.StaticVars Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.StaticVars.enddate Field

name="enddate" Contractual termination date of storage facility

[Visual Basic]
Public enddate As Date
[C#]
public DateTime enddate;
[C++]
public: DateTime enddate;
[JScript]
public var enddate: DateTime;

See Also

Storage.StaticVars Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.StaticVars.fullbynovflag Field

name="fullbynovflag" Boolean flag to specify storage facility full by the 1st day of November

[Visual Basic]
Public fullbynovflag As Boolean
[C#]
public bool fullbynovflag;
[C++]
public: bool fullbynovflag;
[JScript]
public var fullbynovflag: bool;

See Also

Storage.StaticVars Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.StaticVars.MSQ Field

name="MSQ" Maximum storage capacty of the facility

[Visual Basic]
Public MSQ As Long
[C#]
public long MSQ;
[C++]
public: __int64 MSQ;
[JScript]
public var MSQ: long;

See Also

Storage.StaticVars Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.StaticVars.projectlife Field

name="projectlife" Contractual remaining life of deal, could be calculated

[Visual Basic]
Public projectlife As Long
[C#]
public long projectlife;
[C++]
public: __int64 projectlife;
[JScript]
public var projectlife: long;

See Also

Storage.StaticVars Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.StaticVars.simvalue Field

name="simvalue" Physical file of simulation data

[Visual Basic]
Public simvalue As String
[C#]
public string simvalue;
[C++]
public: String* simvalue;
[JScript]
public var simvalue: String;

See Also

Storage.StaticVars Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.StaticVars.Storagecosts Field

name="Storagecost" variable of the storage facility cost structure

[Visual Basic]
Public Storagecosts As CostStruct
[C#]
public CostStruct Storagecosts;
[C++]
public: CostStruct Storagecosts;
[JScript]
public var Storagecosts: CostStruct;

See Also

Storage.StaticVars Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.storage_iter Structure

Structure: storage_iter structure for holding temporary volume results over each iteration

For a list of all members of this type, see Storage.storage_iter Members.

System.Object
System.ValueType
CommodityStorage.Storage.Storage.storage_iter

[Visual Basic]
Public Structure Storage.storage_iter
[C#]
public struct Storage.storage_iter
[C++]
public __value struct Storage.storage_iter

[JScript] In JScript, you can use the structures defined by a type, but you cannot define your own.

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: CommodityStorage.Storage

Assembly: CommodityStorage (in CommodityStorage.dll)

See Also

Storage.storage_iter Members | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.storage_iter Members

Storage.storage_iter overview

Public Instance Fields

currentperiod | name="currentperiod" Current period
currentyear | name="currentyear" Current year
delivered | name="delivered" Physical commodity volume delivered during current period or tenor.
gad | name="gad" Physical commodity volume available for delivery during current period or tenor.
gaddaily | name="gaddaily" Physical commodity volume being delivered during current period or tenor.
gadnext | name="gadnext" Physical commodity volume available for delivery during following period or tenor.
gig | name="gig" Physical commodity volume in inventory.
gigeom | name="gigeom" Physical commodity volume in inventory at the end of the current period or tenor.
position | name="position" Financial positionfor the period

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

Storage.storage_iter Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.storage_iter Fields

The fields of the Storage.storage_iter structure are listed below. For a complete list of Storage.storage_iter structure members, see the Storage.storage_iter Members topic.

Public Instance Fields

currentperiod | name="currentperiod" Current period
currentyear | name="currentyear" Current year
delivered | name="delivered" Physical commodity volume delivered during current period or tenor.
gad | name="gad" Physical commodity volume available for delivery during current period or tenor.
gaddaily | name="gaddaily" Physical commodity volume being delivered during current period or tenor.
gadnext | name="gadnext" Physical commodity volume available for delivery during following period or tenor.
gig | name="gig" Physical commodity volume in inventory.
gigeom | name="gigeom" Physical commodity volume in inventory at the end of the current period or tenor.
position | name="position" Financial positionfor the period

See Also

Storage.storage_iter Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.storage_iter.currentperiod Field

name="currentperiod" Current period

[Visual Basic]
Public currentperiod As Long
[C#]
public long currentperiod;
[C++]
public: __int64 currentperiod;
[JScript]
public var currentperiod: long;

See Also

Storage.storage_iter Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.storage_iter.currentyear Field

name="currentyear" Current year

[Visual Basic]
Public currentyear As Long
[C#]
public long currentyear;
[C++]
public: __int64 currentyear;
[JScript]
public var currentyear: long;

See Also

Storage.storage_iter Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.storage_iter.delivered Field

name="delivered" Physical commodity volume delivered during current period or tenor.

[Visual Basic]
Public delivered As Double
[C#]
public double delivered;
[C++]
public: double delivered;
[JScript]
public var delivered: double;

See Also

Storage.storage_iter Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.storage_iter.gad Field

name="gad" Physical commodity volume available for delivery during current period or tenor.

[Visual Basic]
Public gad As Double
[C#]
public double gad;
[C++]
public: double gad;
[JScript]
public var gad: double;

See Also

Storage.storage_iter Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.storage_iter.gaddaily Field

name="gaddaily" Physical commodity volume being delivered during current period or tenor.

[Visual Basic]
Public gaddaily As Double
[C#]
public double gaddaily;
[C++]
public: double gaddaily;
[JScript]
public var gaddaily: double;

See Also

Storage.storage_iter Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.storage_iter.gadnext Field

name="gadnext" Physical commodity volume available for delivery during following period or tenor.

[Visual Basic]
Public gadnext As Double
[C#]
public double gadnext;
[C++]
public: double gadnext;
[JScript]
public var gadnext: double;

See Also

Storage.storage_iter Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.storage_iter.gig Field

name="gig" Physical commodity volume in inventory.

[Visual Basic]
Public gig As Double
[C#]
public double gig;
[C++]
public: double gig;
[JScript]
public var gig: double;

See Also

Storage.storage_iter Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.storage_iter.gigeom Field

name="gigeom" Physical commodity volume in inventory at the end of the current period or tenor.

[Visual Basic]
Public gigeom As Double
[C#]
public double gigeom;
[C++]
public: double gigeom;
[JScript]
public var gigeom: double;

See Also

Storage.storage_iter Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.storage_iter.position Field

name="position" Financial positionfor the period

[Visual Basic]
Public position As Double
[C#]
public double position;
[C++]
public: double position;
[JScript]
public var position: double;

See Also

Storage.storage_iter Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.trajectorycurve Structure

Structure: trajectorycurve structure for trajectory curve variables and arrays

For a list of all members of this type, see Storage.trajectorycurve Members.

System.Object
System.ValueType
CommodityStorage.Storage.Storage.trajectorycurve

[Visual Basic]
Public Structure Storage.trajectorycurve
[C#]
public struct Storage.trajectorycurve
[C++]
public __value struct Storage.trajectorycurve

[JScript] In JScript, you can use the structures defined by a type, but you cannot define your own.

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: CommodityStorage.Storage

Assembly: CommodityStorage (in CommodityStorage.dll)

See Also

Storage.trajectorycurve Members | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.trajectorycurve Members

Storage.trajectorycurve overview

Public Instance Fields

bidask | name="bidask" Bid - ask spread across all contract expirations array.
ContractDate | name="ContractDate" Contract dates array: used for determining transaction and settlement dates for contracts.
dealperiod | name="dealperiod" Deal period array for indexing deals that do not start on a calendar year, useful for structured products valuations and post processing.
discountfactor | name="discountfactor" Discount factors array
enddate | name="enddate" Last date of the storage contract.
exchangerate | name="exchangerate" Exchange rates array across all contract expirations array.
expirationdate | name="expirationdate" Expiration dates array: used for determining settlement and flow dates.
forward | name="forward" Forward curve.
indexprice | name="indexprice" Current index price: will be implemented for contracts that are settled against the monthly index.
Interest | name="Interest" Interest rate yield curve.
maturity | name="maturity" Maturity values array in percentage of years.
name | name="name" Contract names array across all contract expirations array.
period | name="period" Period array for indexing within deal periods since deals do not start on a calendar year, useful for structured products valuations and post processing.
Price | name="Price" Prices array across all contract expirations array.
seasoncounter | name="seasoncounter" Season counter array for indexing storage seasons since most commodities season do not follow a calendar year.
seasonnumber | name="seasonnumber" Season counter array for indexing within a storage since most commodities season do not follow a calendar year.

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

Storage.trajectorycurve Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.trajectorycurve Fields

The fields of the Storage.trajectorycurve structure are listed below. For a complete list of Storage.trajectorycurve structure members, see the Storage.trajectorycurve Members topic.

Public Instance Fields

bidask | name="bidask" Bid - ask spread across all contract expirations array.
ContractDate | name="ContractDate" Contract dates array: used for determining transaction and settlement dates for contracts.
dealperiod | name="dealperiod" Deal period array for indexing deals that do not start on a calendar year, useful for structured products valuations and post processing.
discountfactor | name="discountfactor" Discount factors array
enddate | name="enddate" Last date of the storage contract.
exchangerate | name="exchangerate" Exchange rates array across all contract expirations array.
expirationdate | name="expirationdate" Expiration dates array: used for determining settlement and flow dates.
forward | name="forward" Forward curve.
indexprice | name="indexprice" Current index price: will be implemented for contracts that are settled against the monthly index.
Interest | name="Interest" Interest rate yield curve.
maturity | name="maturity" Maturity values array in percentage of years.
name | name="name" Contract names array across all contract expirations array.
period | name="period" Period array for indexing within deal periods since deals do not start on a calendar year, useful for structured products valuations and post processing.
Price | name="Price" Prices array across all contract expirations array.
seasoncounter | name="seasoncounter" Season counter array for indexing storage seasons since most commodities season do not follow a calendar year.
seasonnumber | name="seasonnumber" Season counter array for indexing within a storage since most commodities season do not follow a calendar year.

See Also

Storage.trajectorycurve Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.trajectorycurve.bidask Field

name="bidask" Bid - ask spread across all contract expirations array.

[Visual Basic]
Public bidask As Double()
[C#]
public double[] bidask;
[C++]
public: double bidask __gc[];
[JScript]
public var bidask: double[];

See Also

Storage.trajectorycurve Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.trajectorycurve.ContractDate Field

name="ContractDate" Contract dates array: used for determining transaction and settlement dates for contracts.

[Visual Basic]
Public ContractDate As Date()
[C#]
public DateTime[] ContractDate;
[C++]
public: DateTime* ContractDate __gc[];
[JScript]
public var ContractDate: DateTime[];

See Also

Storage.trajectorycurve Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.trajectorycurve.dealperiod Field

name="dealperiod" Deal period array for indexing deals that do not start on a calendar year, useful for structured products valuations and post processing.

[Visual Basic]
Public dealperiod As Long()
[C#]
public long[] dealperiod;
[C++]
public: __int64 dealperiod __gc[];
[JScript]
public var dealperiod: long[];

See Also

Storage.trajectorycurve Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.trajectorycurve.discountfactor Field

name="discountfactor" Discount factors array

[Visual Basic]
Public discountfactor As Double()
[C#]
public double[] discountfactor;
[C++]
public: double discountfactor __gc[];
[JScript]
public var discountfactor: double[];

See Also

Storage.trajectorycurve Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.trajectorycurve.enddate Field

name="enddate" Last date of the storage contract.

[Visual Basic]
Public enddate As Date()
[C#]
public DateTime[] enddate;
[C++]
public: DateTime* enddate __gc[];
[JScript]
public var enddate: DateTime[];

See Also

Storage.trajectorycurve Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.trajectorycurve.exchangerate Field

name="exchangerate" Exchange rates array across all contract expirations array.

[Visual Basic]
Public exchangerate As Double()
[C#]
public double[] exchangerate;
[C++]
public: double exchangerate __gc[];
[JScript]
public var exchangerate: double[];

See Also

Storage.trajectorycurve Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.trajectorycurve.expirationdate Field

name="expirationdate" Expiration dates array: used for determining settlement and flow dates.

[Visual Basic]
Public expirationdate As Date()
[C#]
public DateTime[] expirationdate;
[C++]
public: DateTime* expirationdate __gc[];
[JScript]
public var expirationdate: DateTime[];

See Also

Storage.trajectorycurve Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.trajectorycurve.forward Field

name="forward" Forward curve.

[Visual Basic]
Public forward As Double()
[C#]
public double[] forward;
[C++]
public: double forward __gc[];
[JScript]
public var forward: double[];

See Also

Storage.trajectorycurve Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.trajectorycurve.indexprice Field

name="indexprice" Current index price: will be implemented for contracts that are settled against the monthly index.

[Visual Basic]
Public indexprice As Double
[C#]
public double indexprice;
[C++]
public: double indexprice;
[JScript]
public var indexprice: double;

See Also

Storage.trajectorycurve Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.trajectorycurve.Interest Field

name="Interest" Interest rate yield curve.

[Visual Basic]
Public Interest As Double()
[C#]
public double[] Interest;
[C++]
public: double Interest __gc[];
[JScript]
public var Interest: double[];

See Also

Storage.trajectorycurve Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.trajectorycurve.maturity Field

name="maturity" Maturity values array in percentage of years.

[Visual Basic]
Public maturity As Double()
[C#]
public double[] maturity;
[C++]
public: double maturity __gc[];
[JScript]
public var maturity: double[];

See Also

Storage.trajectorycurve Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.trajectorycurve.name Field

name="name" Contract names array across all contract expirations array.

[Visual Basic]
Public name As String()
[C#]
public string[] name;
[C++]
public: String* name __gc[];
[JScript]
public var name: String[];

See Also

Storage.trajectorycurve Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.trajectorycurve.period Field

name="period" Period array for indexing within deal periods since deals do not start on a calendar year, useful for structured products valuations and post processing.

[Visual Basic]
Public period As Long()
[C#]
public long[] period;
[C++]
public: __int64 period __gc[];
[JScript]
public var period: long[];

See Also

Storage.trajectorycurve Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.trajectorycurve.Price Field

name="Price" Prices array across all contract expirations array.

[Visual Basic]
Public Price As Double()
[C#]
public double[] Price;
[C++]
public: double Price __gc[];
[JScript]
public var Price: double[];

See Also

Storage.trajectorycurve Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.trajectorycurve.seasoncounter Field

name="seasoncounter" Season counter array for indexing storage seasons since most commodities season do not follow a calendar year.

[Visual Basic]
Public seasoncounter As Long()
[C#]
public long[] seasoncounter;
[C++]
public: __int64 seasoncounter __gc[];
[JScript]
public var seasoncounter: long[];

See Also

Storage.trajectorycurve Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.trajectorycurve.seasonnumber Field

name="seasonnumber" Season counter array for indexing within a storage since most commodities season do not follow a calendar year.

[Visual Basic]
Public seasonnumber As Long()
[C#]
public long[] seasonnumber;
[C++]
public: __int64 seasonnumber __gc[];
[JScript]
public var seasonnumber: long[];

See Also

Storage.trajectorycurve Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.value Structure

Structure: value structure for intrinsic, extrinsic and profit structures

For a list of all members of this type, see Storage.value Members.

System.Object
System.ValueType
CommodityStorage.Storage.Storage.value

[Visual Basic]
Public Structure Storage.value
[C#]
public struct Storage.value
[C++]
public __value struct Storage.value

[JScript] In JScript, you can use the structures defined by a type, but you cannot define your own.

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: CommodityStorage.Storage

Assembly: CommodityStorage (in CommodityStorage.dll)

See Also

Storage.value Members | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.value Members

Storage.value overview

Public Instance Fields

s_extrinsic | name="s_extrinsic" Extrinsic Value
s_intrinsic | name="s_intrinsic" Intrinsic Value
s_profit | name="s_profit" Profit array by trajetory and day

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

Storage.value Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.value Fields

The fields of the Storage.value structure are listed below. For a complete list of Storage.value structure members, see the Storage.value Members topic.

Public Instance Fields

s_extrinsic | name="s_extrinsic" Extrinsic Value
s_intrinsic | name="s_intrinsic" Intrinsic Value
s_profit | name="s_profit" Profit array by trajetory and day

See Also

Storage.value Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.value.s_extrinsic Field

name="s_extrinsic" Extrinsic Value

[Visual Basic]
Public s_extrinsic As extrinsic
[C#]
public extrinsic s_extrinsic;
[C++]
public: extrinsic s_extrinsic;
[JScript]
public var s_extrinsic: extrinsic;

See Also

Storage.value Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.value.s_intrinsic Field

name="s_intrinsic" Intrinsic Value

[Visual Basic]
Public s_intrinsic As Double
[C#]
public double s_intrinsic;
[C++]
public: double s_intrinsic;
[JScript]
public var s_intrinsic: double;

See Also

Storage.value Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.value.s_profit Field

name="s_profit" Profit array by trajetory and day

[Visual Basic]
Public s_profit As Profit(,)
[C#]
public Profit[,] s_profit;
[C++]
public: Profit* s_profit __gc[];
[JScript]
public var s_profit: Profit[,];

See Also

Storage.value Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.volumesummary Structure

Structure: volumesummary structure for results of physical volume transactions and statistics the summaries are by month and year

For a list of all members of this type, see Storage.volumesummary Members.

System.Object
System.ValueType
CommodityStorage.Storage.Storage.volumesummary

[Visual Basic]
Public Structure Storage.volumesummary
[C#]
public struct Storage.volumesummary
[C++]
public __value struct Storage.volumesummary

[JScript] In JScript, you can use the structures defined by a type, but you cannot define your own.

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: CommodityStorage.Storage

Assembly: CommodityStorage (in CommodityStorage.dll)

See Also

Storage.volumesummary Members | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.volumesummary Members

Storage.volumesummary overview

Public Instance Fields

bought | name="bought" Physical volumes bought summary array.
boughtcnt | name="boughtcnt" count of Physical volumes bought summary array.
delivered | name="delivered" Physical volumes bought summary array.
deliveredcnt | name="deliveredcnt" count of Physical volumes bought summary array.
Inventory | name="inventory" Physical volumes held in inventory during period summary array.
Inventorycnt | name="inventorycnt" count of Physical volumes held in inventory summary array.
month | name="month" Summary Month
sold | name="sold" Physical volumes bought summary array.
soldcnt | name="soldcnt" count of Physical volumes bought summary array.
year | name="year" Summary Year

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

Storage.volumesummary Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.volumesummary Fields

The fields of the Storage.volumesummary structure are listed below. For a complete list of Storage.volumesummary structure members, see the Storage.volumesummary Members topic.

Public Instance Fields

bought | name="bought" Physical volumes bought summary array.
boughtcnt | name="boughtcnt" count of Physical volumes bought summary array.
delivered | name="delivered" Physical volumes bought summary array.
deliveredcnt | name="deliveredcnt" count of Physical volumes bought summary array.
Inventory | name="inventory" Physical volumes held in inventory during period summary array.
Inventorycnt | name="inventorycnt" count of Physical volumes held in inventory summary array.
month | name="month" Summary Month
sold | name="sold" Physical volumes bought summary array.
soldcnt | name="soldcnt" count of Physical volumes bought summary array.
year | name="year" Summary Year

See Also

Storage.volumesummary Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.volumesummary.bought Field

name="bought" Physical volumes bought summary array.

[Visual Basic]
Public bought As Double()
[C#]
public double[] bought;
[C++]
public: double bought __gc[];
[JScript]
public var bought: double[];

See Also

Storage.volumesummary Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.volumesummary.boughtcnt Field

name="boughtcnt" count of Physical volumes bought summary array.

[Visual Basic]
Public boughtcnt As Double
[C#]
public double boughtcnt;
[C++]
public: double boughtcnt;
[JScript]
public var boughtcnt: double;

See Also

Storage.volumesummary Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.volumesummary.delivered Field

name="delivered" Physical volumes bought summary array.

[Visual Basic]
Public delivered As Double()
[C#]
public double[] delivered;
[C++]
public: double delivered __gc[];
[JScript]
public var delivered: double[];

See Also

Storage.volumesummary Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.volumesummary.deliveredcnt Field

name="deliveredcnt" count of Physical volumes bought summary array.

[Visual Basic]
Public deliveredcnt As Double
[C#]
public double deliveredcnt;
[C++]
public: double deliveredcnt;
[JScript]
public var deliveredcnt: double;

See Also

Storage.volumesummary Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.volumesummary.Inventory Field

name="inventory" Physical volumes held in inventory during period summary array.

[Visual Basic]
Public Inventory As Double()
[C#]
public double[] Inventory;
[C++]
public: double Inventory __gc[];
[JScript]
public var Inventory: double[];

See Also

Storage.volumesummary Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.volumesummary.Inventorycnt Field

name="inventorycnt" count of Physical volumes held in inventory summary array.

[Visual Basic]
Public Inventorycnt As Double
[C#]
public double Inventorycnt;
[C++]
public: double Inventorycnt;
[JScript]
public var Inventorycnt: double;

See Also

Storage.volumesummary Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.volumesummary.month Field

name="month" Summary Month

[Visual Basic]
Public month As Long
[C#]
public long month;
[C++]
public: __int64 month;
[JScript]
public var month: long;

See Also

Storage.volumesummary Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.volumesummary.sold Field

name="sold" Physical volumes bought summary array.

[Visual Basic]
Public sold As Double()
[C#]
public double[] sold;
[C++]
public: double sold __gc[];
[JScript]
public var sold: double[];

See Also

Storage.volumesummary Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.volumesummary.soldcnt Field

name="soldcnt" count of Physical volumes bought summary array.

[Visual Basic]
Public soldcnt As Double
[C#]
public double soldcnt;
[C++]
public: double soldcnt;
[JScript]
public var soldcnt: double;

See Also

Storage.volumesummary Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Storage.volumesummary.year Field

name="year" Summary Year

[Visual Basic]
Public year As Long
[C#]
public long year;
[C++]
public: __int64 year;
[JScript]
public var year: long;

See Also

Storage.volumesummary Structure | CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


Logging

An NDoc Documented Class Library

Logging Namespace

Namespace hierarchy

Classes

Class | Description
EventLogger |
FileLogger |

Interfaces

Interface | Description
ILog |

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


EventLogger Class

For a list of all members of this type, see EventLogger Members.

System.Object
Logging.EventLogger

[Visual Basic]
Public Class EventLogger
    Implements ILog
[C#]
public class EventLogger : ILog
[C++]
public __gc class EventLogger : public ILog
[JScript]
public class EventLogger extends ILog

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Logging

Assembly: Logging (in Logging.dll)

See Also

EventLogger Members | Logging Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


EventLogger Members

EventLogger overview

Private Static (Shared) Fields

DEFAULT_SOURCE
EVENT_LOG
INFO_LENGTH

Public Instance Constructors

EventLogger Constructor

Public Instance Properties

LogMinCharacters

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteLog |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Private Instance Fields

mLogMinCharacters
mSource

See Also

EventLogger Class | Logging Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


EventLogger Constructor

[Visual Basic]
Public Sub New( _
   ByVal source As String _
)
[C#]
public EventLogger(
   string source
);
[C++]
public: EventLogger(
   String* source
);
[JScript]
public function EventLogger(
   String source
);

See Also

EventLogger Class | Logging Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


EventLogger Fields

The fields of the EventLogger class are listed below. For a complete list of EventLogger class members, see the EventLogger Members topic.

Private Static (Shared) Fields

DEFAULT_SOURCE
EVENT_LOG
INFO_LENGTH

Private Instance Fields

mLogMinCharacters
mSource

See Also

EventLogger Class | Logging Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


EventLogger.DEFAULT_SOURCE Field

[Visual Basic]
Private const DEFAULT_SOURCE As String = "Custom Application"
[C#]
private const string DEFAULT_SOURCE = "Custom Application";
[C++]
private: const String* DEFAULT_SOURCE = "Custom Application";
[JScript]
private const var DEFAULT_SOURCE: String = "Custom Application";

See Also

EventLogger Class | Logging Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


EventLogger.EVENT_LOG Field

[Visual Basic]
Private const EVENT_LOG As String = "Application"
[C#]
private const string EVENT_LOG = "Application";
[C++]
private: const String* EVENT_LOG = "Application";
[JScript]
private const var EVENT_LOG: String = "Application";

See Also

EventLogger Class | Logging Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


EventLogger.INFO_LENGTH Field

[Visual Basic]
Private const INFO_LENGTH As Integer = 50
[C#]
private const int INFO_LENGTH = 50;
[C++]
private: const int INFO_LENGTH = 50;
[JScript]
private const var INFO_LENGTH: int = 50;

See Also

EventLogger Class | Logging Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


EventLogger.mLogMinCharacters Field

[Visual Basic]
Private mLogMinCharacters As Boolean
[C#]
private bool mLogMinCharacters;
[C++]
private: bool mLogMinCharacters;
[JScript]
private var mLogMinCharacters: bool;

See Also

EventLogger Class | Logging Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


EventLogger.mSource Field

[Visual Basic]
Private mSource As String
[C#]
private string mSource;
[C++]
private: String* mSource;
[JScript]
private var mSource: String;

See Also

EventLogger Class | Logging Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


EventLogger Properties

The properties of the EventLogger class are listed below. For a complete list of EventLogger class members, see the EventLogger Members topic.

Public Instance Properties

LogMinCharacters

See Also

EventLogger Class | Logging Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


LogMinCharacters Property

An NDoc Documented Class Library

EventLogger.LogMinCharacters Property

[Visual Basic]
Public Property LogMinCharacters As Boolean
[C#]
public bool LogMinCharacters { get; set; }
[C++]
public: __property bool get_LogMinCharacters();
public: __property void set_LogMinCharacters(bool );
[JScript]
public function get LogMinCharacters() : bool
public function set LogMinCharacters(bool);

See Also

EventLogger Class | Logging Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


EventLogger Methods

The methods of the EventLogger class are listed below. For a complete list of EventLogger class members, see the EventLogger Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteLog |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EventLogger Class | Logging Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


EventLogger.WriteLog Method

[Visual Basic]
Public Sub WriteLog( _
   ByVal info As String, _
   ByVal logType As EventLogEntryType _
) _
    Implements ILog.WriteLog
[C#]
public void WriteLog(
   string info,
   EventLogEntryType logType
);
[C++]
public: void WriteLog(
   String* info,
   EventLogEntryType logType
);
[JScript]
public function WriteLog(
   String info,
   EventLogEntryType logType
);

Implements

ILog.WriteLog

See Also

EventLogger Class | Logging Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


FileLogger Class

For a list of all members of this type, see FileLogger Members.

System.Object
Logging.FileLogger

[Visual Basic]
Public Class FileLogger
    Implements ILog
[C#]
public class FileLogger : ILog
[C++]
public __gc class FileLogger : public ILog
[JScript]
public class FileLogger extends ILog

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Logging

Assembly: Logging (in Logging.dll)

See Also

FileLogger Members | Logging Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


FileLogger Members

FileLogger overview

Private Static (Shared) Fields

DEFAULT_FILE_NAME
MAX_FILE_SIZE
MESSAGE_HEADER
MESSAGE_LENGTH
SEVERITY_HEADER

Public Instance Constructors

FileLogger Overloaded. Initializes a new instance of the FileLogger class.

Public Instance Properties

LogMinCharacters

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteLog |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Private Instance Fields

mFileName
mLogMinCharacters
mPath

Private Instance Methods

IsFileNameValid

See Also

FileLogger Class | Logging Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


FileLogger Constructor

Overload List

[Visual Basic] Public Sub New(ByVal String)
[C#] public FileLogger(string);
[C++] public: FileLogger(String*);
[JScript] public function FileLogger(String);

[Visual Basic] Public Sub New(ByVal String,ByVal String)
[C#] public FileLogger(string,string);
[C++] public: FileLogger(String*,String*);
[JScript] public function FileLogger(String,String);

See Also

FileLogger Class | Logging Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


FileLogger Constructor (String)

[Visual Basic]
Public Sub New( _
   ByVal fileName As String _
)
[C#]
public FileLogger(
   string fileName
);
[C++]
public: FileLogger(
   String* fileName
);
[JScript]
public function FileLogger(
   String fileName
);

See Also

FileLogger Class | Logging Namespace | FileLogger Constructor Overload List

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


FileLogger Constructor (String, String)

[Visual Basic]
Public Sub New( _
   ByVal fileName As String, _
   ByVal path As String _
)
[C#]
public FileLogger(
   string fileName,
   string path
);
[C++]
public: FileLogger(
   String* fileName,
   String* path
);
[JScript]
public function FileLogger(
   String fileName,
   String path
);

See Also

FileLogger Class | Logging Namespace | FileLogger Constructor Overload List

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


FileLogger Fields

The fields of the FileLogger class are listed below. For a complete list of FileLogger class members, see the FileLogger Members topic.

Private Static (Shared) Fields

DEFAULT_FILE_NAME
MAX_FILE_SIZE
MESSAGE_HEADER
MESSAGE_LENGTH
SEVERITY_HEADER

Private Instance Fields

mFileName
mLogMinCharacters
mPath

See Also

FileLogger Class | Logging Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


FileLogger.DEFAULT_FILE_NAME Field

[Visual Basic]
Private const DEFAULT_FILE_NAME As String = "Debug.txt"
[C#]
private const string DEFAULT_FILE_NAME = "Debug.txt";
[C++]
private: const String* DEFAULT_FILE_NAME = "Debug.txt";
[JScript]
private const var DEFAULT_FILE_NAME: String = "Debug.txt";

See Also

FileLogger Class | Logging Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


FileLogger.MAX_FILE_SIZE Field

[Visual Basic]
Private const MAX_FILE_SIZE As Long = 999999999999999
[C#]
private const long MAX_FILE_SIZE = 999999999999999;
[C++]
private: const __int64 MAX_FILE_SIZE = 999999999999999;
[JScript]
private const var MAX_FILE_SIZE: long = 999999999999999;

See Also

FileLogger Class | Logging Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


FileLogger.MESSAGE_HEADER Field

[Visual Basic]
Private const MESSAGE_HEADER As String = " MESSAGE: "
[C#]
private const string MESSAGE_HEADER = " MESSAGE: ";
[C++]
private: const String* MESSAGE_HEADER = " MESSAGE: ";
[JScript]
private const var MESSAGE_HEADER: String = " MESSAGE: ";

See Also

FileLogger Class | Logging Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


FileLogger.MESSAGE_LENGTH Field

[Visual Basic]
Private const MESSAGE_LENGTH As Integer = 10000
[C#]
private const int MESSAGE_LENGTH = 10000;
[C++]
private: const int MESSAGE_LENGTH = 10000;
[JScript]
private const var MESSAGE_LENGTH: int = 10000;

See Also

FileLogger Class | Logging Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


FileLogger.mFileName Field

[Visual Basic]
Private mFileName As String
[C#]
private string mFileName;
[C++]
private: String* mFileName;
[JScript]
private var mFileName: String;

See Also

FileLogger Class | Logging Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


FileLogger.mLogMinCharacters Field

[Visual Basic]
Private mLogMinCharacters As Boolean
[C#]
private bool mLogMinCharacters;
[C++]
private: bool mLogMinCharacters;
[JScript]
private var mLogMinCharacters: bool;

See Also

FileLogger Class | Logging Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


FileLogger.mPath Field

[Visual Basic]
Private mPath As String
[C#]
private string mPath;
[C++]
private: String* mPath;
[JScript]
private var mPath: String;

See Also

FileLogger Class | Logging Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


FileLogger.SEVERITY_HEADER Field

[Visual Basic]
Private const SEVERITY_HEADER As String = " SEVERITY: "
[C#]
private const string SEVERITY_HEADER = " SEVERITY: ";
[C++]
private: const String* SEVERITY_HEADER = " SEVERITY: ";
[JScript]
private const var SEVERITY_HEADER: String = " SEVERITY: ";

See Also

FileLogger Class | Logging Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


FileLogger Properties

The properties of the FileLogger class are listed below. For a complete list of FileLogger class members, see the FileLogger Members topic.

Public Instance Properties

LogMinCharacters

See Also

FileLogger Class | Logging Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


LogMinCharacters Property

An NDoc Documented Class Library

FileLogger.LogMinCharacters Property

[Visual Basic]
Public Property LogMinCharacters As Boolean
[C#]
public bool LogMinCharacters { get; set; }
[C++]
public: __property bool get_LogMinCharacters();
public: __property void set_LogMinCharacters(bool );
[JScript]
public function get LogMinCharacters() : bool
public function set LogMinCharacters(bool);

See Also

FileLogger Class | Logging Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


FileLogger Methods

The methods of the FileLogger class are listed below. For a complete list of FileLogger class members, see the FileLogger Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteLog |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Private Instance Methods

IsFileNameValid

See Also

FileLogger Class | Logging Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


FileLogger.IsFileNameValid Method

[Visual Basic]
Private Function IsFileNameValid( _
   ByVal filename As String _
) As Boolean
[C#]
private bool IsFileNameValid(
   string filename
);
[C++]
private: bool IsFileNameValid(
   String* filename
);
[JScript]
private function IsFileNameValid(
   String filename
): bool;

See Also

FileLogger Class | Logging Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


FileLogger.WriteLog Method

[Visual Basic]
Public Sub WriteLog( _
   ByVal message As String, _
   ByVal logType As EventLogEntryType _
) _
    Implements ILog.WriteLog
[C#]
public void WriteLog(
   string message,
   EventLogEntryType logType
);
[C++]
public: void WriteLog(
   String* message,
   EventLogEntryType logType
);
[JScript]
public function WriteLog(
   String message,
   EventLogEntryType logType
);

Implements

ILog.WriteLog

See Also

FileLogger Class | Logging Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


ILog Interface

For a list of all members of this type, see ILog Members.

[Visual Basic]
Friend Interface ILog
[C#]
internal interface ILog
[C++]
private __gc __interface ILog
[JScript]
internal interface ILog

Types that implement ILog

Type | Description
EventLogger |
FileLogger |

Requirements

Namespace: Logging

Assembly: Logging (in Logging.dll)

See Also

ILog Members | Logging Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


ILog Members

ILog overview

Public Instance Methods

WriteLog

See Also

ILog Interface | Logging Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


ILog Methods

The methods of the ILog interface are listed below. For a complete list of ILog interface members, see the ILog Members topic.

Public Instance Methods

WriteLog

See Also

ILog Interface | Logging Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


ILog.WriteLog Method

[Visual Basic]
Sub WriteLog( _
   ByVal strMsg As String, _
   ByVal eLogType As EventLogEntryType _
)
[C#]
void WriteLog(
   string strMsg,
   EventLogEntryType eLogType
);
[C++]
void WriteLog(
   String* strMsg,
   EventLogEntryType eLogType
);
[JScript]
function WriteLog(
   String strMsg,
   EventLogEntryType eLogType
);

See Also

ILog Interface | Logging Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


CommodityStorage.StorageHierarchy

An NDoc Documented Class Library

CommodityStorage.Storage Hierarchy

System.Object
CommodityStorage.Storage.Storage
System.ValueType
CommodityStorage.Storage.Storage.CostStruct
CommodityStorage.Storage.Storage.DateStruct
CommodityStorage.Storage.Storage.dynamic_vars
CommodityStorage.Storage.Storage.extrinsic
CommodityStorage.Storage.Storage.lincon
CommodityStorage.Storage.Storage.PrintFlagStruct
CommodityStorage.Storage.Storage.Profit
CommodityStorage.Storage.Storage.Ratchets
CommodityStorage.Storage.Storage.RiskAdjStruct
CommodityStorage.Storage.Storage.s_trajectory
CommodityStorage.Storage.Storage.simcurve
CommodityStorage.Storage.Storage.SS_inputs
CommodityStorage.Storage.Storage.ss_results
CommodityStorage.Storage.Storage.StaticVars
CommodityStorage.Storage.Storage.storage_iter
CommodityStorage.Storage.Storage.trajectorycurve
CommodityStorage.Storage.Storage.value
CommodityStorage.Storage.Storage.volumesummary

See Also

CommodityStorage.Storage Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net


LoggingHierarchy

An NDoc Documented Class Library

Logging Hierarchy

System.Object
Logging.EventLogger ---- Logging.ILog
Logging.FileLogger ---- Logging.ILog
Logging.ILog

See Also

Logging Namespace

Syntax based on .NET Framework version 1.1.

Send comments on this topic.

Copyright (C) 2004 Joe Wayne Byers Written by: Joe Wayne Byers, PhD Financial Systems & Economic Analytics, LTD. 3602 S 7t4th W. Ct. Tulsa, OK 74107 (918) 445-9224 financial.seal@cox.net Contribution accepted to facility program maintenance and enhancement. Send check or money orders to address above. This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Portions of code and binaries licensed under LGPL. These include LPSolve4 (http://groups.yahoo.com/group/lp_solve/) and Stochastix.net calendar class and its inheritants www.quantlib.net